[c-nsp] Basic QoS on ATM subinterfaces

Dave Weis djweis at internetsolver.com
Tue Nov 24 10:45:20 EST 2009


Tim Franklin wrote:
>> I've got a PA-A3-OC3 that is terminating a large number of PPPoA 
>> connections. I need to do basic QoS/prioritization for voice traffic.
>> I 
>> am using a subinterface per VPI with a vc-class to reference the 
>> virtual-template.
>>
>> I have set up a parent/child policy-map as the documentation suggested
>> but trying to apply it doesn't work:
>>
>> router(config)#int atm4/0
>> router(config-if)#service-policy output VOICE-PARENT
>>   GTS : Not supported on this interface
> 
> No, this won't work.  You've got several places you can apply the template:
> 
> -On the sub-interface
> -On the PVC, with the outer shaper removed
> -On the virtual-access (via the virtual-template)
> 
> If you're bulk-terminating a bunch of PPPoA sessions, I'd suggest that you want it applied to the virtual-access interface.  You can do this by either applying it to the virtual-template (if you're sure you always want the same policy for all the users), or push it back from RADIUS as a Cisco-avpair as each virtual-access interface is cloned.

OK, something like this:

class-map match-all EVERYTHING
  match access-group name EVERYTHING
class-map match-all IS-VOICE
  match access-group name IS-VOICE
!
!
policy-map IS-VOICE
  class IS-VOICE
   priority percent 75
   set dscp ef
  class EVERYTHING
   set dscp default

vc-class atm pppoa-1
   encapsulation aal5mux ppp Virtual-Template1

interface Virtual-Template1
  ip unnumbered Loopback0
  ip accounting output-packets
  no logging event link-status
  peer default ip address pool adsl1
  ppp authentication pap chap radius-ppp
  ppp authorization radius-ppp
  ppp link reorders
  ppp multilink
  ppp multilink fragment disable
  service-policy output IS-VOICE

ip access-list standard EVERYTHING
  permit any
!
ip access-list extended IS-VOICE
  permit ip 192.168.221.0 0.0.0.63 any

I have applied this configuration but the only interfaces that show up 
in show queueing are MLP bundles. The PVC's that show up after that 
section all list the queueing as FIFO still:

router#show queueing
Current fair queue configuration:

   Interface           Discard    Dynamic  Reserved  Link    Priority
                       threshold  queues   queues    queues  queues
   Virtual-Access180   64         256      256       8       1
   Virtual-Access207   64         256      256       8       1
   Virtual-Access450   64         256      256       8       1
   Virtual-Access541   64         256      256       8       1
   Virtual-Access573   64         256      256       8       1
   Virtual-Access574   64         256      256       8       1
   Virtual-Access575   64         256      256       8       1
   Virtual-Access595   64         256      256       8       1
   Virtual-Access597   64         256      256       8       1
   Virtual-Access599   64         256      256       8       1
   Virtual-Access640   64         256      256       8       1
   Virtual-Access651   64         256      256       8       1
   Virtual-Access654   64         256      256       8       1

Current DLCI priority queue configuration:
Current priority queue configuration:

List   Queue  Args
Current custom queue configuration:

VC 15/155 -
VC 15/155: Per VC queueing is FIFO.
VC 14/99 -
VC 14/99: Per VC queueing is FIFO.
VC 13/43 -
VC 13/43: Per VC queueing is FIFO.
VC 11/187 -
VC 11/187: Per VC queueing is FIFO.
VC 10/531 -
VC 10/531: Per VC queueing is FIFO.
VC 10/275 -
VC 10/275: Per VC queueing is FIFO.
VC 15/156 -
VC 15/156: Per VC queueing is FIFO.


Have I missed something else?

Thanks
dave




-- 
Dave Weis
515-224-9229
djweis at internetsolver.com
http://www.internetsolver.com/
Please check out our Complete Support Service
http://www.internetsolver.com/completesupport/


More information about the cisco-nsp mailing list