[c-nsp] ISIS Adj-filter problem
Victor Cappuccio
vcappucc at cisco.com
Tue Sep 8 08:56:49 EDT 2009
Hi,
Did you tried the same command but not on the DIS?? On a LAN, one of the
routers elects itself the DIS, based on interface priority (the default is
64). If all interface priorities are the same, the router with the highest
subnetwork point of attachment (SNPA) is selected
I did your same configuration, but now I applied the filter to all the
router but the DIS.
R2 in this case is the DIS!
R2#show run int f0/0
Building configuration...
Current configuration : 132 bytes
!
interface FastEthernet0/0
ip address 10.10.123.2 255.255.255.0
ip router isis
duplex auto
speed auto
isis priority 127
end
R2#show clns neigh
System Id Interface SNPA State Holdtime Type
Protocol
R3 Fa0/0 c003.163c.0000 Up 25 L1 IS-IS
R1 Fa0/0 c001.163c.0000 Up 29 L1 IS-IS
R2#show clns is-
System Id Interface State Type Priority Circuit Id Format
R3 Fa0/0 Up L1 64 R2.01 Phase V
R1 Fa0/0 Up L1 64 R2.01 Phase V
R2#
R2#show ip route isis
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
i L1 10.10.3.3/32 [115/10] via 10.10.123.3, FastEthernet0/0
i L1 10.10.1.1/32 [115/10] via 10.10.123.1, FastEthernet0/0
---
R1#show run int f0/0
Building configuration...
Current configuration : 140 bytes
!
interface FastEthernet0/0
ip address 10.10.123.1 255.255.255.0
ip router isis
duplex auto
speed auto
isis adjacency-filter R2
end
R1#show run | in clns filter
clns filter-set R2 permit 49.0001.0000.0000.0002.00
R1#show isis neigh
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa0/0 10.10.123.2 UP 9 R2.01
R1#show ip route isis
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 10.10.2.2/32 [115/10] via 10.10.123.2, FastEthernet0/0
R1#
----
R3#show run int f0/0
Building configuration...
Current configuration : 140 bytes
!
interface FastEthernet0/0
ip address 10.10.123.3 255.255.255.0
ip router isis
duplex auto
speed auto
isis adjacency-filter R2
end
R3#show run | in clns filter
clns filter-set R2 permit 49.0001.0000.0000.0002.00
R3#show clns neigh
System Id Interface SNPA State Holdtime Type
Protocol
R2 Fa0/0 c002.163c.0000 Up 7 L1 IS-IS
R3#
R3#show clns is-neighbors
System Id Interface State Type Priority Circuit Id Format
R2 Fa0/0 Up L1 127 R2.01 Phase V
R3#show ip route isis
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 10.10.2.2/32 [115/10] via 10.10.123.2, FastEthernet0/0
R3#
Thanks,
Victor Cappuccio.-
vcappucc at cisco.com
CCIE(R/S) #20657
STAC Support Engineer
Cisco Small Business Support.
-----Original Message-----
From: cisco-nsp-bounces at puck.nether.net
[mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Dave Kruger
Sent: martes, 08 de septiembre de 2009 15:04
To: Ibrahim Abo Zaid
Cc: cisco_nsp
Subject: Re: [c-nsp] ISIS Adj-filter problem
Hi there
have u managed to figure out what was causing that?
Did you see that your clns filter references
49.0001.0000.0000.0100.00
where as your R1 router's Sys ID is
49.0001.0000.0000.0001.00
Regards,
Dave
Ibrahim Abo Zaid wrote:
> Hi All
>
> I was testing ISIS Adj-filter option , R1,R2 and R3 are connected over
> ethernet switch (using dynamips) with the below configuration
>
> the configuration works for adj point and both R2 and R3 have ADJ with R1
> only , the problem is R2 is droping R1 and R3 LSPs and debug shows it is
> dropped due to invalid adj . can you help to resolve that ?
>
> Configuration
>
> R1
> interface Loopback0
> ip address 10.10.1.1 255.255.255.255
> !
> interface FastEthernet0/0
> ip address 10.10.123.1 255.255.255.0
> ip router isis
>
> router isis
> net
>
> is-type level-1
> passive-interface Loopback0
>
> R2
> interface Loopback0
> ip address 10.10.2.2 255.255.255.255
> !
> interface FastEthernet0/0
> ip address 10.10.123.2 255.255.255.0
> ip router isis
> isis adjacency-filter A1
> !
> router isis
> net 49.0001.0000.0000.0002.00
> is-type level-1
> passive-interface Loopback0
>
> clns filter-set A1 permit 49.0001.0000.0000.0100.00
>
> R3
>
> interface Loopback0
> ip address 10.10.3.3 255.255.255.255
> !
> interface FastEthernet0/0
> ip address 10.10.123.3 255.255.255.0
> ip router isis
> isis adjacency-filter A1
>
>
> router isis
> net 49.0001.0000.0000.0003.00
> is-type level-1
> passive-interface Loopback0
>
> clns filter-set A1 permit 49.0001.0000.0000.0100.00
>
>
> verification
>
>
> R1#sh clns neighbors
> System Id Interface SNPA State Holdtime Type
> Protocol
> R2 Fa0/0 c201.0544.0000 Up 8 L1 IS-IS
> R3 Fa0/0 c202.0544.0000 Up 7 L1 IS-IS
>
> R1 has R2 and R3 LSPs
>
> R1#sh isis database
> IS-IS Level-1 Link State Database:
> LSPID LSP Seq Num LSP Checksum LSP Holdtime
ATT/P/OL
> R1.00-00 * 0x00000010 0x2D88 849 0/0/0
> R2.00-00 0x00000009 0x8037 1036 0/0/0
> R2.01-00 0x00000003 0x78D8 1036 0/0/0
> R3.00-00 0x00000005 0x4470 552 0/0/0
> R3.01-00 0x00000006 0x78D3 1091 0/0/0
>
> but has R3-Lo0 route ONLY !!
>
> R1#sh ip route isis
> 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
> i L1 10.10.3.3/32 [115/10] via 10.10.123.3, FastEthernet0/0
>
> R2#sh clns neighbors
> System Id Interface SNPA State Holdtime Type
> Protocol
> R1 Fa0/0 c200.0544.0000 Up 21 L1 IS-IS
>
> R2 don't have R1 and R3 LSPs !!!
>
>
> R2#sh isis database
> IS-IS Level-1 Link State Database:
> LSPID LSP Seq Num LSP Checksum LSP Holdtime
ATT/P/OL
> R2.00-00 * 0x00000009 0x8037 985 0/0/0
> R2.01-00 * 0x00000003 0x78D8 986 0/0/0
>
> NO ISIS Route , it normal no LSP :)
> R2#sh ip route isis
> R2#
>
> R3
>
> R3#sh clns neighbors
> System Id Interface SNPA State Holdtime Type
> Protocol
> R1 Fa0/0 c200.0544.0000 Up 26 L1 IS-IS
>
> R3#sh isis database
> IS-IS Level-1 Link State Database:
> LSPID LSP Seq Num LSP Checksum LSP Holdtime
ATT/P/OL
> R1.00-00 0x00000013 0x278B 1181 0/0/0
> R2.00-00 0x00000009 0x8037 845 0/0/0
> R2.01-00 0x00000003 0x78D8 846 0/0/0
> R3.00-00 * 0x00000006 0x4271 1186 0/0/0
> R3.01-00 * 0x00000007 0x76D4 1185 0/0/0
>
> route to R1-Lo0 only !!
>
> R3#sh ip route isis
> 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
> i L1 10.10.1.1/32 [115/10] via 10.10.123.1, FastEthernet0/0
>
> debug isis update-packets shows update is dropped due to invalid ADJ
>
>
> *Mar 1 00:30:16.751: ISIS-Upd: Invalid adjacency
> *Mar 1 00:30:26.619: ISIS-Upd: Invalid adjacency
> *Mar 1 00:30:34.151: ISIS-Upd: Invalid adjacency
>
> any ideas
>
> best regards
> --Ibrahim
> _______________________________________________
> cisco-nsp mailing list cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
More information about the cisco-nsp
mailing list