[c-nsp] Router logs going to dmesg

Andy Saykao andy.saykao at staff.netspace.net.au
Mon Sep 21 01:44:12 EDT 2009

Hi All,
I'm trying to send cisco logs to a syslog server running Solaris 9. It's
logging fine except that I'm seeing some logs showing up in dmesg. 
Example of a dmesg outout:
Sep 21 13:44:16 [] 3297: Sep 21 13:44:15.981 AEST:
%LINK-3-UPDOWN: Interface GigabitEthernet0/45, changed state to down
Sep 21 13:44:21 [] 3298: Sep 21 13:44:20.956 AEST:
%LINK-3-UPDOWN: Interface GigabitEthernet0/45, changed state to up
Sep 21 13:48:38 agr1-cr-loopback-0.x.x.x 315047: Sep 21 13:48:37.756
AEST: %SNMP-3-AUTHFAIL: Authentication failure for SNMP req from host

I've tried changing the facility to local0.info on the cisco devices but
still the same thing is happening. Is there a particular facility I
should be using so the logs don't appear in dmesg???
This was the only thing I could find on goggle about my problem but no
real solution.
This is my /etc/syslog.conf file.
# Log cisco routers
local0.info                                     /var/log/cisco.log

And my config on the routers.
logging facility local0
logging source-interface Loopback0
logging 210.15.210.x


This email and any files transmitted with it are confidential and intended
 solely for the use of the individual or entity to whom they are addressed. 
Please notify the sender immediately by email if you have received this 
email by mistake and delete this email from your system. Please note that
 any views or opinions presented in this email are solely those of the
 author and do not necessarily represent those of the organisation. 
Finally, the recipient should check this email and any attachments for 
the presence of viruses. The organisation accepts no liability for any 
damage caused by any virus transmitted by this email.

More information about the cisco-nsp mailing list