[c-nsp] Cisco L2tpv3

Anthony V. Daroqui adaroqui at coherecomm.com
Mon Jul 12 14:41:24 EDT 2010


Sorry to take so long for the the update. I can't believe the interfaces were shutdown... but over the weekend I retried it and had success in getting the setup exactly how we wanted, which was dot1q over the T1.

HQ-Switch#show run

vlan 1998
!
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1998
 switchport mode trunk
!
interface Vlan1998
 ip address 10.0.0.1 255.255.255.252
!
!
end  

-------------------

HQ-Router#show run
ip cef                                                                                                                                                                        
!                                                                                                                                                                              
                                                                                                                                                                                                                                                                                                                                                    
!                                                                                                                                                                              
l2tp-class l2class                                                                                                                                                            
!                                                                                                                                                                              
pseudowire-class pswire                                                                                                                                                        
 encapsulation l2tpv3                                                                                                                                                          
 protocol l2tpv3 l2class                                                                                                                                                      
 ip local interface Loopback0                                                                                                                                                  
!                                                                                                                                                                              
!                                                                                                                                                                              
interface Loopback0                                                                                                                                                            
 ip address 172.16.1.1 255.255.255.255                                                                                                                                        
!                                                                                                                                                                              
interface FastEthernet0/0                                                                                                                                                      
 no ip address                                                                                                                                                                
 duplex auto                                                                                                                                                                  
 speed auto                                                                                                                                                                    
!                                                                                                                                                                              
interface FastEthernet0/0.1998                                                                                                                                                
 encapsulation dot1Q 1998                                                                                                                                                      
 no cdp enable                                                                                                                                                                
 xconnect 172.16.2.2 100 pw-class pswire                                                                                                                                      
!                                                                                                                                                                              
interface FastEthernet0/1                                                                                                                                                      
 no ip address                                                                                                                                                                
 shutdown                                                                                                                                                                      
 duplex auto                                                                                                                                                                  
 speed auto                                                                                                                                                                    
!                                                                                                                                                                              
interface Serial0/0/0                                                                                                                                                          
 ip address 192.168.93.197 255.255.255.0                                                                                                                                        
 encapsulation ppp                                                                                                                                                            
 no cdp enable                                                                                                                                                                
!                                                                                                                                                                              

ip route 172.16.2.2 255.255.255.255 192.168.93.198                                                                                                                              
!                                                                                                                                                                              
end

-------------------

Client Router#show run                  
!
ip cef                                                                                                                                                                        
!                                                                                                                                                                              
!                                                                                                                                                                              
!                                                                                                                                                                              
!                                                                                                                                                                              
l2tp-class l2class                                                                                                                                                            
!                                                                                                                                                                              
!                                                                                                                                                                              
pseudowire-class pswire                                                                                                                                                        
 encapsulation l2tpv3                                                                                                                                                          
 protocol l2tpv3 l2class                                                                                                                                                      
 ip local interface Loopback0                                                                                                                                                  
!                                                                                                                                                                              
!                                                                                                                                                                              
!                                                                                                                                                                              
!                                                                                                                                                                              
interface Loopback0                                                                                                                                                            
 ip address 172.16.2.2 255.255.255.255                                                                                                                                        
!                                                                                                                                                                              
interface FastEthernet0/0                                                                                                                                                      
 no ip address                                                                                                                                                                
 duplex auto                                                                                                                                                                  
 speed auto                                                                                                                                                                    
!                                                                                                                                                                              
interface FastEthernet0/0.1998                                                                                                                                                
 encapsulation dot1Q 1998                                                                                                                                                      
 no cdp enable                                                                                                                                                                
 xconnect 172.16.1.1 100 pw-class pswire                                                                                                                                      
!                                                                                                                                                                              
interface FastEthernet0/1                                                                                                                                                      
 no ip address                                                                                                                                                                
 shutdown                                                                                                                                                                      
 duplex auto                                                                                                                                                                  
 speed auto                                                                                                                                                                    
!                                                                                                                                                                              
interface Serial0/0/0                                                                                                                                                          
 ip address 192.168.93.198 255.255.255.252                                                                                                                                      
 encapsulation ppp                                                                                                                                                            
 no cdp enable                                                                                                                                                                
!                                                                                                                                                                              

ip route 172.16.1.1 255.255.255.255 192.168.93.197                                                                                                                              
!                                                                                                                                                                              
end

--------------------

Client-Switch#show run
!
vlan 1998
!
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1998
 switchport mode trunk
!
!
interface Vlan1998
 ip address 10.0.0.2 255.255.255.252
!
!
end




----- Original Message -----
From: "Vincent C Jones" <v.jones at networkingunlimited.com>
To: "Anthony V. Daroqui" <adaroqui at coherecomm.com>
Cc: cisco-nsp at puck.nether.net
Sent: Monday, July 12, 2010 2:05:01 PM GMT -05:00 US/Canada Eastern
Subject: Re: [c-nsp] Cisco L2tpv3

According to your "show run" all interfaces on the router are in
shutdown state, so nothing is going to work. One you have interfaces up,
you also need to have working routes at each end to the IP address of
the pseudowire endpoint at the other end.

-- 
Vincent C. Jones
Networking Unlimited, Inc.
Phone: +1 201 568-7810
V.Jones at NetworkingUnlimited.com


On Fri, 2010-07-09 at 12:54 -0700, Anthony V. Daroqui wrote:
> Hi, I am currently trying to provide one of our clients a vlan over a PPP link as per their request of only a layer 2 connection.
> The connection would be like 3750g <--> 7200 <--> 1841 where the 7200 and 1841 is a ppp link. In doing some research, we found L2TPv3 to be a viable option. However, I am having trouble keeping the tunnel up and sending traffic over it.
> 
> At the moment I am trying to configure only a simple layer 2 tunnel on test devices: 2 1841 routers, Version 12.4(15)T12, Advanced Services.
> 
> I am currently using these 2 sites as reference: http://prakashkalsaria.wordpress.com/2010/05/11/l2tpv3-over-hdlc-l2tpv3-over-ppp/, http://www.informit.com/library/content.aspx?b=Troubleshooting_VPNs&seqNum=44
> 
> On the other hand I was  also recently informed that there may be too much overhead in a layer 2 tunnel.  If that is the case, what is the more viable option for this setup?
> 
> I have attached the debug output from the tunnels as well. Any assistance would be appreciated.
> 
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/


More information about the cisco-nsp mailing list