[c-nsp] IP issues with 3560

Sophan Pheng sophan.p at altatechnologies.com
Tue Jun 29 17:13:57 EDT 2010


I finally got it figured out, that last email was a huge help, thank you! I set the ports to their specified vlans, then set each vlan to an IP on the specific segments, and turned on ip routing. My config is below:

User Access Verification

Password:
Switch>en
Password:
Switch#show running-config
Building configuration...

Current configuration : 1424 bytes
!
! Last configuration change at 15:31:03 UTC Tue Jun 29 2010
! NVRAM config last updated at 15:06:01 UTC Tue Jun 29 2010
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$..CG$YmuMsiC/CHmZssdOlyUcA1
!
no aaa new-model
clock timezone UTC -6
clock summer-time UTC recurring
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport access vlan 2
!
interface FastEthernet0/3
 switchport access vlan 2
!
interface FastEthernet0/4
 switchport access vlan 3
!
interface FastEthernet0/5
 switchport access vlan 3
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface Vlan1
 ip address 10.0.0.2 255.255.255.0
!
interface Vlan2
 ip address 10.125.25.2 255.255.255.0
!
interface Vlan3
 ip address 10.125.19.6 255.255.255.0
!
ip default-gateway 10.0.0.1
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password xxxxx
 login
line vty 5 15
 password xxxxx
 login
!
End

We should be all set now, thank you all so much!!

-----Original Message-----
From: Charles Klement [mailto:cjk at klement.org] 
Sent: Tuesday, June 29, 2010 2:27 PM
To: Sophan Pheng
Subject: Re: [c-nsp] IP issues with 3560

I see in your config that you have defined layer3 vlan interfaces. You
need to make sure that the layer 2 vlans are also defined. You can
typically do this by typing in 'vlan 2' and then 'vlan 3' etc when in
global config mode. Note, that there is no 'int' infront of those
previous 2 commands. If you have already defined the vlan instances
you can skip this step.

Next you need to decide which vlan you want your ports in.

Right now all your ports are in vlan 1. You need to go into each port
and use the command 'switchport access vlan 3' if you want that port
in vlan 3. If you want to, you can also define a range of ports by
typing in 'int range fa0/1-10' and then use 'switchport access vlan 2'
if you wanted those 10 ports associated with vlan 2

Good luck.

On 6/29/10, Sophan Pheng <sophan.p at altatechnologies.com> wrote:
> Still having issues, although I tried to follow your suggestions. Here is my
> config, can you tell me if im heading in the right direction? I think im
> confused on the SVI portion, each time I try to set an IP to the port
> interface, it tells me it overlaps with the vlan IP.
>
> Current configuration : 1342 bytes
> !
> ! Last configuration change at 11:39:08 UTC Tue Jun 29 2010
> ! NVRAM config last updated at 10:16:01 UTC Tue Jun 29 2010
> !
> version 12.2
> no service pad
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname Switch
> !
> boot-start-marker
> boot-end-marker
> !
> enable secret 5 $1$1it3$ZLsZBGgPum27PkZz7KXV9/
> !
> no aaa new-model
> clock timezone UTC -6
> clock summer-time UTC recurring
> system mtu routing 1500
> ip subnet-zero
> ip routing
> !
> !
> !
> !
> !
> !
> !
> !
> spanning-tree mode pvst
> spanning-tree extend system-id
> !
> vlan internal allocation policy ascending
> !
> !
> !
> interface FastEthernet0/1
> !
> interface FastEthernet0/2
>  ip access-group 1 in
> !
> interface FastEthernet0/3
> !
> interface FastEthernet0/4
> !
> interface FastEthernet0/5
> !
> interface FastEthernet0/6
> !
> interface FastEthernet0/7
> !
> interface FastEthernet0/8
> !
> interface FastEthernet0/9
> !
> interface FastEthernet0/10
> !
> interface FastEthernet0/11
> !
> interface FastEthernet0/12
> !
> interface GigabitEthernet0/1
> !
> interface Vlan1
>  ip address 10.0.0.2 255.255.255.0
> !
> interface Vlan2
>  ip address 10.125.25.4 255.255.255.0
> !
> interface Vlan3
>  ip address 10.125.19.5 255.255.255.0
> !
> ip default-gateway 10.0.0.1
> ip classless
> ip http server
> !
> !
> control-plane
> !
> !
> line con 0
> line vty 0 4
>  password xxxxxx
>  login
> line vty 5 15
>  password xxxxxxx
>  login
> !
> end
>
> Switch#
> Switch#
> Switch#
>
> Thanks again for the help guys!!
>
> -----Original Message-----
> From: Andy Koch [mailto:gawul00 at gmail.com]
> Sent: Monday, June 28, 2010 8:40 PM
> To: Sophan Pheng
> Subject: Re: [c-nsp] IP issues with 3560
>
> On Mon, Jun 28, 2010 at 11:36, Sophan Pheng
> <sophan.p at altatechnologies.com> wrote:
>> Hello All,
>>
>> I have not dealt with this before so any help/comments would be great and
>> much appreciated...
>>
>> We have the following IP's that need to be able to ping each other through
>> this box. I have a server sitting at 10.125.25.5/255.255.0.0 that connects
>> to the rest of the network via a microwave link. It connects to the
>> 10.125.19.x segment to upload data to an archiving server. I need to be
>> able to ping 25.2 from 19.x and vice versa.
>
>
> Please double check your subnet mask.  255.255.0.0 would place both
> 10.125.25.5 and 10.125.19.x in the same subnet.  If you separated the
> hosts on different VLANs, then the switch, even if configured for
> routing, would not route such packets.
>
>
>
>> Can you please give some assistance as to how I can accomplish this? So
>> far I have only been able to get the 25.5 to ping the Vlan it is connected
>> to, but not anything on the other side (19.x) even with IP Routing
>> enabled. Currently, I have reset it to factory to start from scratch.
>>
>> Can anybody suggest what the problem could be?
>
> Also check your SVI interfaces on the switch.  Each VLAN should have
> its own SVI interface with an IP in the corresponding segment. From
> there, ensure IP routing is enabled and the switch should then route
> packets from one VLAN to the other.
>
>> Thanks in advance!!
>>
>> Sophan
>
> Good Luck.
>
> Andy
> gawul00 at gmail.com
>
>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>




More information about the cisco-nsp mailing list