[c-nsp] simple bandwidth throttle recepies?

Alan Buxey A.L.M.Buxey at lboro.ac.uk
Fri Mar 12 15:20:22 EST 2010


Hi,

>     I don't care to try and do any traffic classification, I really just 
> want to say that port fa0/15 should have 2mbps up/down and that's it. 
> Even better would be limiting the rates asymmetrical and in less than 
> 1mbps increments but I don't know what's available. I do want 'cheap' 
> however and anything on the refurb market/ebay and with copper 
> 10/100mbps ports that can do this would be preferable. So I guess I am 
> looking for both a specfic hardware reccomendation as well as a sample 
> qos receipe that would demonstrate to acheive this on said hardware.

decent Cisco switches can do this...cheaper ones though....hmmm.

something nasty like


class-map match-all 1mbit
  match access-group 199
!
!
policy-map 1mbit
  class 1mbit
    set ip dscp 8
    police 1000000 8192 exceed-action dscp 8

access-list 199 permit ip any any


interface FastEthernet0/X
 description 1mbit rate limited port
 switchport access vlan 666
 switchport mode access
 switchport nonegotiate
 service-policy input 1mbit
 ip access-group USER in
 no cdp enable
 no keepalive
 spanning-tree portfast
 spanning-tree bpdufilter enable

ip access-list standard USER
 permit 111.222.111.222


thats 1mbit rate-limit on a port that the user will connect to at 100mbit...and
just for fun, they'll only be able to have the address 111.222.111.222 on that
port (to stop them grabbing some other address...) - ideal if they are providing
eg a router/NAT box for their network as service facing provision.

should work on plenty of lower-end switches. YMMV.

alan


More information about the cisco-nsp mailing list