[c-nsp] Redistributing certain BGP routes into OSPF

Christopher J. Wargaski wargo1 at gmail.com
Wed Apr 27 23:18:07 EDT 2011


Folks--

   Thank you for your responses. I gave this a try but it did not work out.

interface Loopback0
 description Local Loopback Interface
 ip address 192.168.254.2 255.255.255.255
end

interface FastEthernet0/0
 description Connected to Indianapolis LAN
 ip address 10.2.1.1 255.255.248.0
 no ip redirects
 ip directed-broadcast
 ip virtual-reassembly
end

router ospf 10
 router-id 192.168.254.2
 log-adjacency-changes
 redistribute bgp 65001 subnets route-map BGP-to-OSPF
 passive-interface FastEthernet0/1
 passive-interface Serial0/0/0
 passive-interface Serial0/1/0
 network 10.2.0.0 0.0.7.255 area 0
 network 10.2.8.0 0.0.7.255 area 0
 network 192.168.0.0 0.0.0.255 area 0

route-map BGP-to-OSPF permit 10
 match ip address 10

route-map BGP-to-OSPF permit 20
set ip next-hop 192.168.254.2
match ip route-source 11

access-list 10 remark ACL for BGP route map
access-list 10 permit 10.0.0.0 0.7.255.255
access-list 10 permit 192.168.0.0 0.0.7.255

access-list 11 remark ACL for BGP route map
access-list 11 permit 10.0.22.50

--------------------------------------------------------------------

On the ASA:

router ospf 10
 router-id 10.2.1.3
 network 10.2.0.0 255.255.248.0 area 0
 log-adj-changes

route inside 192.168.254.2 255.255.255.255 10.2.1.1 1

--------------------------------------------------------------------

I redistribute the BGP into OSPF and this is what I see on the ASA and
voila:

Indianapolis-ASA# sh route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 12.165.244.145 to network 0.0.0.0

O E2 100.128.0.0 255.255.0.0 [110/1] via 10.2.1.1, 0:01:49, inside
O E2 192.168.8.0 255.255.255.0 [110/1] via 10.2.1.1, 47:13:17, inside
O E2 162.111.213.16 255.255.255.240 [110/1] via 10.2.1.1, 0:01:49, inside
O E2 162.111.221.0 255.255.255.240 [110/1] via 10.2.1.1, 0:01:49, inside

---------------------------

   Any thoughts on whether this is a limitation of OSPF? I have know that it
is fairly picky about secondary subnets and such. Perhaps this is one of
those limitations. Since I am running 7.2 on the ASA, my only other dynamic
routing protocol choice is RIP. :-(  I know that I could gain EIGRP in 8.X,
but I think I would have a hard time convincing the management to allow me
to upgrade a production device for testing.


cjw


On Wed, Apr 27, 2011 at 7:28 PM, Eshan Bhide <eshanbhide at gmail.com> wrote:

> As Randy mentioned "set ip next-hop" for far end router (which really, is
> not really a BGP neighbour) is not supported. You could have a loopback on
> the Indy-Rtr, route map with next-hop as the loopback and then static route
> on the ASA for the said loopback and that would work
>
>


More information about the cisco-nsp mailing list