[c-nsp] QoS: Shaping and Queueing on different Levels (physical IF, sub IF)

Hendrik Kahmann hendrik at kahmann.net
Thu Aug 25 06:06:40 EDT 2011


Hello!

I am just working on a QoS configuration on Cisco 19xx and 29xx and could
need some help.


What I want to do:

1. I have got a configuration with up to six VRF-instances per router and
for each of this there is a vlan-subinterface unter gi0/0.

2. I want to shape all the traffic on gi0/0 to some bandwidth (i.e.
10mbit/s).

3. I want to prioritize voice-, best-effort and interactive traffic for all
the traffic leaving on gi0/0.


Base configuration:

class-map match-any traffic-high
 match dscp cs3
!
class-map match-any traffic-voice
 match dscp cs5
! 
policy-map my-queuing 
class class-default
   	bandwidth remaining percent 60
   	queue-limit 40
class traffic-high
   	bandwidth remaining percent 40
   	queue-limit 20
class traffic-voice
   	priority percent 40
!
interface GigabitEthernet0/0
 no ip address
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip vrf forwarding blue
 ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/0.200
 encapsulation dot1Q 200
 ip vrf forwarding yellow
 ip address 192.168.2.1 255.255.255.0
!


How can I achieve this? All the config I did until know was rejected by IOS
or not working as desired. Any hints or recommendations would be welcome!


Kind regards,

Hendrik





More information about the cisco-nsp mailing list