[c-nsp] IOS XR BGP error: parent address family not initialized

John Neiberger jneiberger at gmail.com
Fri Mar 11 12:09:30 EST 2011


I'm trying to configure multicast VPN extranet routing and I get the
following error when trying to commit my config:

router bgp 1
 vrf A
  address-family ipv4 unicast
!!% 'BGP' detected the 'warning' condition 'The parent address family
has not been initialized'
  !
 !
 vrf B
  address-family ipv4 unicast
!!% 'BGP' detected the 'warning' condition 'The parent address family
has not been initialized'
  !
 !
!
end


Here is the configuration I'm trying to commit, so far. I must be
missing something. I really, really new to IOS XR, so it's not clear
to me what I'm missing:

!! IOS XR Configuration 4.0.1
vrf A
 address-family ipv4 unicast
  export route-target
   1:100
  !
 !
!
vrf B
 address-family ipv4 unicast
  export route-target
   2:100
   no 2:200
  !
 !
!
interface Loopback99
 vrf B
 ipv4 address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 vrf A
 ipv4 address 10.10.10.1 255.255.255.252
 flow ipv4 monitor VDN2-NF-MONITOR sampler VDN2-NF-SAMPLER ingress
!
!
rd-set 1:100
end-set
!
rd-set 2:100
end-set
!
route-policy extranet_streams_from_vrf_A
  if destination in (239.0.0.0/32 ge 8 le 32) then
    set rpf-topology vrf A
  else
    pass
  endif
end-policy
!
router bgp 1
 address-family ipv4 unicast
 !
 vrf A
  rd 1:100
  address-family ipv4 unicast
   redistribute connected
  !
 !
 vrf B
  rd 2:100
  address-family ipv4 unicast
   redistribute connected
  !
 !
!
multicast-routing
 address-family ipv4
  nsf
  mdt source GigabitEthernet0/0/0/1
  interface all enable
 !
 vrf A
  address-family ipv4
   mdt data 239.0.0.0/8
   mdt default ipv4 239.99.99.99
  !
 !
 vrf B
  address-family ipv4
   mdt data 239.0.0.0/8
   mdt default ipv4 239.99.99.99
  !
 !
!
router igmp
 interface Loopback99
  version 3
  join-group 239.133.110.1 172.22.83.70
 !
!
router pim
 vrf B
  address-family ipv4
   rpf topology route-policy extranet_streams_from_vrf_A
  !
 !
!
end


More information about the cisco-nsp mailing list