[c-nsp] IGMP disabled in VRFs on ASR9K

John Neiberger jneiberger at gmail.com
Fri Mar 11 16:44:13 EST 2011


I'm still in the middle of trying to get Multicast VPN Extranet
Routing to work and I've run into a weird problem. For testing, I have
a multicast source and a multicast receiver attached to the router.
When they're in the default VRF, the output of "show igmp interface"
shows that IGMP is enabled on those interfaces, as expected. When I
move them both into a different VRF, IGMP is disabled and I can't
figure out how to enable it. I even tried enabling PIM on g0/4/0/2 to
see if that would enable IGMP, but it still says it's disabled. Here's
my IGMP config:


router igmp
 vrf A
  interface Loopback98
   join-group 239.133.110.1 172.22.83.70
  !
  interface GigabitEthernet0/4/0/1
   version 3
  !
 !
 vrf B
  interface Loopback99
   join-group 239.133.110.1 172.22.83.70
  !
  interface GigabitEthernet0/0/0/3
   version 3
  !
  interface GigabitEthernet0/4/0/2
   version 3
  !
 !
!

But I still see this:


RP/0/RSP0/CPU0:lab-gw2#show igmp vrf A int
Fri Mar 11 21:37:36.335 UTC

Loopback98 is up, line protocol is up
  Internet address is 192.168.3.1/24
  IGMP is disabled on interface
GigabitEthernet0/4/0/1 is up, line protocol is up
  Internet address is 10.10.10.1/30
  IGMP is disabled on interface
RP/0/RSP0/CPU0:lab-gw2#show igmp vrf B int
Fri Mar 11 21:37:43.752 UTC

Loopback99 is up, line protocol is up
  Internet address is 192.168.1.1/24
  IGMP is disabled on interface
GigabitEthernet0/4/0/2 is up, line protocol is up
  Internet address is 172.22.148.17/27
  IGMP is disabled on interface
RP/0/RSP0/CPU0:lab-gw2#


What in the world is going on? Here is the rest of my config just in
case anyone spots anything wrong. I think we're tantalizing close to
getting this to work and it's really bugging me that I haven't been
able to figure it out.  lol

RP/0/RSP0/CPU0:lab-gw2#show run
Fri Mar 11 21:38:45.265 UTC
Building configuration...
!! IOS XR Configuration 4.0.1
!! Last configuration change at Fri Mar 11 21:19:28 2011 by root
!
hostname lab-gw2
logging buffered 500000
telnet vrf default ipv4 server max-servers 5
domain name lab.priv
vrf A
 address-family ipv4 unicast
  export route-target
   1:100
  !
 !
!
vrf B
 address-family ipv4 unicast
  import route-target
   1:100
  !
 !
!
ipv4 access-list TSTM
 10 remark VDN2 SSM address blocks
 20 permit ipv4 any 237.0.0.0 0.255.255.255
 30 permit ipv4 any 239.0.0.0 0.255.255.255
!
!
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface Loopback98
 vrf A
 ipv4 address 192.168.3.1 255.255.255.0
!
interface Loopback99
 vrf B
 ipv4 address 192.168.1.1 255.255.255.0
!
!
interface GigabitEthernet0/4/0/0
 ipv4 address 10.1.1.1 255.255.255.252
!
interface GigabitEthernet0/4/0/1
 vrf A
 ipv4 address 10.10.10.1 255.255.255.252
 flow ipv4 monitor VDN2-NF-MONITOR sampler VDN2-NF-SAMPLER ingress
!
interface GigabitEthernet0/4/0/2
 vrf B
 ipv4 address 172.22.148.17 255.255.255.224
!
!
rd-set 1:100
end-set
!
rd-set 2:100
end-set
!
route-policy extranet_streams_from_vrf_A
  if destination in (239.0.0.0/8 ge 8 le 32) then
    set rpf-topology vrf A
  else
    pass
  endif
end-policy
!
router static
 address-family ipv4 unicast
  10.31.0.0/16 172.26.0.1
 !
 vrf A
  address-family ipv4 unicast
   172.22.83.70/32 10.10.10.2
  !
 !
!
router isis TESTLAB
 net 49.0001.2222.0000.2222.00
 address-family ipv4 unicast
  metric-style wide
 !
 interface Loopback0
  passive
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/4/0/1
  address-family ipv4 unicast
  !
 !
 interface TenGigE0/3/0/0
  address-family ipv4 unicast
  !
 !
!
router bgp 1
 address-family ipv4 unicast
 !
 address-family vpnv4 unicast
 !
 vrf A
  rd 1:100
  address-family ipv4 unicast
   redistribute connected
   redistribute static metric 100
  !
 !
 vrf B
  rd 2:100
  address-family ipv4 unicast
   redistribute connected
  !
 !
!
multicast-routing
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   enable
  !
  nsf
  mdt source GigabitEthernet0/0/0/1
  ssm range TSTM
  interface all enable
 !
 vrf A
  address-family ipv4
   mdt source Loopback98
   mdt data 239.0.0.0/8
   mdt default ipv4 239.99.99.99
   ssm range TSTM
  !
 !
 vrf B
  address-family ipv4
   mdt source Loopback99
   mdt data 239.0.0.0/8
   mdt default ipv4 239.99.99.99
   ssm range TSTM
  !
 !
!
router igmp
 vrf A
  interface Loopback98
   join-group 239.133.110.1 172.22.83.70
  !
  interface GigabitEthernet0/4/0/1
   version 3
  !
 !
 vrf B
  interface Loopback99
   join-group 239.133.110.1 172.22.83.70
  !
  interface GigabitEthernet0/0/0/3
   version 3
  !
  interface GigabitEthernet0/4/0/2
   version 3
  !
 !
!
ssh server v2
router pim
 vrf B
  address-family ipv4
   rpf topology route-policy extranet_streams_from_vrf_A
   interface GigabitEthernet0/4/0/2
    enable
   !
  !
 !
!
end

RP/0/RSP0/CPU0:lab-gw2#


More information about the cisco-nsp mailing list