[c-nsp] Internet BGP autofailover
alex nyagah
alex.nyagah.k at gmail.com
Mon Feb 13 04:53:45 EST 2012
Hi Group,
I have the following configs in my router but auto failover between two ISP
is not working, can someone please help..
interface GigabitEthernet0/1
description Link to ISP_A
ip address 10.10.10.205 255.255.255.252
ip accounting output-packets
ip flow ingress
ip nbar protocol-discovery
duplex auto
speed auto
no negotiation auto
!
interface GigabitEthernet0/2
description Connection to ISP_2
ip address 20.20.20.34 255.255.255.252
ip accounting output-packets
ip flow ingress
ip nbar protocol-discovery
load-interval 30
duplex auto
speed auto
no negotiation auto
!
interface GigabitEthernet0/3
description Connection to WALTER LAN
ip address 10.20.30.254 255.255.255.0
ip tcp adjust-mss 1420
duplex auto
speed auto
no negotiation auto
!
router bgp 6450
bgp log-neighbor-changes
neighbor 20.20.20.33 remote-as 31177
neighbor 20.20.20.33 description ISP_A-BGP
neighbor 20.20.20.33 ebgp-multihop 8
neighbor 20.20.20.33 update-source GigabitEthernet0/2
neighbor 10.10.10.206 remote-as 9010
neighbor 10.10.10.206 description ISP_A-Ke-eBGP
neighbor 10.10.10.206 update-source GigabitEthernet0/1
maximum-paths 2
!
address-family ipv4
neighbor 20.20.20.33 activate
neighbor 20.20.20.33 weight 1000
neighbor 20.20.20.33 prefix-list WALTER-SUBNET out
neighbor 20.20.20.33 route-map ISP_B_IMPORT in
neighbor 10.10.10.206 activate
neighbor 10.10.10.206 weight 100
neighbor 10.10.10.206 prefix-list WALTER-SUBNET out
neighbor 10.10.10.206 route-map prepending in
maximum-paths 2
no auto-summary
no synchronization
network 10.20.30.0 mask 255.255.255.0
exit-address-family
!
ip route 10.20.30.0 255.255.255.0 Null0 254 name BGP-Advertisement
ip flow-export source GigabitEthernet0/1
ip flow-export version 5 origin-as
!
no ip http server
!
!
!
ip prefix-list DEFAULT seq 10 permit 0.0.0.0/0
!
ip prefix-list WALTER-SUBNET seq 5 permit 10.20.30.0/24
ip prefix-list WALTER-SUBNET seq 10 deny 0.0.0.0/0 le 32
!
route-map ISP_B_IMPORT permit 10
match ip address prefix-list DEFAULT
!
route-map prepending permit 10
match ip address prefix-list DEFAULT
--
**
More information about the cisco-nsp
mailing list