[c-nsp] ASR9K IRB/BVI on MOD80 LC

Claes Jansson claes at gastabud.com
Wed Sep 26 08:09:34 EDT 2012


Well, what I'm trying to do is to route multicast traffic coming from an 
upstream iptv supplier.

And i might be doing something very wrong here, this is my first time 
configuring an ASR9k :-)

In short, recieve it on bvi400 (the peering interface gi0/0/0/9 
l2transport connected to a l2vpn IPTV1:uplink ) and route it out to STBs 
on BVI11 (IPTV1:vlan11)

AFAIK, the upstream has configured PIM-DM and all groups are flooded to 
us (see counters on gi0/0/0/9). I know this might be an issue so i tried 
to configure two static groups, but no difference what i can se. Althoug 
i could not see all groups even on the ME3600X. It seemed that the 
groups were joined "on demand" when requested by STBs.


On 2012-09-26 09:21, Oliver Boehmer (oboehmer) wrote:
> Claes,
>
>> Does anyone have a clue about the state of IRB/BVI on MOD80 (Typhoon)
>> linecard? It's not listed as supported in the release notes (4.2.1), but
>> ipv4 unicast seems to be working just fine, but not multicast as far as
>> i have tried. Have someone else tested this?
> Hmm, it should work, I have this running in a customer network on both
> Trident and Typhoon LCs.. Including multicast (edge/receiver facing
> deployment). did you enable igmp snooping in the l2vpn bridge-domain?
Yes, as far as i understand the snooping profile is applied to the 
bridge domains. One for the uplink-port and one for the "clients" in the 
bridge-domain. See config below..
>
>> And if i can't get BVI's to work, my only other option is to use a
>> "loop" cable between two ports, one that has l3 subinterfaces on one
>> side, and the other l2transport subinterfaces connected to the l2vpn
>> bridge-domains?
> well, that's always an "option" :-|
:-)
>
> 	oli
>
>
>


I got it to work on a ME3600X with the following config

#
# ME3600X config
#
interface GigabitEthernet0/1
  description IPTV1_EXT
  no switchport
  ip address 192.168.66.24 255.255.255.0
  ip access-group IPTV1_out out
  ip pim neighbor-filter 11
  ip pim bsr-border
  ip pim dense-mode
  load-interval 30
  spanning-tree portfast
  service-policy output IPTV1_out
!
int vlan11
  ip address 10.4.34.1 255.255.255.0
  ip pim sparse-mode
!


#
# Config from ASR9K-02
#
!
  interface BVI11
  vrf IPTV1
  ipv4 mtu 1500
  ipv4 address 10.4.33.1 255.255.255.0
  load-interval 30
!
interface BVI400
  vrf IPTV1
  ipv4 mtu 1500
  ipv4 address 192.168.66.24 255.255.255.0
  ipv4 access-group IPTV1_in ingress hardware-count interface-statistics
  ipv4 access-group IPTV1_out egress hardware-count interface-statistics
!
interface GigabitEthernet0/0/0/9
  description EXT_IPTV1
  negotiation auto
  l2transport
  !
!
vrf IPTV1
  address-family ipv4 unicast
  !
!
l2vpn
  bridge group IPTV1
   bridge-domain uplink
    interface GigabitEthernet0/0/0/9
     igmp snooping profile uplink_port
    !
    routed interface BVI400
   !
   bridge-domain vlan11
    dhcp ipv4 snoop profile trust
    igmp snooping profile client
    interface TenGigE0/0/1/0.11
     description Access-switch with an STB connected
     dhcp ipv4 snoop profile snoop_untrust
    !
    vfi IPTV1
     neighbor 1.1.1.1 pw-id 11
     !
    !
    routed interface BVI11
   !
  !
!

router igmp
  vrf IPTV1
   interface BVI11
    router enable
   !
   interface BVI400
    static-group 239.251.255.250 inc-mask 0.0.0.1 count 2 192.168.72.68
    router enable
   !
   version 2
  !
!

igmp snooping profile client
!
igmp snooping profile uplink_port
  mrouter
!
router pim
  vrf IPTV1
   address-family ipv4
    rp-address 192.168.66.252
    rp-address 192.168.66.254
    interface BVI11
     enable
    !
    interface BVI400
     bsr-border
     enable
     neighbor-filter IPTV1_pim
    !
   !
  !
!
multicast-routing
  address-family ipv4
   nsf
   mdt source Loopback0
   interface all enable
  !
  vrf IPTV1
   address-family ipv4
    interface BVI11
     enable
    !
    interface BVI400
     enable
     boundary IPTV1_groups
    !
    rate-per-route
    interface all enable
    accounting per-prefix forward-only
   !
  !
!

#
# Some show commands...
#

RP/0/RSP0/CPU0:ASR9K-02#sh pim vrf IPTV1 topology
Wed Sep 26 11:41:41.871 UTC

IP PIM Multicast Topology Table
Entry state: (*/S,G)[RPT/SPT] Protocol Uptime Info
Entry flags: KAT - Keep Alive Timer, AA - Assume Alive, PA - Probe Alive
     RA - Really Alive, IA - Inherit Alive, LH - Last Hop
     DSS - Don't Signal Sources,  RR - Register Received
     SR - Sending Registers, E - MSDP External, EX - Extranet
     DCC - Don't Check Connected, ME - MDT Encap, MD - MDT Decap
     MT - Crossed Data MDT threshold, MA - Data MDT group assigned
Interface state: Name, Uptime, Fwd, Info
Interface flags: LI - Local Interest, LD - Local Dissinterest,
     II - Internal Interest, ID - Internal Dissinterest,
     LH - Last Hop, AS - Assert, AB - Admin Boundary, EX - Extranet

(*,239.251.255.12) SM Up: 06:18:05 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      06:18:05  off LI

(*,239.251.255.13) SM Up: 07:47:50 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      07:47:50  off LI

(*,239.251.255.14) SM Up: 06:18:08 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      06:18:08  off LI

(*,239.251.255.15) SM Up: 06:18:18 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      06:18:18  off LI

(*,239.251.255.17) SM Up: 15:59:35 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      15:59:35  off LI

(*,239.251.255.43) SM Up: 11:09:49 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      11:09:49  off LI

(*,239.251.255.45) SM Up: 07:47:50 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      07:47:50  off LI

(*,239.251.255.167) SM Up: 18:05:18 RP: 192.168.66.254
JP: Null(never) RPF: BVI400,192.168.66.254* Flags:
   BVI400                      18:05:18  off LI

(*,239.251.255.250) SM Up: 18:05:28 RP: 192.168.66.254
JP: Join(00:00:47) RPF: BVI400,192.168.66.254* Flags: LH
   BVI11                       14:29:26  fwd LI LH
   BVI400                      18:05:28  off LI

(192.168.72.68,239.251.255.250)SPT SM Up: 14:22:09
JP: Join(00:00:37) RPF: BVI400,192.168.66.252 Flags: KAT(00:03:29) RA
   BVI400                      14:19:32  off AS(192.168.66.254,00:02:38)

(*,239.251.255.251) SM Up: 18:05:28 RP: 192.168.66.254
JP: Join(00:00:47) RPF: BVI400,192.168.66.254* Flags: LH
   BVI11                       14:29:26  fwd LI LH
   BVI400                      18:05:28  off LI

(192.168.72.68,239.251.255.251)SPT SM Up: 14:22:09
JP: Join(00:00:37) RPF: BVI400,192.168.66.252 Flags: KAT(00:03:29) RA
   BVI400                      14:19:31  off AS(192.168.66.254,00:02:34)
!

RP/0/RSP0/CPU0:ASR9K-02#sh mfib vrf IPTV1 ipv4 route
Wed Sep 26 11:36:41.245 UTC

IP Multicast Forwarding Information Base
Entry flags: C - Directly-Connected Check, S - Signal, D - Drop,
   IA - Inherit Accept, IF - Inherit From, MA - MDT Address,
   ME - MDT Encap, MD - MDT Decap, MT - MDT Threshold Crossed,
   MH - MDT interface handle, CD - Conditional Decap,
   DT - MDT Decap True, EX - Extranet
   MoFE - MoFRR Enabled, MoFS - MoFRR State
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
   NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
   EG - Egress, EI - Encapsulation Interface, MI - MDT Interface,
   EX - Extranet, A2 - Secondary Accept
Forwarding/Replication Counts: Packets in/Packets out/Bytes out
Failure Counts: RPF / TTL / Empty Olist / Encap RL / Other

(*,224.0.0.0/4),   Flags:  C
   Up: 14:17:08
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0

(*,224.0.0.0/24),   Flags:  D
   Up: 1w5d
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0

(*,224.0.1.39),   Flags:  S
   Up: 1w5d
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0

(*,224.0.1.40),   Flags:  S
   Up: 1w5d
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0

(*,232.0.0.0/8),   Flags:  D
   Up: 1w5d
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0

(*,239.251.255.12),   Flags:  C
   Up: 06:13:05
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.13),   Flags:  C
   Up: 07:42:50
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.14),   Flags:  C
   Up: 06:13:08
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.15),   Flags:  C
   Up: 06:13:17
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.17),   Flags:  C
   Up: 15:54:35
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.43),   Flags:  C
   Up: 11:04:48
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.45),   Flags:  C
   Up: 07:42:50
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.167),   Flags:  C
   Up: 18:00:17
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI400 Flags:  A, Up:03:19:04

(*,239.251.255.250),   Flags:  C
   Up: 18:00:28
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI11 Flags:  NS, Up:14:24:25
   BVI400 Flags:  A NS, Up:03:19:04

(192.168.72.68,239.251.255.250),   Flags:
   Up: 14:17:08
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI11 Flags:  NS, Up:14:17:08
   BVI400 Flags:  A, Up:14:17:08

(*,239.251.255.251),   Flags:  C
   Up: 18:00:28
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI11 Flags:  NS, Up:14:24:25
   BVI400 Flags:  A NS, Up:03:19:04

(192.168.72.68,239.251.255.251),   Flags:
   Up: 14:17:08
   Last Used: never
   SW Forwarding Counts: 0/0/0
   SW Replication Counts: 0/0/0
   SW Failure Counts: 0/0/0/0/0
   BVI11 Flags:  NS, Up:14:17:08
   BVI400 Flags:  A, Up:14:17:08
!
RP/0/RSP0/CPU0:ASR9K-02#sh mrib vrf IPTV1 ipv4 route
Wed Sep 26 11:26:48.488 UTC

IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
     C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
     IF - Inherit From, D - Drop, MA - MDT Address, ME - MDT Encap,
     MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
     CD - Conditional Decap, MPLS - MPLS Decap, MF - MPLS Encap, EX - 
Extranet
     MoFE - MoFRR Enabled, MoFS - MoFRR State
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
     NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
     II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
     LD - Local Disinterest, DI - Decapsulation Interface
     EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
     EX - Extranet, A2 - Secondary Accept

(*,224.0.0.0/4) RPF nbr: 192.168.66.254 Flags: C
   Up: 14:07:16

(*,224.0.0.0/24) Flags: D
   Up: 1w5d

(*,224.0.1.39) Flags: S
   Up: 1w5d

(*,224.0.1.40) Flags: S
   Up: 1w5d

(*,232.0.0.0/8) Flags: D
   Up: 1w5d

(*,239.251.255.12) RPF nbr: 192.168.66.254 Flags: C
   Up: 06:03:12
   Incoming Interface List
     BVI400 Flags: A LI, Up: 06:03:12

(*,239.251.255.13) RPF nbr: 192.168.66.254 Flags: C
   Up: 07:32:57
   Incoming Interface List
     BVI400 Flags: A LI, Up: 07:32:57

(*,239.251.255.14) RPF nbr: 192.168.66.254 Flags: C
   Up: 06:03:15
   Incoming Interface List
     BVI400 Flags: A LI, Up: 06:03:15

(*,239.251.255.15) RPF nbr: 192.168.66.254 Flags: C
   Up: 06:03:24
   Incoming Interface List
     BVI400 Flags: A LI, Up: 06:03:24

(*,239.251.255.17) RPF nbr: 192.168.66.254 Flags: C
   Up: 15:44:42
   Incoming Interface List
     BVI400 Flags: A LI, Up: 15:44:42

(*,239.251.255.43) RPF nbr: 192.168.66.254 Flags: C
   Up: 10:54:55
   Incoming Interface List
     BVI400 Flags: A LI, Up: 10:54:55

(*,239.251.255.45) RPF nbr: 192.168.66.254 Flags: C
   Up: 07:32:57
   Incoming Interface List
     BVI400 Flags: A LI, Up: 07:32:57

(*,239.251.255.167) RPF nbr: 192.168.66.254 Flags: C
   Up: 17:50:25
   Incoming Interface List
     BVI400 Flags: A LI, Up: 17:50:25

(*,239.251.255.250) RPF nbr: 192.168.66.254 Flags: C
   Up: 17:50:35
   Incoming Interface List
     BVI400 Flags: A NS LI, Up: 17:50:35
   Outgoing Interface List
     BVI11 Flags: F NS LI, Up: 14:14:33

(192.168.72.68,239.251.255.250) RPF nbr: 192.168.66.252 Flags:
   Up: 14:07:15
   Incoming Interface List
     BVI400 Flags: A, Up: 14:07:15
   Outgoing Interface List
     BVI11 Flags: F NS, Up: 14:07:15

(*,239.251.255.251) RPF nbr: 192.168.66.254 Flags: C
   Up: 17:50:35
   Incoming Interface List
     BVI400 Flags: A NS LI, Up: 17:50:35
   Outgoing Interface List
     BVI11 Flags: F NS LI, Up: 14:14:33

(192.168.72.68,239.251.255.251) RPF nbr: 192.168.66.252 Flags:
   Up: 14:07:15
   Incoming Interface List
     BVI400 Flags: A, Up: 14:07:15
   Outgoing Interface List
     BVI11 Flags: F NS, Up: 14:07:15
!
RP/0/RSP0/CPU0:ASR9K-02#sh igmp vrf IPTV1 groups
Wed Sep 26 11:40:56.214 UTC
IGMP Connected Group Membership
Group Address   Interface                     Uptime    Expires Last 
Reporter
224.0.0.2       BVI11                         14:28:46  never 10.4.33.1
224.0.0.13      BVI11                         14:32:41  never 10.4.33.1
224.0.0.22      BVI11                         14:28:46  never 10.4.33.1
239.251.255.250 BVI11                         14:28:40  00:01:47 10.4.33.251
239.251.255.251 BVI11                         14:28:40  00:01:52 10.4.33.251
224.0.0.2       BVI400                        1d14h     never 192.168.66.24
224.0.0.13      BVI400                        1d13h     never 192.168.66.24
224.0.0.18      BVI400                        1d13h     00:01:50 
192.168.66.254
224.0.0.22      BVI400                        1d14h     never 192.168.66.254
239.251.255.12  BVI400                        06:17:20  00:01:51 
192.168.66.217
239.251.255.13  BVI400                        07:47:05  00:01:50 
192.168.66.217
239.251.255.14  BVI400                        06:17:22  00:01:49 
192.168.66.217
239.251.255.15  BVI400                        06:17:32  00:01:47 
192.168.66.217
239.251.255.17  BVI400                        15:58:50  00:01:48 
192.168.66.217
239.251.255.43  BVI400                        11:09:03  00:01:52 
192.168.66.217
239.251.255.45  BVI400                        07:47:05  00:01:53 
192.168.66.217
239.251.255.167 BVI400                        18:04:32  00:01:53 
192.168.66.212
239.251.255.250 BVI400                        18:04:43  never 192.168.66.212
239.251.255.251 BVI400                        18:04:43  never 192.168.66.212
!
RP/0/RSP0/CPU0:ASR9K-02#sh int gi0/0/0/9
Wed Sep 26 11:40:35.977 UTC
GigabitEthernet0/0/0/9 is up, line protocol is up
   Interface state transitions: 5
   Hardware is GigabitEthernet, address is 6c9c.ed35.b455 (bia 
6c9c.ed35.b455)
   Description: EXT_IPTV1
   Layer 2 Transport Mode
   MTU 1514 bytes, BW 1000000 Kbit (Max: 1000000 Kbit)
      reliability 254/255, txload 0/255, rxload 144/255
   Encapsulation ARPA,
   Full-duplex, 1000Mb/s, link type is autonegotiation
   output flow control is off, input flow control is off
   loopback not set,
   ARP type ARPA, ARP timeout 04:00:00
   Last input 00:00:00, output 00:00:01
   Last clearing of "show interface" counters never
   5 minute input rate 566641000 bits/sec, 52169 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      8596879657 packets input, 11671825038185 bytes, 118440350 total 
input drops
      176 drops for unrecognized upper-level protocol
      Received 57091 broadcast packets, 8595566379 multicast packets
               0 runts, 12 giants, 0 throttles, 0 parity
      13 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      722780 packets output, 115658407 bytes, 0 total output drops
      Output 5814 broadcast packets, 22080 multicast packets
      0 output errors, 0 underruns, 0 applique, 0 resets
      0 output buffer failures, 0 output buffers swapped out
      5 carrier transitions

!
RP/0/RSP0/CPU0:ASR9K-02#sh int bvi11
Wed Sep 26 11:39:48.735 UTC
BVI11 is up, line protocol is up
   Interface state transitions: 5
   Hardware is Bridge-Group Virtual Interface, address is 6c9c.ed3f.a845
   Internet address is 10.4.33.1/24
   MTU 1514 bytes, BW 10000000 Kbit (Max: 10000000 Kbit)
      reliability 253/255, txload 0/255, rxload 0/255
   Encapsulation ARPA,  loopback not set,
   ARP type ARPA, ARP timeout 04:00:00
   Last input 00:00:00, output 00:00:00
   Last clearing of "show interface" counters never
   30 second input rate 0 bits/sec, 0 packets/sec
   30 second output rate 0 bits/sec, 0 packets/sec
      1264295 packets input, 164018316 bytes, 2992 total input drops
      456659 drops for unrecognized upper-level protocol
      Received 49524 broadcast packets, 469597 multicast packets
      1378175 packets output, 1354643180 bytes, 0 total output drops
      Output 522 broadcast packets, 36791 multicast packets
!
RP/0/RSP0/CPU0:ASR9K-02#sh int bvi400
Wed Sep 26 11:39:50.783 UTC
BVI400 is up, line protocol is up
   Interface state transitions: 3
   Hardware is Bridge-Group Virtual Interface, address is 6c9c.ed3f.a845
   Internet address is 192.168.66.24/24
   MTU 1514 bytes, BW 10000000 Kbit (Max: 10000000 Kbit)
      reliability 253/255, txload 0/255, rxload 0/255
   Encapsulation ARPA,  loopback not set,
   ARP type ARPA, ARP timeout 04:00:00
   Last input 00:00:00, output 00:00:00
   Last clearing of "show interface" counters never
   5 minute input rate 0 bits/sec, 1 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      1241437 packets input, 1233702297 bytes, 140712357 total input drops
      14098 drops for unrecognized upper-level protocol
      Received 47250 broadcast packets, 7055561886 multicast packets
      638816 packets output, 109731390 bytes, 0 total output drops
      Output 6 broadcast packets, 13562 multicast packets
!





More information about the cisco-nsp mailing list