[c-nsp] Sup720 hanging after rommon starts loading IOS

"Rolf Hanßen" nsp at rhanssen.de
Fri Apr 19 12:12:22 EDT 2013


I have an issue with a (refurbished) Sup720-2B. It does not load the IOS.
Chassis is a 6509, also tried a 6509-E and tried Slot 5 + 6 to make sure
the chassis is ok.
Few seconds after telling me to load the IOS it hangs:
System Bootstrap, Version 8.5(3)
Copyright (c) 1994-2008 by cisco Systems, Inc.
Cat6k-Sup720/SP processor with 524288 Kbytes of main memory

Autoboot executing command: "boot bootflash:"
Loading image, please wait ...


All status LEDs are red from that point.
I tried with 3 different 64GB Flash modules I had from some past upgrades.

I at least see some images on those modules (and I am quite sure they
worked when they were removed ;)), sample:
rommon 4 > dir bootflash:
         File size           Checksum   File name
  46666996 bytes (0x2c814f4)  0x27786551    s72033-pk9sv-mz.122-18.SXD7b.bin

I think rommon recognizes that the images exists, if I enter a wrong
filename i get an error message.

Maybe need to change another setting ?

rommon 1 > set
PS1=rommon ! >
RET_2_RTS=08:14:12 UTC Wed Mar 7 2012

boot -v shows some lines before freezing:

boot: bootstring is: "bootflash:s72033-pk9sv-mz.122-18.SXD7b.bin"
ROM: set load_again: a00042e0 bfc2d1ac 80006c50 30409001
Loading image, please wait ...

loading section to address 0x80008000 from file position 0x16c, size is
loading section to address 0x80020000 from file position 0x1816c, size is
loading section to address 0x800234e0 from file position 0x1b64c, size is

loading section to address 0x80020000 from file position 0x11c, size is
loading section to address 0x80028000 from file position 0x811c, size is
loading section to address 0x80028e00 from file position 0x8f1c, size is 0x20
loading section to address 0x80028e20 from file position 0x8f3c, size is

The adresses change depending on the image/flash module.

Any hint how to make that card running IOS or is this an hardware issue ?

It also does not read from a CF card (formatted and readable from a Sup2T,
maybe that uses another format ?) in rommon:

rommon 2 > dir disk0:
monlib does not contain a valid magic number
dir: cannot open device "disk0:"

Same if I use disk1 or a CF to Flash-module adapter.

kind regards

More information about the cisco-nsp mailing list