[c-nsp] FW: Cisco blade switch config

Kevin Berry kevin.berry.70 at gmail.com
Thu Feb 21 04:25:32 EST 2013


Look at the show run, for this part:


interface Port-channel1
 description HP CORE-SWITCH
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 spanning-tree portfast trunk
 spanning-tree vlan 1-10,100 cost 25
!
interface Port-channel2
 description ESXi VLAN trunk
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
!
interface FastEthernet0
 description ILO connection
 no ip address
 no ip route-cache cef
 no ip route-cache
 shutdown
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/3
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 spanning-tree portfast
!

Now, the show inter trunk:

CISCO-SW2#show inter trunk
Port        Mode             Encapsulation  Status        Native vlan
Gi0/3       on               802.1q         trunking      1
Gi0/6       on               802.1q         trunking      1
Gi0/8       on               802.1q         trunking      1
Po1         on               802.1q         trunking      1
Port        Vlans allowed on trunk
Gi0/3       1-3,100
Gi0/6       1-3,100
Gi0/8       1-3,100
Po1         1-3,100
Port        Vlans allowed and active in management domain
Gi0/3       1-3
Gi0/6       1-3
Gi0/8       1-3
Po1         1-3
Port        Vlans in spanning tree forwarding state and not pruned
Gi0/3       1-3
Gi0/6       1-3
Gi0/8       1-3
Po1         1-3

WHY is it that gi 0/1 & gi 0/2 are not here?  I have hosts in those slots,
powered on, and need to be on VLANs 1,2,3, 100.

show vlans:
CISCO-SW2#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- ---------
-------------------------------
1    default                          active    Gi0/1, Gi0/2, Gi0/4, Gi0/5
                                                Gi0/7, Gi0/9, Gi0/10, Gi0/11
                                                Gi0/12, Gi0/13, Gi0/14,
Gi0/15
                                                Gi0/16, Gi0/17, Gi0/23,
Gi0/24
2    DMZ                              active
3    VLAN0003                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------
------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0
Doesnt seem to show them in the correct vlans.......

?




On Wed, Feb 20, 2013 at 5:09 PM, Andrew Miehs <andrew at 2sheds.de> wrote:

> What does Show interface trunk show?
>
> Sent from a mobile device
>
> On 21/02/2013, at 9:05, "Kevin Berry" <kevin.berry.70 at gmail.com> wrote:
>
> > Etherchannel now shows only the two uplink ports, as below:
> >
> > Group  Port-channel  Protocol    Ports
> >> ------+-------------+-----------+-------------------------------------
> >> ------+-------------+-----------+------
> >> ----
> >> 1      Po1(SU)         LACP      Gi0/20(P)   Gi0/22(P)
> >>
> >> You original show etherchannel had too many ports in the portchannel.
> Have
> > you fixed this yet?
> >
> > -----Original Message-----
> > From: Andrew Miehs [mailto:andrew at 2sheds.de]
> > Sent: Wednesday, February 20, 2013 5:03 PM
> > To: Kevin Berry
> > Cc: <cisco-nsp at puck.nether.net>
> > Subject: Re: [c-nsp] FW: Cisco blade switch config
> >
> >
> >
> > Sent from a mobile device
> >
> > On 21/02/2013, at 8:11, "Kevin Berry" <kevin.berry.70 at gmail.com> wrote:
> >
> >> Yes, I am aware. My HP simply was configured something like:
> >>
> >> Config t
> >> Trunk 21-22 trk1 lacp
> >> Trunk 37-38 trk2 lacp
> >> Exit
> >>
> >> Then I made sure that those trunks were TAGGED for each VLAN.
> >>
> >> The HP switch, appears correct. I believe, even by review Then for
> >> Cisco, I built Etherchannel LACP from ports. My etherchannel summary
> >> now shows that gi 0/20 & 0/22 are in use and bundled in port channel.
> >> So that seems fine.
> >
> >
> >> My etherchannel for those ports was built for channel 1, or PO1.
> >> Config
> >> reads:
> >>> interface Port-channel1
> >>> description HP CORE
> >>> switchport trunk allowed vlan 1-3,100 switchport mode trunk
> >>> spanning-tree portfast trunk spanning-tree vlan 4-99 cost 20 !
> >>> interface GigabitEthernet0/1
> >>> switchport trunk allowed vlan 1-3,100 switchport mode trunk speed
> >>> 1000 channel-group 1 mode active spanning-tree portfast !
> >>> interface GigabitEthernet0/2
> >>> switchport trunk allowed vlan 1-3,100 switchport mode trunk speed
> >>> 1000 channel-group 1 mode active spanning-tree portfast
> >
> > You original show etherchannel had too many ports in the portchannel.
> Have
> > you fixed this yet?
> >
> >> Now, this being the case, would you not expect these ports to carry
> >> traffic on those vlans (1,2,3,100) ?
> >> If I have a ESX host in gi 0/1 and it has vm's on 2 of those vlans,
> >> and 2 virtual switches are configured, one for each ip segment/vlan,
> >> then each VM should send traffic to my uplink ports, in this case gi
> >> 0/20 & 0/22, which will pass all those vlans on to the next switch?
> >>
> >> It is odd to me, as port gi 0/1 needs to be able to actually
> >> accommodate multiple vlans, so to me that would be a trunk. Then, to
> >> combine multiple ports to move traffic, I need the etherchannel (with
> >> LACP talking to the HP). It seems this all works fine as long as only
> >> 1 vlan is applied. AS soon as the expectation is for more than one vlan,
> > it ceases.
> >
>


More information about the cisco-nsp mailing list