[c-nsp] 1811 questions (bridging, nat, etc)

Peter Rathlev peter at rathlev.dk
Wed Jun 12 04:11:15 EDT 2013


On Tue, 2013-06-11 at 21:16 -0400, David Hubbard wrote:
> Can I do NAT on a vlan interface in an 1811?  I've read some things that
> made me think no.  If not, any other options?

I don't have a 1800 with switchports handy but on a 1941W we have an
internal interface connecting to the embedded access point which is a
switchport. We use configuration like this, might work for you:

 interface Wlan-GigabitEthernet0/0
  description Embedded AP connection
  switchport trunk native vlan 501
  switchport trunk allowed vlan 1,401,501,1002-1005
  switchport mode trunk
 !
 interface Vlan401
  description SVI (towards AP, could be internal switchports)
  no ip address
  bridge-group 4
  bridge-group 4 spanning-disabled
 !
 interface GigabitEthernet0/0.401
  description Subif (towards other switch)
  encapsulation dot1Q 401
  bridge-group 4
  bridge-group 4 spanning-disabled
 !
 interface BVI4
  mac-address acde.4800.0004
  ip vrf forwarding VRF-X
  ip address 192.2.100.1 255.255.255.0
  ip helper-address 198.51.100.10
  ip helper-address 203.0.113.150
 !
 bridge 4 protocol ieee
 bridge 4 route ip
 !
 
I'm almost (but not 100%) certain that the BVI does all features. I
haven't tested NAT though.

-- 
Peter




More information about the cisco-nsp mailing list