[c-nsp] Cisco 2960G not passing DHCP

Curtis Piehler cpiehler2 at gmail.com
Sun Oct 22 19:34:01 EDT 2017

Including NSP

On Oct 22, 2017 7:33 PM, "Curtis Piehler" <cpiehler2 at gmail.com> wrote:

> No security features running and no DHCP snooping.  There are 3 Raritan
> PDUs and one Fortigate connected to the 2960G.  All of them exhibiting the
> same behavior.  No dhcp requests passing through and no MAC address on the
> port.  Moving the host devices to the 3560G was my next step.  I am not at
> the location so just trying to do as much as I can remotely before the on
> site visit.
> On Oct 22, 2017 7:22 PM, "Igor Sukhomlinov" <dvalinswamp at gmail.com> wrote:
>> HI Curtis,
>> Anything in the logs of the 2960?
>> Do you have any security features enabled,e.g. DAI, DHCP snooping? Faced
>> similar behavior several times due to configurations in the past.
>> Is that only that Raritan experiencing problems on the 2960? Have you
>> tried mowing the affected unit to the 3560?
>> Rgds,
>> Igor
>> On Mon, Oct 23, 2017 at 9:24 AM, Curtis Piehler <cpiehler2 at gmail.com>
>> wrote:
>>> I'm racking my brains out on this yet it seems so simple unless I am
>>> encountering a bug.
>>> I have several host devices connected to the following switch,
>>> Firewalls/PDUs, etc...:
>>> Switch Ports Model              SW Version            SW Image
>>> ------ ----- -----              ----------            ----------
>>> *    1 48    WS-C2960G-48TC-L   12.2(55)SE10          C2960-LANBASEK9-M
>>> This switch sits down stream from a 3560G which uplinks to a firewall
>>> (Router on a stick).  The problem I am encountering is that the devices
>>> connected downstream of the 2960G are not receiving DHCP from the 3560G
>>> switch or firewall.  Of course I have one DHCP at a time but to test
>>> different devices that can serve out DHCP.  What's odd is that I have the
>>> same exact model PDU connected to the 3560G and it obtains DHCP without
>>> issues.
>>> The devices downstream of the 2960G do not yield any MAC address.  I have
>>> done all sorts of DHCP debugging and nothing comes up from the devices.
>>> I
>>> even tried moving the DHCP server down to the 2960G and I see no
>>> activity.
>>> Statically assigning IPs to devices work no problem.
>>> The PDUs are Raritan factory defaulted so when the port is shut/no shut
>>> they are designed to get DHCP.  The firewall is a Fortinet with the
>>> interface set to obtain DHCP.
>>> Unfortunately I can not get a traffic sniffer on this switch but I'm
>>> wondering if anyone has had this issue before or heard of this.
>>> Curtis
>>> _______________________________________________
>>> cisco-nsp mailing list  cisco-nsp at puck.nether.net
>>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>>> archive at http://puck.nether.net/pipermail/cisco-nsp/

More information about the cisco-nsp mailing list