[c-nsp] csr1000v -ports not in order

adamv0025 at netconsultings.com adamv0025 at netconsultings.com
Mon Jun 4 18:49:12 EDT 2018

> James Bensley
> Sent: Friday, June 01, 2018 10:11 PM
> On 1 June 2018 21:35:22 BST, "Matúš Staudt" <matus.staudt at digmia.com>
> wrote:
> >Hi Adam,
> >
> >the ID seems to be the MAC address.
> >
> >In our experience, at first boot the VM brings up the interfaces in the
> >order they are in the XML file.
> >
> >After that it remembers the MAC-IFName binding - which can create
> >"gaps" in your interface name order if you delete a port, then add
> >another (as it will get a new random MAC from the hypervisor).
> >
> >Our IF definition looks like this:
> >
> ><interface type='bridge'>
> > <mac address='52:54:00:4f:a1:ed'/>
> > <source bridge='br02'/>
> > <model type='virtio'/>
> > <address type='pci' domain='0x0000' bus='0x00' slot='0x03'
> >function='0x0'/>
> ></interface>
> >
> >Even when I shuffle them around, the IFs in the VM are correct after a
> >reboot.
> >
> >Hope this helps.
> >Matus
> This is what we do to. Generate the XML from a Jinja2 template, put the
> MAC address in there and then the interfaces seem to "stick". The example
> above is for a Linux bridge. This works for us (as in sticky) as well as SR-IOV.
Hi gents,
Thanks for the replies, mine looks similar:

    <interface type='bridge'>
      <mac address='52:54:01:00:22:98'/>
      <source bridge='backbone-1'/>
      <virtualport type='openvswitch'>
        <parameters interfaceid='7c7cf663-24e5-48d0-bae7-0ffb594ac0c8'/>
      <target dev='ge-25-pe3.pop'/>
      <model type='virtio'/>
      <alias name='net26'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1e' function='0x0'/>

First I thought it's the problem with 48 interfaces in xml -while CSR supports max 26
So I tried with 26 to no avail even 16 is messed up but 8 is ok.
I even tried to hardcode the pci bus and slot -but that didn't help either.
And it's not ordering based on MAC value either.
Haven't run into this problem with vMX or XRv,

Also on a side not the standard console aint' working on these either:
    <serial type='tcp'>
      <source mode='bind' host='' service='60165'/>
      <protocol type='telnet'/>
      <target port='0'/>
      <alias name='serial0'/>

Not sure what's going on here


::carrier-class solutions for the telecommunications industry::

More information about the cisco-nsp mailing list