[cisco-voip] SRST Prefix

Andrew Dignan andy at dignans.com
Mon Feb 7 00:33:23 EST 2005


The key to the "Alias" command working properly is to configure "no
huntstop" under the telephony service.  Below is a working config of
SRST/MGCP Fall back that works with no issues.  Notice the incoming DNIS
is 4205, which I change to 6530.  The VOIP dial peer is 4205, which I
change to 6530, which in turn is the default destination/first ALIAS call.
 Lastly, ensure you have the "call application alternate DEFAULT" command
in or else you will hear dead air.

*******************************************

voice rtp send-recv
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
 codec preference 3 g729br8
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
ccm-manager fallback-mgcp
ccm-manager redundant-host x.x.x.x
ccm-manager mgcp
ccm-manager music-on-hold
mta receive maximum-recipients 0
!
!
controller T1 0/0
 framing esf
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-wink-start
 description VWIC-1MFT-T1 PSTN CAS T1
!
 class-map match-all VoIP
  match access-group name VoIP-ACL
 class-map match-all VoIP-Control
  match access-group name VoIP-Control-ACL
 class-map match-all VoIP-CTIos
  match access-group name VoIP-CTIos-ACL
!
!
 policy-map VoIP-CTIos-LLQ
  class VoIP
   priority 320
  class VoIP-Control
   bandwidth 24
  class VoIP-CTIos
   bandwidth 32
  class class-default
   fair-queue
!
translation-rule 1
 Rule 1 ^4205 6530
!
!
!
!
interface Loopback0
 ip address x.x.x.x 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/0
 description *****Connection to ROUTER*****
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/0.5
 description Data Vlan 5
 encapsulation dot1Q 5 native
 ip address x.x.x.x 255.255.255.0
 ip helper-address x.x.x.x
!
interface FastEthernet0/0.105
 description Voice Vlan 105
 encapsulation dot1Q 105
 ip address x.x.x.x 255.255.255.0
 ip helper-address x.x.x.x
 ip pim sparse-mode
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 description *****PTP to xxx*****
 ip address x.x.x.x 255.255.255.252
 ip pim sparse-mode
 service-policy output VoIP-CTIos-LLQ
!
router eigrp 100
 passive-interface Loopback0
 network x.x.x.x
 no auto-summary
 no eigrp log-neighbor-changes
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
ip pim rp-address x.x.x.x
!
!
ip access-list extended TestSRST
 deny   tcp any x.x.x.x 0.0.0.255 eq 2000
 deny   udp any x.x.x.x 0.0.0.255 eq 2000
 deny   udp any x.x.x.x 0.0.0.255 eq 2427
 deny   tcp any x.x.x.x 0.0.0.255 eq 2427
 permit ip any any
ip access-list extended VoIP-ACL
 permit ip any any dscp ef
ip access-list extended VoIP-Control-ACL
 permit ip any any dscp af31
!
!
!
call application alternate DEFAULT
call rsvp-sync
!
voice-port 0/0:1
 input gain -3
 output attenuation 3
 echo-cancel coverage 32
 description *****CID# xxxxx*****
!
voice-port 1/1/0
 echo-cancel coverage 32
 echo-cancel suppressor
 no comfort-noise
 timeouts wait-release 3
 timing hookflash-out 50
 description *****POTS BACKUP*****
 music-threshold -70
!
voice-port 1/1/1
 echo-cancel coverage 32
 echo-cancel suppressor
 no comfort-noise
 timeouts wait-release 3
 timing hookflash-out 50
 description *****OVERHEAD PAGING*****
 music-threshold -70
!
mgcp
mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 999110 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 999111 pots
 application mgcpapp
 port 1/1/1
!
dial-peer voice 999001 pots
 application mgcpapp
 port 0/0:1
!
dial-peer voice 9 pots
 description *****7-Digit - SRST*****
 application default
 destination-pattern 9[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 port 0/0:1
 forward-digits 7
!
dial-peer voice 91 pots
 description *****10-Digit - SRST*****
 application default
 destination-pattern 91[2-9].........
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 port 0/0:1
!
dial-peer voice 911 pots
 description *****911 - SRST*****
 application default
 destination-pattern 9911
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 port 1/1/0
 forward-digits 3
!
dial-peer voice 80 pots
 description *****Overhead Paging*****
 destination-pattern #80
 port 1/1/1
!
dial-peer voice 4205 voip
 tone ringback alert-no-PI
 preference 1
 application default
 destination-pattern 4205
 progress_ind setup enable 3
 translate-outgoing called 1
 voice-class codec 1
 session target ipv4:x.x.x.x
 no vad
!
!
call-manager-fallback
 max-conferences 4
 limit-dn 7910 1
 limit-dn 7940 2
 limit-dn 7960 6
 timeouts interdigit 3
 ip source-address x.x.x.x port 2000
 max-ephones 48
 max-dn 192
 keepalive 10
 default-destination 6530
 voicemail xxxx
 no huntstop
 alias 1 6530 to 6530 preference 1
 alias 2 6510 to 6536 preference 2
 date-format dd-mm-yy
!
!
line con 0
 password 7
 stopbits 1
line aux 0
line vty 0 4
 password 7
 login
line vty 5 15
 password 7
 login
!
ntp clock-period 17180208
ntp server x.x.x.x prefer
!
end

*********************************************

Andy - Berbee

> Gents,
>
> Thanks for the prompt replies.  The 'attendant DN' is configured properly
> under the port configuration in CCMAdmin.  Inbound/outbound calls work
> fine
> under normal operations; inbound calls in fallback mode are a problem
> though.
>
> The extension that is configured under the 'attendant DN' is the pilot
> number for my Unity 'Auto Attendant' call handler application.  However,
> in
> fallback mode (SRST) I cannot redirect inbound calls to an alternate
> extension because the 'attendant DN' (auto attendant) is no longer
> available?
>
> I have tried using the 'Alias' command.  When I enable my call trace
> (debug
> voip ccapi inout) I see the call come into the gateway and connect, but
> then
> nothing happens (dead air).  I even tried using translation profiles to
> convert the 'called number', or lack thereof, to a known extension -
> similar
> behaviour to 'Connection Plar' for H.323.  Same 'dead air' results.
>
> Please keep the feedback coming, they're all great ideas.
>
> Best regards,
> Colin
>
>
>
> -----Original Message-----
> From: Wes Sisk [mailto:wsisk at cisco.com]
> Sent: Sunday, February 06, 2005 5:43 PM
> To: Colin Lowe
> Cc: 'Ryan Ratliff'; cisco-voip at puck.nether.net; 'King, Jesse'
> Subject: Re: [cisco-voip] SRST Prefix
>
> For MGCP, you will need to configure "attendant dn" under the port
> configuration in CCMAdmin.
>
> Step3:
> http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186
> a008009428e.shtml
>
> /Wes
>
> Colin Lowe wrote:
>
>>Ryan,
>>
>>I can see how this will work where the gateway is a non-MGCP controlled
>>gateway (i.e. H.323).
>>
>>However, if the gateway is an MGCP gateway, how do you redirect the call
>> in
>>SRST mode, while not affecting inbound calls during normal operation? If
> I'm
>>reading my traces properly, application MGCPAPP seems to invoke and the
> call
>>goes nowhere (I hear dead air).
>>
>>Any help would be greatly appreciated...
>>
>>Colin
>>
>>
>>
>>-----Original Message-----
>>From: cisco-voip-bounces at puck.nether.net
>>[mailto:cisco-voip-bounces at puck.nether.net] On Behalf Of King, Jesse
>>Sent: Friday, February 04, 2005 3:30 PM
>>To: Ryan Ratliff
>>Cc: cisco-voip at puck.nether.net
>>Subject: RE: [cisco-voip] SRST Prefix
>>
>>Exactly what I was looking for. Worked perfect. Thanks.
>>
>>Jesse
>>
>>-----Original Message-----
>>From: Ryan Ratliff [mailto:rratliff at cisco.com]
>>Sent: Friday, February 04, 2005 3:03 PM
>>To: King, Jesse
>>Cc: cisco-voip at puck.nether.net
>>Subject: Re: [cisco-voip] SRST Prefix
>>
>>For an FXO port you'll have to configure a connection plar <dn> under the
>>voice-port for the FXO port.
>>
>>Since there is no concept of a called number with FXO you have to
>> redirect
>>every call inbound on the port to a specific place.
>>
>>-Ryan
>>On Feb 4, 2005, at 2:36 PM, King, Jesse wrote:
>>
>>Can someone point me in the right direction to point inbound calls with
> SRST
>>on an FXO port to a specific extension?
>>
>>Thanks.
>>
>>Jesse
>>_______________________________________________
>>cisco-voip mailing list
>>cisco-voip at puck.nether.net
>>https://puck.nether.net/mailman/listinfo/cisco-voip
>>
>>_______________________________________________
>>cisco-voip mailing list
>>cisco-voip at puck.nether.net
>>https://puck.nether.net/mailman/listinfo/cisco-voip
>>
>>
>>
>
> --
> No virus found in this incoming message.
> Checked by AVG Anti-Virus.
> Version: 7.0.300 / Virus Database: 265.8.5 - Release Date: 2/3/2005
>
>
> --
> No virus found in this outgoing message.
> Checked by AVG Anti-Virus.
> Version: 7.0.300 / Virus Database: 265.8.5 - Release Date: 2/3/2005
>
>
> _______________________________________________
> cisco-voip mailing list
> cisco-voip at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-voip
>



More information about the cisco-voip mailing list