[cisco-voip] Centralized Unity QOS

Philip Walenta pwalenta at wi.rr.com
Thu Jan 12 12:27:58 EST 2006


There are two things *all* voice traffic needs to have covered by QoS.

1.  Control traffic.  IF you're running CM 4.1, control traffic is marked as
DSCP CS3and uses port 2000 for skinny, but also other ports for MGCP which I
think is port 2427 and H.323 which uses TCP 1720.  This needs a queue of no
less than 10k per 100 phones or so (QoS SRND has more specific info, but I
use this as my general starting point).

2.  Voice Bearer traffic - also known as RTP.  By default, this uses DSCP
EF, and can use UDP ports 16384-32767.

I use the following on most of my routers (and I verify the switches let the
CS3 and EF pass correctly):

!
! The following needs to be built on a given WAN router
!
! The ### should be replaced with suitable numbers for the bandwidth
! available at the site and the amount of voice traffic needing
! Proper QoS coverage
!
class-map match-all VOICE-Bearer
 match ip dscp ef
!
class-map match-all VOICE-Control
 match ip dscp cs3
 match ip dscp af31
!
!
policy-map WAN-LINK
 class VOICE-Bearer
  priority ### 
 class VOICE-Control
  bandwidth ###
class class-default
  fair-queue
  random-detect dscp-based 
!
! MGCP should have the following two commands executed to ensure
! proper packet marking for QoS.  These are the defaults for 12.3.11T.
!
mgcp ip qos dscp cs3 signaling 
mgcp ip qos dscp ef media
!

This ensures that MGCP gets properly marked, and singalling gets marked
correctly as well.  Depending on your level of IOS, these may be the
defaults.  H.323 has equivalent commands when attached to VOIP dial-peers:

!
dial-peer voice 4100 voip
 ip qos dscp cs3 signaling
 ip qos dscp ef media
!

Once again, these may or may not be the defaults depending on your level of
IOS.

Either way, you can go port based with ACL's, or DSCP based.  I've leaned
towards DSCP based because that seems to be the way Cisco is leaning at the
moment with most of their network gear.

Hope this helps.

-----Original Message-----
From: cisco-voip-bounces at puck.nether.net
[mailto:cisco-voip-bounces at puck.nether.net] On Behalf Of Ortiz, Carlos
Sent: Thursday, January 12, 2006 11:00 AM
To: erickbe at yahoo.com; cisco-voip at puck.nether.net
Subject: RE: [cisco-voip] Centralized Unity QOS

When someone calls at the remote site and then leaves a message, isn't that
skinny as well?  I guess the question more correctly stated is:

What needs to be prioritized as that person is leaving a message in real
time and the traffic is traversing the WAN?

Thanks for the suggestions guys.....

Carlos

-----Original Message-----
From: Erick Bergquist [mailto:erickbe at yahoo.com]
Sent: Thursday, January 12, 2006 11:36 AM
To: Ortiz, Carlos; cisco-voip at puck.nether.net
Subject: RE: [cisco-voip] Centralized Unity QOS

Well, FRTS is needed as the other person stated, but also the Voice-ACL is
matching port 2000 traffic which is signalling for SCCP so should be in the
signal class instead, else all that sccp is getting priortized also. That
may be covered by the other access-list already but the voice-class is first
listed in policy map and has priority. 

Without FRTS, traffic goes out at a 120ms interval and cisco QoS/SRND
recommends to lower that down to your codec sampling rate which is 10ms or
20ms. You do that by configuring and enabling FRTS. 

Erick

--- "Ortiz, Carlos" <CORTIZ at broward.org> wrote:

> Most of our IPT network is connected via high speed Metro Ethernet.
> Only have 2 IPT sites across WAN links so any pointers would be 
> appreciated.  (frame at remotes to ATM at HQ)
> 
> I moved this to the top as I noticed some physical errors on the 
> remote T1.(That's an obvious problem).
> 
> Serial0/0/0 is up, line protocol is up 
>   Hardware is GT96K with integrated T1 CSU/DSU
>   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
>      reliability 255/255, txload 8/255, rxload
> 35/255
>   Encapsulation FRAME-RELAY IETF, loopback not set
>   Keepalive set (10 sec)
>   LMI enq sent  611473, LMI stat recvd 611468, LMI upd recvd 0, DTE 
> LMI up
>   LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
>   LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
>   FR SVC disabled, LAPF state down
>   Broadcast queue 1/64, broadcasts sent/dropped 1505335/0, interface 
> broadcasts 1403643
>   Last input 00:00:00, output 00:00:00, output hang never
>   Last clearing of "show interface" counters 10w0d
>   Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops:
> 11188
>   Queueing strategy: Class-based queueing
>   Output queue: 1/1000/64/11188 (size/max
> total/threshold/drops) 
>      Conversations  1/26/256 (active/max active/max
> total)
>      Reserved Conversations 1/1 (allocated/max
> allocated)
>      Available Bandwidth 310 kilobits/sec
>   5 minute input rate 213000 bits/sec, 35 packets/sec
>   5 minute output rate 50000 bits/sec, 37 packets/sec
>      187878726 packets input, 997404112 bytes, 0 no buffer
>      Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
>      12264 input errors, 12263 CRC, 416 frame, 65 overrun, 0 ignored,
> 364 abort
>      248917925 packets output, 2303451383 bytes, 0 underruns
>      0 output errors, 0 collisions, 2 interface resets
>      0 output buffer failures, 0 output buffers swapped out
>      0 carrier transitions
>      DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
> 
> 
> 
> 1) ip access-list extended Voice-ACL
>    permit tcp any any eq 2000
>    permit tcp any eq 2000 any
> 
> 2) I have not implemented FR Traffic shaping
> 
> 3)Sh run int
>  interface Serial0/0/0
>  no ip address
>  encapsulation frame-relay IETF
>  ip route-cache flow
>  frame-relay lmi-type ansi
>  service-policy output QOS-Policy
> !
> interface Serial0/0/0.90 point-to-point  description Housing 
> Finance-80QGDA503566  ip address  ip pim sparse-dense-mode  ip ospf 
> message-digest-key 1 md5 7  frame-relay interface-dlci 90
> 
> 4) Class Maps  class-map match-all
> Voice-Signal-Class
>  match access-group name Voice-Signal-ACL class-map match-any 
> Voice-Class  match access-group name Voice-ACL  match ip precedence 5  
> match  dscp ef
> 
> 5) Policy Maps
>  policy-map QOS-Policy
>  class Voice-Class
>   priority 768
>  class Voice-Signal-Class
>   bandwidth 80
>  class class-default
>   fair-queue
> 
> 6) sh frame PVC PVC Statistics for interface Serial0/0/0 (Frame Relay
> DTE)
> 
>               Active     Inactive      Deleted      
> Static
>   Local          1            0            0        
>    0
>   Switched       0            0            0        
>    0
>   Unused         0            0            0        
>    0
> 
> DLCI = 90, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = 
> Serial0/0/0.90
> 
>   input pkts 187232129     output pkts 248281814   
> in bytes 967738245 
>   out bytes 2305236587     dropped pkts 0          
> in pkts dropped 0
> 
>   out pkts dropped 0                out bytes
> dropped 0         
>   in FECN pkts 0           in BECN pkts 0          
> out FECN pkts 0
> 
>   out BECN pkts 0          in DE pkts 0            
> out DE pkts 0
> 
>   out bcast pkts 1505160   out bcast bytes 209805146
> 
>   5 minute input rate 281000 bits/sec, 62 packets/sec
>   5 minute output rate 67000 bits/sec, 59 packets/sec
>   pvc create time 10w4d, last time pvc status changed 10w4d
> 
> 
> 7) Not doing phone calls between sites but regions and locations are 
> configured.  Codec is G711 and I just changed location max audio 
> bandwidth to 768 (was 512).
> 
> 
> -----Original Message-----
> From: Erick Bergquist [mailto:erickbe at yahoo.com]
> Sent: Thursday, January 12, 2006 8:24 AM
> To: Ortiz, Carlos; cisco-voip at puck.nether.net
> Subject: Re: [cisco-voip] Centralized Unity QOS
> 
> 
> What does the ACL Voice-ACL have in it?
> 
> How is the frame relay traffic shaping (FRTS) setup, if any? Can you 
> post a show run of the T1/frame interface and related class-maps for 
> frame? And a show frame pvc ### from both sides. Post the class-map 
> and policy-map used for QoS also.
> 
> Are there any physical interface errors on either routers WAN or LAN 
> interfaces, how is LAN going to Unity server? QoS on the Switches? Any 
> errors on the switchport connecting to the unity server?
> 
> Anyone complaining of quality on phone calls between the sites, 
> besides unity traffic?
> 
> What codec is used between the sites (are regions configured)?
> 
> --- "Ortiz, Carlos" <CORTIZ at broward.org> wrote:
> 
> > Anyone else have a centralized Unity setup?  I occasionally have 
> > users across a T1 (Frame) complain that their messages
> are
> > garbled.  I have
> > QOS applied to the remote T1 location outbound,
> and
> > outbound from the
> > remote location back to HQ.  Basically I am giving priority to port 
> > 2000 upon exiting the remote router.  What else would Unity need 
> > prioritized to make sure messages are getting through? Here is the 
> > show policy map command.  Notice the Voice Class has  shows one 
> > drop.
> > 
> >  
> > 
> > Class-map: Voice-Class (match-any)
> > 
> >   13837884 packets, 1568348294 bytes
> > 
> >   5 minute offered rate 0 bps, drop rate 0 bps
> > 
> >   Match: access-group name Voice-ACL
> > 
> >     8214782 packets, 421778111 bytes
> > 
> >     5 minute rate 0 bps
> > 
> >   Match: ip precedence 5
> > 
> >     5623104 packets, 1146570431 bytes
> > 
> >     5 minute rate 0 bps
> > 
> >   Match:  dscp ef (46)
> > 
> >     0 packets, 0 bytes
> > 
> >     5 minute rate 0 bps
> > 
> >   Queueing
> > 
> >     Strict Priority
> > 
> >     Output Queue: Conversation 264
> > 
> >     Bandwidth 768 (kbps) Burst 19200 (Bytes)
> > 
> >     (pkts matched/bytes matched) 1323128/78512368
> > 
> >     (total drops/bytes drops) 1/1171
> > 
> >  
> > 
> >  
> > 
> > Carlos Ortiz
> > 
> > Senior Information Technology Specialist
> > 
> > Broward County Office of Information Technology
> > 
> > Data Communications
> > 
> >  
> > 
> >  
> > 
> > > _______________________________________________
> > cisco-voip mailing list
> > cisco-voip at puck.nether.net
> >
> https://puck.nether.net/mailman/listinfo/cisco-voip
> > 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 

_______________________________________________
cisco-voip mailing list
cisco-voip at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip



More information about the cisco-voip mailing list