[cisco-voip] H323 config

Jonathan Charles jonvoip at gmail.com
Fri Apr 20 10:38:50 EDT 2007


I thought you could only use trunk groups on analog...?


Jonathan

On 4/20/07, Robert Kulagowski <bob at smalltime.com> wrote:
>
> Voll, Scott wrote:
> > Can someone send me a sample config with 2 or 3 pri's in use for an H323
> > Voice gateway.
>
> I like using trunk groups, especially if you have a bunch of PRIs and/or
> analogs.  That way, you don't need to individually have a dial-peer for
> each port.  Take a look at dial-peer 8011; it shows it pretty well.
> Dial peer 10 shows how you can force calls out analogs without having to
> have a DP for each analog port.
>
> IOS 12.4.9(T)
>
> I also have this as a Word Document; at the top of the Document I have
> reminders like {SITEPREFIX} {IPSUBNET}, etc.  Then when it comes to
> deploy I can just do a search / replace and get the boilerplate out of
> the way and concentrate on dial-peers.
>
> no service pad
> service tcp-keepalives-in
> service tcp-keepalives-out
> no service config
> service timestamps debug datetime msec localtime
> service timestamps log datetime msec localtime
> service password-encryption
> !
> hostname {SITEPREFIX}VGW01
> card type t1 0 1
> ! Need to tell card whether it is an E1 or T1
> !
> logging buffered 51200 debugging
> !
> aaa new-model
> !
> !
> aaa authentication login default group radius local
> aaa authentication login console-in local
> !
> clock timezone {TIMEZONE} {TZOFFSET}
> clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
> network-clock-participate wic 1
> network-clock-select 1 T1 0/1/0
> !
> voice-card 0
>   dsp tdm pooling
>   dsp services dspfarm
>   no local-bypass
>
> ! Use this so that individual ports don't have to be enumerated in
> ! the dial peers
> trunk group  FXO
> max-retry 5
>   voice-class cause-code 1
>   hunt-scheme round-robin
>
> ! Used to differentiate if there are multiple PRIs at a site
> trunk group  Local
>
> trunk group  LongDistance
>
> voice class cause-code 1
>   no-circuit
>
>
>
> !
> no ip dhcp use vrf connected
> ! Used to release IP address back in to the pool
> no ip dhcp conflict logging
> ! Next command puts a copy of the dhcp database off-site
> ip dhcp database tftp://1.1.1.1/{SITEPREFIX}VGW01-dhcp
> ip dhcp excluded-address 1.1.{IPSUBNET}.1 1.1.{IPSUBNET}.20
> ! Polycom 7936's statically allocated downward from .19
> !
> ! Generic "phones" is good enough ; makes other documentation easier,
> ! like firmware update doc
> ip dhcp pool Phones
>     network 1.1.{IPSUBNET}.0 255.255.255.0
>     option 150 ip 1.1.1.10 1.1.23.10
>     default-router 1.1.{IPSUBNET}.1
>     lease 7
> !
> no ip bootp server
> no ip domain lookup
> no ftp-server write-enable
> isdn switch-type primary-ni
> isdn voice-call-failure 0
> !
> voice call send-alert
> voice call carrier capacity active
> voice rtp send-recv
> !
> voice service voip
>   h323
>    call preserve limit-media-detection
> !
> voice class codec 1
> ! TO select which codec to use
>   codec preference 1 g711ulaw
>   codec preference 2 g729r8
> !
> !
> voice class h323 1
> ! If first call manager is not available timeout switch to 2nd
>   h225 timeout tcp establish 5
>    call preserve
> !
> !
> !
> !
> !
> voice vad-time 65536
> !
> voice translation-rule {SITECODE}
> ! for rule 1, we're taking inbound calls that start with 89 and changing
> ! it to 3489.  (Site prefix is 34)
>   rule 1 /^89/ /3489/
> ! for rule 2, we're taking any inbound call that comes in as 4141 and
> ! changing it to the operator number
>   rule 2 /^4141/ /348900/
> ! for rule 3, we're taking inbound call to 5921 and sending it to
> ! operator  (800 number has DNIS of 5921)
>   rule 3 /^5921/ /348900/
> !
> !
> voice translation-profile Prepend_Sitecode
>   translate called {SITECODE}
> !
> !
> ! For AAR and SRST
> application
>   service rdnis_save flash:rdnis_save.tcl
>    param restore_did 81234567890
>   !
>   global
>    service alternate default
>   !
> !
> !
> controller T1 0/1/0
>   framing esf
>   linecode b8zs
>   pri-group timeslots 1-24
>   description CIRCUIT ID
> controller T1 0/2/0
>   framing esf
>   linecode b8zs
>   pri-group timeslots 1-24
>   description CIRCUIT ID
> controller T1 0/2/1
>   framing esf
>   linecode b8zs
>   pri-group timeslots 1-24
>   description CIRCUIT ID
> !
> !
> interface Loopback0
>   description For music-on-hold
>   ip address 6.6.6.6 255.255.255.255
> !
> interface GigabitEthernet0/0
>   description To {SITEPREFIX}VSW01 Port g1/0/1
>   ip address 1.1.{IPSUBNET}.1 255.255.255.0
>   no ip unreachables
>   no ip proxy-arp
>   duplex auto
>   speed auto
>   no mop enabled
> ! Best Practices security
>   h323-gateway voip bind srcaddr 10.1.{IPSUBNET}.1
> no shut
> !
> interface GigabitEthernet0/1
>   description To Production
>   ip address 1.1.1.5 255.255.0.0
>   no ip unreachables
>   no ip proxy-arp
>   duplex full
>   speed 100
>   no mop enabled
> no shut
> !
> interface Serial0/1/0:23
>   no ip address
>   isdn switch-type primary-ni
>   isdn incoming-voice voice
>   isdn map address . plan isdn type national
>   no cdp enable
> ! Set to appropriate trunk group; Local or LongDistance
>   trunk-group Local
>
> interface Serial0/2/0:23
>   no ip address
>   isdn switch-type primary-ni
>   isdn incoming-voice voice
>   isdn map address . plan isdn type national
>   no cdp enable
> ! Set to appropriate trunk group; Local or LongDistance
>   trunk-group Local
>
> interface Serial0/2/1:23
>   no ip address
>   isdn switch-type primary-ni
>   isdn incoming-voice voice
>   isdn map address . plan isdn type national
>   no cdp enable
> ! Set to appropriate trunk group; Local or LongDistance
>   trunk-group LongDistance
>
>
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 1.1.{IPSUBNET}.1.1
> !
> no ip http server
> ip http authentication local
> !
> !
> ! Dump syslog to off-site server
> ! Use the IP address of the voice interface, not the one facing
> ! production
> logging source-interface GigabitEthernet0/0
> logging 1.1.23.9
> !
> !
> control-plane
>
> voice-port 0/0/0
>   trunk-group FXO
>   timing hookflash-out 500
> connection plar {OperatorNumber}
> !
> voice-port 0/0/1
>   trunk-group FXO
>   timing hookflash-out 500
> connection plar {OperatorNumber}
>
> !
> voice-port 0/0/2
>   trunk-group FXO
>   timing hookflash-out 500
> connection plar {OperatorNumber}
> !
> voice-port 0/0/3
>   trunk-group FXO
>   timing hookflash-out 500
> connection plar {OperatorNumber}
> !
> !
> voice-port 0/1/0:23
>   translation-profile incoming Prepend_Sitecode
>   input gain -3
>   echo-cancel coverage 24
>   echo-cancel erl worst-case 0
>   playout-delay minimum low
>   no comfort-noise
>
> voice-port 0/2/0:23
>   translation-profile incoming Prepend_Sitecode
>   input gain -3
>   echo-cancel coverage 24
>   echo-cancel erl worst-case 0
>   playout-delay minimum low
>   no comfort-noise
>
> voice-port 0/2/1:23
>   translation-profile incoming Prepend_Sitecode
>   input gain -3
>   echo-cancel coverage 24
>   echo-cancel erl worst-case 0
>   playout-delay minimum low
>   no comfort-noise
> !
> sccp local GigabitEthernet0/0
> sccp ccm 10.1.23.10 identifier 3 version 4.1
> sccp ccm 10.1.1.12 identifier 2 version 4.1
> sccp ccm 10.1.1.11 identifier 1 version 4.1
> sccp
> !
> sccp ccm group 1
> associate ccm 2 priority 2
>   associate ccm 1 priority 1
>   associate profile 10 register {SITEPREFIX}CFB01
> !
> dspfarm profile 10 conference
>   codec g711ulaw
>   codec g711alaw
>   codec g729ar8
>   codec g729abr8
>   codec g729r8
>   codec g729br8
> associate application SCCP
> no shut
> !
> !
> ! Dial-peer sequence and numbering pattern
> ! For incoming, use sitecode + a number
>
> dial-peer voice {SITECODE}1 pots
> description
> incoming called-number {SITECODE}....
>   direct-inward-dial
>   port 0/1/0:15
>
> dial-peer voice {SITECODE}2 pots
> description
> incoming called-number {SITECODE}....
>   direct-inward-dial
>   port 0/2/0:15
>
>
> ! Dial-peer for voip is the IP address without dots.  Use the right
> ! ones!
> dial-peer voice 11111 voip
>   destination-pattern {SITECODE}....
>   progress_ind setup enable 3
>   progress_ind progress enable 8
>   voice-class codec 1
>   voice-class h323 1
>   session target ipv4:1.1.1.11
>   dtmf-relay h245-alphanumeric
>   ip qos dscp cs3 signaling
>   no vad
>   fax-relay ecm disable
> !
> dial-peer voice 111112 voip
>   preference 1
> destination-pattern {SITECODE}....
>   progress_ind setup enable 3
>   progress_ind progress enable 8
>   voice-class codec 1
>   voice-class h323 1
>   session target ipv4:1.1.1.12
>   dtmf-relay h245-alphanumeric
>   ip qos dscp cs3 signaling
>   no vad
>   fax-relay ecm disable
> !
> ! Dial-peer for pots is "8" – as the escape code
> ! Next is the number of digits that we're dealing with, so 7, 10, 11,
> ! etc
> ! Last is the preference number so analog can be less preferred than PRI
> ! with the same destination
> ! pattern
>
> dial-peer voice 871 pots
> trunkgroup Local 1
> trunkgroup FXO 3
> description Local Calling pattern – use Local PRI first, then FXO if PRI
> is full or busy
> destination-pattern 8.......
> clid restrict
>
> dial-peer voice 8101 pots
> preference 1
> trunkgroup LongDistance
> description LD Calling pattern
> destination-pattern 81..........
> clid restrict
> ! LD calls out the LD PRI don't need a 1
>
> dial-peer voice 8102 pots
> ! We only use this dial peer if the one above is down / full
> preference 2
> trunkgroup Local 1
> trunkgroup FXO 3
> description LD Calling pattern – use Local PRI first, then FXO if PRI
> is full or busy
> destination-pattern 81..........
> clid restrict
> ! LD calls out the local PRI or FXO need the "1" in front.
> prefix 1
>
> dial-peer voice 8011 pots
> ! One dial-peer covers all of our bases.
>   trunkgroup LongDistance 1
>   trunkgroup Local 3
>   trunkgroup FXO 5
>   description International call
>   destination-pattern 8011T
>   progress_ind setup enable 3
>   prefix 011
>
> dial-peer voice 911 pots
> description Used with CER
>   destination-pattern 6911
>   progress_ind setup enable 3
>   trunkgroup Local
>   forward-digits 3
> !
> dial-peer voice 8411 pots
> description x11 Services
>   destination-pattern 8[2-9]11
>   trunkgroup Local 1
>   trunkgroup FXO 3
>   forward-digits 3
> !
> dial-peer voice 9101 pots
>   description Used to send caller ID for inter-office calls
>   destination-pattern 91[2-9].........
>   progress_ind setup enable 3
> trunkgroup LongDistance
> ! Note that we don't have clid restrict on this dial peer, and it has a
> ! "9" - we stuff the 9 on the route pattern in CM; users can't dial "9"
> ! directly
>   forward-digits 10
>
> dial-peer voice 9011 pots
>   trunkgroup LongDistance
>   description Used to send caller ID for inter-office calls
> internationally
>   destination-pattern 9011T
>   progress_ind setup enable 3
>   prefix 011
>
> dial-peer voice 10 pots
> description Different escape pattern to force a call to analog
> trunkgroup FXO
> destination-pattern *8T
> !
>
> ! Convert to U.S.-based 911 for our foreign guests; do the same for
> ! "110" and "112" in case of SRST mode
> num-exp 911 8911
> num-exp 110 8911
> num-exp 8110 8911
> num-exp 112 8911
> num-exp 8112 8911
>
>
> gateway
>    media-inactivity-criteria rtp
>    timer receive-rtcp 1000
> ip rtcp report interval 65535
>
>
> !
> line con 0
>   login authentication console-in
> line vty 0 15
>   session-timeout 120
>   exec-timeout 60
> autoselect during-login
> !
> ntp server 1.1.1.26
> ntp update-calendar
> ! If there's a core dump, then send it via TFTP somewhere else for
> analysis
> exception dump 1.1.23.9
>
> ! archive command provides CLI history of who entered a command
> archive
>   log config
>    logging enable
>    notify syslog
>    hidekeys
> end
> _______________________________________________
> cisco-voip mailing list
> cisco-voip at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-voip
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://puck.nether.net/pipermail/cisco-voip/attachments/20070420/2e21fa4b/attachment-0001.html 


More information about the cisco-voip mailing list