[cisco-voip] Update: partially working configuration, Re: Polycom Video integrated to Cisco
Robert Kulagowski
rkulagow at gmail.com
Tue Oct 21 12:39:33 EDT 2008
Here's a partially working configuration. What works: a single call at
384K, either inbound or outbound.
What doesn't work: I can't seem to get multiple inbound calls working,
and the TAC engineer is on vacation until 2008-10-22. Can't seem to
make outbound call to Codian 3241 with more than one b-channel;
something that Codian and TAC are going back and forth about how
secondary b-channels are supposed to be exchanged.
The video units have a hardcoded GK address of 10.23.10.210 and
automatically register on bootup with the ISR. This and the "session
target ras" in the dial-peer means that we don't need static IP /
hardcoded DPs for every single unit at a site.
Many thanks to Anthony Yeung in TAC to even get it this far. I've tried
to put inline comments on things that were discovered in the course of
getting this (partially) working.
#sh inven
NAME: "2821 chassis", DESCR: "2821 chassis"
PID: CISCO2821 , VID: V04 , SN: FTX1133A3JY
NAME: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0
SubSlot 0", DESCR: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1"
PID: VWIC2-1MFT-T1/E1 , VID: V01 , SN: FOC10193H39
NAME: "PVDMII DSP SIMM with Two DSPs on Slot 0 SubSlot 4", DESCR:
"PVDMII DSP SIMM with Two DSPs"
PID: PVDM2-32 , VID: V01 , SN: FOC11241W26
NAME: "PVDMII DSP SIMM with Two DSPs on Slot 0 SubSlot 5", DESCR:
"PVDMII DSP SIMM with Two DSPs"
PID: PVDM2-32 , VID: V01 , SN: FOC11244UDP
NAME: "PVDMII DSP SIMM with four DSPs on Slot 0 SubSlot 6", DESCR:
"PVDMII DSP SIMM with four DSPs"
PID: PVDM2-64 , VID: V01 , SN: FOC11385KJR
Current configuration : 6369 bytes
!
! Last configuration change at 10:06:08 CDT Mon Oct 20 2008
! NVRAM config last updated at 16:02:02 CDT Thu Oct 16 2008
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service sequence-numbers
!
hostname Router
!
boot-start-marker
boot system flash:c2800nm-ipvoice_ivs-mz.124-20.T.bin
boot-end-marker
!
card type t1 0 0
logging message-counter syslog
logging buffered 10000000
!
no aaa new-model
clock timezone CST -6
clock summer-time CDT recurring
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
ip source-route
!
!
ip cef
!
!
no ip bootp server
ip name-server 10.1.1.6
multilink bundle-name authenticated
!
isdn switch-type primary-ni
isdn voice-call-failure 0
!
!
trunk group Local
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
fax protocol pass-through g711ulaw
h323
call start slow
call preserve limit-media-detection
h245 caps mode restricted
modem passthrough nse codec g711ulaw
!
!
!
! NOTE!! One way video issue was due to H.320 and H.323 legs
! wanting different audio codecs (Polycom FX always wanted a-law
! HDX 4002 wanted u-law, and the router can't transcode.
! Works if you only give one g.711 choice, in class 3 below)
voice class codec 1
codec preference 1 g711ulaw bytes 160
codec preference 2 g729r8 bytes 20
codec preference 3 g711alaw bytes 160
!
voice class codec 2
codec preference 1 g711ulaw bytes 160
codec preference 2 g729r8 bytes 20
codec preference 3 g711alaw bytes 160
video codec h261
video codec h263
video codec h264
!
voice class codec 3
codec preference 1 g711alaw bytes 160
codec preference 2 g729r8 bytes 20
video codec h261
video codec h263
video codec h264
!
!
!
voice class h323 1
h225 timeout tcp establish 5
call preserve
!
!
!
!
!
!
!
! Router has to have a pool of DIDs used for secondary b-channels.
! Incoming call to router sets up, router and distant end use H.221
! to negotiate DIDs for b-channels 2 to n. Good thing DIDs are cheap?
voice class called number pool 7
index 1 3127054830 - 3127054839
index 2 3127054826 - 3127054829
!
!
voice vad-time 65536
!
voice translation-rule 211
! Two DIDs for two endpoints with H.323 id of "213749"
! and "213804". Everything else gets site code "21"+xxxx
rule 1 /3127054840/ /213749/
rule 2 /3127054841/ /213804/
rule 15 /312705/ /21/
!
!
voice translation-profile Prepend_Sitecode
translate called 211
!
!
voice-card 0
dspfarm
dsp services dspfarm
no local-bypass
!
!
!
file prompt quiet
archive
log config
hidekeys
!
!
controller T1 0/0/0
framing esf
linecode b8zs
cablelength long 0db
pri-group timeslots 1-24
!
!
!
!
!
interface Loopback0
description For music-on-hold
ip address 6.6.6.6 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.23.10.210 255.255.0.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip id pstn ipaddr 10.23.10.210 1719
h323-gateway voip h323-id gw-chicago
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 10.23.10.210
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn supp-service name calling
isdn integrate calltype all
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
!
ip http server
!
ip access-list standard ForceSRST
deny 10.201.255.0 0.0.0.255
permit any
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
! The called number pool takes effect before any translations
! So the DIDs for secondary b-channels aren't affected.
voice-class called-number-pool 7
!
!
!
sccp local GigabitEthernet0/0
sccp ccm 10.201.255.2 identifier 1 version 5.0.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 10 register TestCFB01
!
dspfarm profile 10 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
! Inbound and outbound calls use two legs; one for the H.320
! And one for the H.323
!
dial-peer voice 1 pots
description Incoming video call pots leg
translation-profile incoming Prepend_Sitecode
information-type video
! Setting aside the 40 to 48 part of the range for video DIDs
incoming called-number 312705484[0-8]
bandwidth maximum 1024
direct-inward-dial
!
dial-peer voice 2 voip
description Incoming video call, H.323 leg.
! Translation profile on POTS leg
huntstop
!
destination-pattern 213[78]..
voice-class codec 3
session target ras
!
dial-peer voice 3 voip
description Outbound H.323 calls hit this DP
voice-class codec 3
incoming called-number .T
!
dial-peer voice 4 pots
description Outbound H.320 leg. Video units dial 1 or 011 for
outbound call
destination-pattern [01].T
information-type video
bandwidth maximum 1024
port 0/0/0:23
forward-digits all
!
dial-peer voice 10 pots
description Incoming voice calls
translation-profile incoming Prepend_Sitecode
incoming called-number 31270548..
direct-inward-dial
!
dial-peer voice 11 voip
description Dialpeer to CallManager
huntstop
destination-pattern 21....
progress_ind setup enable 3
progress_ind progress enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:10.201.255.2
dtmf-relay h245-alphanumeric
fax-relay ecm disable
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 12 voip
voice-class codec 1
voice-class h323 1
incoming called-number 8.T
dtmf-relay h245-alphanumeric
!
dial-peer voice 13 pots
! Voice calls always have an "8" in the front
! So we know it's voice and not video
description Outbound dial-peer for voice calls
destination-pattern 8.T
port 0/0/0:23
!
!
gateway
timer receive-rtp 1200
!
!
gatekeeper
zone local video video.foo.bar 10.23.10.210
zone local pstn video.foo.bar
no zone subnet pstn default enable
zone subnet pstn 10.23.10.210/32 enable
zone prefix pstn 011*
zone prefix pstn 1*
gw-type-prefix 1#* default-technology
no use-proxy video default inbound-to terminal
no use-proxy video default outbound-from terminal
no shutdown
!
!
call-manager-fallback
secondary-dialtone 8
max-conferences 6 gain -6
transfer-system local-consult
timeouts interdigit 5
ip source-address 10.23.10.210 port 2000
max-ephones 10
max-dn 20 dual-line
system message primary Fallback mode Enabled
transfer-pattern T
!
banner login ^C
Access to this computer system and its associated network,
computer resources, and data is restricted to those authorized.
Use by unauthorized individuals or for unauthorized purposes is a
violation of Federal and/or State law. Violators will be prosecuted.
^C
!
line con 0
line aux 0
line vty 0 4
exec-timeout 60 0
privilege level 15
login
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 10.255.1.5
ntp server 10.255.1.10
end
More information about the cisco-voip
mailing list