[cisco-voip] Voice Vlan not recognized on cisco 2900xl

Joseph Mays mays at win.net
Mon Aug 22 14:19:50 EDT 2011


I made the suggested changes, but still no service on the phone, and the switch does not show vlan7 as associated with any ports in "show vlan". How should a voice vlan show up in "show vlan"? Should I even be expecting it to be associated with ports?

On the switch now...

Switch#show run
Building configuration...

Current configuration:
!
version 12.0
[...]
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
switchport voice vlan 7
spanning-tree portfast
[...]
interface FastEthernet0/9
switchport access vlan 2
switchport voice vlan 7
spanning-tree portfast
!
interface FastEthernet0/10
[...]
Switch#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    VLAN0002                         active    Fa0/2, Fa0/3, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24
7    VLAN0007                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
7    enet  100007     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0



----- Original Message ----- 
From: "Buchanan, James" <jbuchanan at presidio.com>
To: "Joseph Mays" <mays at win.net>; <cisco-voip at puck.nether.net>
Sent: Saturday, August 20, 2011 10:46 AM
Subject: RE: [cisco-voip] Voice Vlan not recognized on cisco 2900xl


OH, on the 2900xl, you may need to do this:

Switchport trunk native <datavlan>

Then, your switchport voice as-is.

James Buchanan| UC Technology Manager | Presidio South | Presidio Networked Solutions
12 Cadillac Dr Ste 130 Brentwood, TN 37027 | jbuchanan at presidio.com<mailto:jbuchanan at presidio.com>
D: 615-866-5729 | F:615-866-5781  www.presidio.com<http://www.presidio.com/>

From: cisco-voip-bounces at puck.nether.net [mailto:cisco-voip-bounces at puck.nether.net] On Behalf Of Joseph Mays
Sent: Friday, August 19, 2011 4:07 PM
To: cisco-voip at puck.nether.net
Subject: [cisco-voip] Voice Vlan not recognized on cisco 2900xl

Trying to set up 2 VLAN's to run on a switch, one for access, one for voice. The access VLAN works fine, but the voice VLAN just does not seem to be associated with any port as far as the switch is concerned. The switch is a 2900xl.

On the router....

interface FastEthernet0/1
description LAN connection to Winnet Labs Switch
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 216.24.19.1 255.255.255.248
no snmp trap link-status
!
interface FastEthernet0/1.7
description Winnet Labs Voice VLAN
encapsulation dot1Q 7
ip address 216.24.19.73 255.255.255.248
no snmp trap link-status

On the switch....

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 2
switchport voice vlan 7
spanning-tree portfast
!
[...]
interface FastEthernet0/9
switchport access vlan 2
switchport voice vlan 7
spanning-tree portfast

Plugging a netbook into port 2 works on VLAN2.

Plugging the netbook into the PC port of VOIP phone which has the PC port configured to VLAN2 works, then plugging the phone into port 9, allows the netbook to work. Changing the access vlan to 7 when the phone itself is configured to be VLAN 7 causes port 9 to show up associated with VLAN 7, and then you can make calls with the phone. But with the voice vlan set to 7 and the phone VLAN ID set to 7, vlan 7 does not show up as associated with any ports at all and the phone just does not work....

Switch>show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    VLAN0002                         active    Fa0/2, Fa0/3, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24
7    VLAN0007                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
7    enet  100007     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://puck.nether.net/pipermail/cisco-voip/attachments/20110822/d2a24c22/attachment.html>


More information about the cisco-voip mailing list