[cisco-voip] QoS on Catalyst 3550

Cristobal Priego cristobalpriego at gmail.com
Thu Feb 3 14:55:01 EST 2011


you could try this config

class-map match-all VOICE
 match ip dscp 46
class-map match-any CALL-SIGNALING
 match ip dscp 26
 match ip dscp 24

class-map match-all VVLAN-VOICE
 match vlan <voice vlan>
 match class-map VOICE

class-map match-all VVLAN-CALL-SIGNALING
 match vlan <voice vlan>
 match class-map CALL-SIGNALING


class-map match-all DVLAN-ANY
 match vlan 10 ! VLAN 10 is DVLAN
 match class-map ANY ! Matches all DVLAN traffic

policy-map IPPHONEPC
class VVLAN-VOICE
 set ip dscp 46
 police 2097000 61440 exceed-action drop

class VVLAN-CALL-SIGNALING
 set ip dscp 24
 set ip dscp 24
 police 32000 8000 exceed-action policed-dscp-transmit

class DVLAN-ANY
 set ip dscp 0
 police 5000000 8000 exceed-action policed-dscp-transmit

interface Gi0/X
CAT3550(config-if)# switchport access vlan  DVLAN
CAT3550(config-if)# switchport voice vlan VVLAN
CAT3550(config-if)# mls qos trust device cisco-phone
CAT3550(config-if)# service-policy input IPPHONEPC

2011/2/2 <John.VanLaecke at ghd.com>

> Normally i put on the port and trunks
>
> "mls qos trust dscp"
>
> Then do the policy map on the router as the switch is layer 2 and will not
> understand IP info.
>
>
>
>
>
> Regards,
> *
> John Van Laecke **
> **Senior Voice Engineer
> *
>
>
>  From: Nick Matthews <matthnick at gmail.com> To:
> Michael Crilly <michael.crilly at comtek.co.uk>
> Cc: cisco-voip at puck.nether.net, cisco-nsp at puck.nether.net Date: 03/02/2011
> 02:25 PM Subject: Re: [cisco-voip] QoS on Catalyst 3550 Sent by:
> cisco-voip-bounces at puck.nether.net
> ------------------------------
>
>
>
> If I remember correctly the DSCP value will be determined inbound.  I'm not
> sure if trusting DSCP outbound is the correct way to do this.  I would think
> it would be switched - trust dscp inbound, set dscp outbound.  Then again,
> not a 6500 guru.
>
> -nick
>
> On Wed, Feb 2, 2011 at 12:14 PM, Michael Crilly <*
> michael.crilly at comtek.co.uk* <michael.crilly at comtek.co.uk>> wrote:
> Greetings,
>
> I am attempting to configure QoS on a series of 3550s, a 3560 and our core
> switch, a 4500. Currently, I am testing QoS configurations on the 3550, but
> with limited success.
>
> Using auto qos would be nice, but we can't count on the handset marking its
> traffic as DSCP 46 (or CoS 5) as we're using a mash-up of Cisco IP phones,
> Nortel phones, etc. Therefore, we want to match traffic on our VoIP IP
> network, which is currently configured to run on *10.200.0.0/16*<http://10.200.0.0/16>
> .
>
> The issue I am having is nothing is being matched when I look at the output
> of 'show policy-map interface fa0/3' (fa0/3, for example), but I can see
> packets being classified as DSCP 46 when I look at the 'mls qos interface
> fa0/3 stats' command.
>
> I have attached my switch's configuration (with passwords censored). Could
> someone take a quick peak and let me know if they can see anything that is
> missing? It could be something obvious that my now stale eyes are missing,
> so a fresh pair might help.
>
> Thanks in advance for all assistance/responses.
>
> Kind regards,
>
> --
>
> Michael Crilly
> ICT Systems Administrator
> Comtek Network Systems
>
> E: *michael.crilly at comtek.co.uk* <michael.crilly at comtek.co.uk>
>
>
> _______________________________________________
> cisco-voip mailing list*
> **cisco-voip at puck.nether.net* <cisco-voip at puck.nether.net>*
> **https://puck.nether.net/mailman/listinfo/cisco-voip*<https://puck.nether.net/mailman/listinfo/cisco-voip>
>
>
>
> _____________________
> This e-mail has been scanned for viruses by MessageLabs.
> _______________________________________________
>
> cisco-voip mailing list
> cisco-voip at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-voip
>
>
> _____________________
> This email and all attachments are confidential. For further important
> information about emails sent to or from GHD or if you have received this
> email in error, please refer to http://www.ghd.com/emaildisclaimer.html .
> _____________________
> This e-mail has been scanned for viruses by MessageLabs.
>
> _______________________________________________
> cisco-voip mailing list
> cisco-voip at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-voip
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://puck.nether.net/pipermail/cisco-voip/attachments/20110203/99450836/attachment.html>


More information about the cisco-voip mailing list