[cisco-voip] UCS-E and using both internal and external connections.

Chris Osborne (Americas) chris.osborne at dimensiondata.com
Tue Sep 12 11:47:06 EDT 2017


Here are two examples I’ve used in the past

----example 1  -------
ip unnumbered and Vlans  – so you have some ip range flexibility.  ( also I think the external NIC is just a layer 2 interface that is for outside switch connectivity)

I this case I only used 2/0 for the CIMC and esxi and the 2/1 for all host communications ( voice, firewall, vmware)  broke out onto vlans

interface ucse2/0
ip unnumbered Vlan11
imc ip address 10.20.X.X 255.255.255.192 default-gateway 10.20.X.X (where this is the IP of Vlan11)
imc access-port shared-lom console
!
( if you plan on using the other IP”s in the vlan 11 range you have to put static routes to this interface)
ip route 10.20.X.132 255.255.255.255 ucse2/0 name cimc
ip route 10.20.X.133 255.255.255.255 ucse2/0 name exsi


interface ucse2/1
description Internal switch interface connected to Service Module
switchport trunk native vlan 11
switchport trunk allowed vlan 1-5,7,8,12
switchport mode trunk
no ip address

interface Vlan11
description Management Vlan
ip address 10.20.X.X 255.255.255.192

interface Vlan2
description Voice Vlan
ip address 10.20.99.X 255.255.255.128

….


---- example 2 -----

Basic voice installation with a BEK6S – nothing fancy since it was a base 100 user system with Router as SRST to a single CUCM/CUC/IMP

interface ucse1/0
description Internal interface connected to UCSE Port 0
ip unnumbered GigabitEthernet0/0
imc ip address 10.180.X.5 255.255.254.0 default-gateway 10.180.X.2
 imc access-port shared-lom console
!
interface ucse1/1
description Internal switch interface connected to UCSE Port 1
no ip address

ip route 10.180.X.5 255.255.255.255 ucse1/0 name cimc
ip route 10.180.X.6 255.255.255.255 ucse1/0 name esxi
ip route 10.180.X.7 255.255.255.255 ucse1/0 name CUCM
ip route 10.180.X.8 255.255.255.255 ucse1/0 name CUPS
ip route 10.180.X.9 255.255.255.255 ucse1/0 name CUC



Chris Osborne
Sr Solution Architect
T: 704-969-2771
M: 864-423-8288
E: chris.osborne at dimensiondata.com<mailto:chris.osborne at dimensiondata.com>
For more information, please go to www.dimensiondata.com/en-US<http://www.dimensiondata.com/en-US>






From: Lelio Fulgenzi [mailto:lelio at uoguelph.ca]
Sent: Tuesday, September 12, 2017 11:31 AM
To: Chris Osborne (Americas) <chris.osborne at dimensiondata.com>; cisco-voip voyp list <cisco-voip at puck.nether.net>
Subject: RE: UCS-E and using both internal and external connections.


Thanks Chris. This is the answer I seem to be getting from different avenues. I like to get comments about design and deployment options from various sources.

The TAC confirmed using all interfaces at once, but cautioned that they are not bonded together. So in my case, I’d have vSwitch zero for management using ge<slot>/2 (external) and vSwitch one for applications using ge<slot>/0 (internal L3 interface).

I’m still working out how to configure things  with respect to what the default gateway of the guest applications would be, but I think I’m there. Essentially create a loopback and assign that loopback to the ip unnumbered configuration on the UCS-E blade itself. This loopback would be a subnet of, say, /29, with 6 usable ip addresses, one for router, 5 for guests. Overkill, but I can’t go with just two host ip address that you get with a /30. This loopback would then be the default gateway of the guest application on the same subnet.

I’ve also asked the TAC to confirm what type of port is the external GE connection – L2 or L3 or selectable? I’d want to be able to plug the external GE connection into an upstream switch configured for the campus ESXi host VLAN.

If you have thoughts on any of the above, that would be great!


---
Lelio Fulgenzi, B.A.
Senior Analyst, Network Infrastructure
Computing and Communications Services (CCS)
University of Guelph

519-824-4120 Ext 56354
lelio at uoguelph.ca<mailto:lelio at uoguelph.ca>
www.uoguelph.ca/ccs<http://www.uoguelph.ca/ccs>
Room 037, Animal Science and Nutrition Building
Guelph, Ontario, N1G 2W1

From: Chris Osborne (Americas) [mailto:chris.osborne at dimensiondata.com]
Sent: Tuesday, September 12, 2017 11:04 AM
To: Lelio Fulgenzi; cisco-voip voyp list
Subject: RE: UCS-E and using both internal and external connections.

Lelio

I’m my experience you will have two internal (router) interfaces to the E140 blade 2/0 and 2/1 plus an external NIC on the card blade itself (I’ve never used it, couldn’t find a reason to)

So you could definitely setup one NIC as internal and the other as External inside the router and or use the external NIC as well as a backup to switch.

Vmware just see’s the 3 NIC’s and you can use them as you see fit with VSwitch setups as normal UCS seriers servers.


Chris Osborne
Sr Solution Architect
T: 704-969-2771
M: 864-423-8288
E: chris.osborne at dimensiondata.com<mailto:chris.osborne at dimensiondata.com>
For more information, please go to www.dimensiondata.com/en-US<http://www.dimensiondata.com/en-US>






From: cisco-voip [mailto:cisco-voip-bounces at puck.nether.net] On Behalf Of Lelio Fulgenzi
Sent: Saturday, September 09, 2017 9:49 PM
To: cisco-voip voyp list <cisco-voip at puck.nether.net<mailto:cisco-voip at puck.nether.net>>
Subject: [cisco-voip] UCS-E and using both internal and external connections.





I'm in the process of designing a new demployment of four ucs-E blades (e140s-m2) into four ISR-G2 routers (2x3945,1x3925,1x2921).

The question I have is whether or not I can use _both_ an internal interface and external interface to communicate with the blade? External for ESXi and internal for guests (unity express) running on ESXi.

I'd like to use external for ESXi to stick with existing models but to also remove the router internals as a failure point. The guest itself would need to talk with the router internals to ensure unity express can register with SRST without any infrastructure requirements.

What are people's thoughts about this?

Sent from my iPhone
_______________________________________________
cisco-voip mailing list
cisco-voip at puck.nether.net<mailto:cisco-voip at puck.nether.net>
https://puck.nether.net/mailman/listinfo/cisco-voip<https://puck.nether.net/mailman/listinfo/cisco-voip>


itevomcid
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://puck.nether.net/pipermail/cisco-voip/attachments/20170912/6488308e/attachment.html>


More information about the cisco-voip mailing list