Hi Carlos,<br>
I used the following configuration guides available from Cisco Online,
with no problems. Just remember that this guides are for
IOS12.2.(11)T
onwards and that the command "call appplication alternate default" has
changed to the following on IOS 12.3.14T onwards<br>
<br>
application<br>
==>global <br>
==> service alternate dafault<br>
<br>
Guides<br>
======<br>
<br>
1-) Configuring SRS Telephony and MGCP Gateway Fallback
(<a href="http://www.cisco.com/warp/public/788/AVVID/configsrst_mgcpfallback.html">http://www.cisco.com/warp/public/788/AVVID/configsrst_mgcpfallback.html</a>)<br>
<br>
2-) MGCP Gateway Fallback Transition to Default H.323 Session
Application
(<a href="http://www.cisco.com/en/US/tech/tk1077/technologies_configuration_example09186a008012ecc6.shtml">http://www.cisco.com/en/US/tech/tk1077/technologies_configuration_example09186a008012ecc6.shtml</a>)<br>
<br>
I also had to use an Outbound Translation Rule because in our
environment users dial a "0" to obtain an outside line. More
information about translation rules can be found at,<br>
<br>
You can find out more information about "Number Translation using Voice Translation Profiles" from <br>
<br>
<a href="http://www.cisco.com/en/US/tech/tk652/tk90/technologies_configuration_example09186a00803f818a.shtml">http://www.cisco.com/en/US/tech/tk652/tk90/technologies_configuration_example09186a00803f818a.shtml</a><br>
<br>
<noscript>
<link rel="Stylesheet" href="http://www.cisco.com/swa/c/cdc.css" type="text/css">
</noscript><link href="http://www.cisco.com/swa/c/cdc.css" type="text/css" rel="stylesheet"><link href="/swa/c/book.css" type="text/css" rel="stylesheet"><table border="0" cellpadding="0" cellspacing="0" width="100%"><tbody>
<tr align="left" valign="top"><td width="70%"><div class="book"><div class="title"></div></div></td></tr></tbody></table><a href="http://www.cisco.com/en/US/products/sw/voicesw/ps2169/products_command_reference_book09186a008054e8b9.html">
http://www.cisco.com/en/US/products/sw/voicesw/ps2169/products_command_reference_book09186a008054e8b9.html</a><br>
<br>
Nevertheless, I have also inlcuded a working config for you.<br>
<br>
Hope it helps,<br>
<br>
Sergio Aguilera<br>
<br>
<br>
<br>
<br>
version 12.3<br>
service config<br>
no service pad<br>
service timestamps debug datetime msec show-timezone<br>
service timestamps log datetime msec show-timezone<br>
service password-encryption<br>
service compress-config<br>
!<br>
!<br>
boot-start-marker<br>
boot system flash c3725-ipvoice-mz.123-11.T6.bin<br>
boot-end-marker<br>
!<br>
no logging console<br>
enable password 7 12170000160E0910332A<br>
!<br>
username support password 7 1107160B44061C031621<br>
network-clock-participate slot 2<br>
network-clock-select 1 E1 2/0<br>
voice-card 2<br>
dspfarm<br>
!<br>
ip subnet-zero<br>
ip cef<br>
!<br>
!<br>
!<br>
!<br>
isdn switch-type primary-net5<br>
isdn voice-call-failure 0<br>
!<br>
!<br>
voice rtp send-recv<br>
!<br>
voice service pots<br>
!<br>
voice service voip<br>
!<br>
!<br>
voice class codec 100<br>
codec preference 1 g711ulaw<br>
codec preference 2 g729r8 bytes 30<br>
!<br>
!<br>
!<br>
voice class h323 10<br>
h225 timeout tcp establish 3<br>
!<br>
!<br>
!<br>
!<br>
!<br>
!<br>
voice translation-rule 1<br>
rule 1 /^0/ //<br>
!<br>
!<br>
voice translation-profile SRST_Outbound<br>
translate called 1<br>
!<br>
!<br>
ccm-manager fallback-mgcp<br>
ccm-manager redundant-host <a href="http://10.35.255.230">10.35.255.230</a><br>
ccm-manager mgcp<br>
ccm-manager music-on-hold<br>
!<br>
!<br>
controller E1 2/0<br>
pri-group timeslots 1-20 service mgcp<br>
!<br>
!<br>
!<br>
interface FastEthernet0/0<br>
ip address <a href="http://10.17.200.220">10.17.200.220</a> <a href="http://255.255.255.0">255.255.255.0</a><br>
duplex auto<br>
speed auto<br>
standby 1 ip <a href="http://10.17.200.225">10.17.200.225</a><br>
standby 1 timers 3 7<br>
standby 1 preempt<br>
!<br>
!<br>
interface FastEthernet0/1<br>
ip address <a href="http://10.34.255.220">10.34.255.220</a> <a href="http://255.255.248.0">255.255.248.0</a><br>
duplex auto<br>
speed auto<br>
!<br>
interface Serial0/1<br>
no ip address<br>
shutdown<br>
clockrate 2000000<br>
!<br>
interface Serial2/0:15<br>
no ip address<br>
isdn switch-type primary-net5<br>
isdn incoming-voice voice<br>
isdn bind-l3 ccm-manager<br>
no cdp enable<br>
!<br>
ip classless<br>
ip route <a href="http://0.0.0.0">0.0.0.0</a> <a href="http://0.0.0.0">0.0.0.0</a> <a href="http://10.17.200.254">10.17.200.254</a><br>
!<br>
ip http server<br>
!<br>
<br>
!<br>
control-plane<br>
!<br>
!<br>
call application alternate default<br>
!<br>
!<br>
voice-port 2/0:15<br>
cptone AU<br>
!<br>
mgcp<br>
mgcp call-agent <a href="http://10.34.255.230">10.34.255.230</a> 2427 service-type mgcp version 0.1<br>
mgcp dtmf-relay voip codec all mode out-of-band<br>
mgcp rtp unreachable timeout 1000 action notify<br>
mgcp modem passthrough voip mode nse<br>
mgcp package-capability rtp-package<br>
mgcp package-capability sst-package<br>
no mgcp package-capability fxr-package<br>
mgcp package-capability pre-package<br>
no mgcp timer receive-rtcp<br>
mgcp sdp simple<br>
mgcp fax t38 inhibit<br>
mgcp rtp payload-type g726r16 static<br>
!<br>
mgcp profile default<br>
!<br>
!<br>
!<br>
dial-peer voice 68000 pots<br>
description Used in SRST mode for Inbound and Outbound PSTN Calls<br>
translation-profile outgoing SRST_Outbound<br>
preference 1<br>
destination-pattern 0T<br>
incoming called-number .<br>
clid restrict<br>
clid restrict<br>
direct-inward-dial<br>
port 2/0:15<br>
forward-digits all<br>
!<br>
!<br>
call-manager-fallback<br>
max-conferences 8<br>
limit-dn 7940 1<br>
limit-dn 7960 5<br>
timeouts interdigit 2<br>
ip source-address <a href="http://10.17.200.225">10.17.200.225</a> port 2000<br>
max-ephones 120<br>
max-dn 500<br>
keepalive 20<br>
voicemail 061218111<br>
call-forward busy 061218111<br>
call-forward noan 061218111 timeout 10<br>
time-zone 48<br>
time-format 24<br>
date-format dd-mm-yy<br>
!<br>
!<br>
line con 0<br>
password 7 111F160C07060E1F10<br>
line aux 0<br>
line vty 0 4<br>
password 7 050F030A35424B1D<br>
line vty 5 15<br>
password 7 050F030A35424B1D<br>
!<br>
ntp clock-period 17180782<br>
ntp server <a href="http://10.0.9.1">10.0.9.1</a> prefer<br>
!<br>
end<br>
<br>
Message: 1<br>
Date: Thu, 24 Nov 2005 11:10:28 -0500<br>
From: "Ortiz, Carlos" <<a onclick="return top.js.OpenExtLink(window,event,this)" href="mailto:CORTIZ@broward.org">CORTIZ@broward.org</a>><br>
Subject: [cisco-voip] MGCP Fallback<br>
To: <<a onclick="return top.js.OpenExtLink(window,event,this)" href="mailto:cisco-voip@puck.nether.net">cisco-voip@puck.nether.net</a>><br>
Message-ID:<br>
<<a onclick="return top.js.OpenExtLink(window,event,this)" href="mailto:26B357EF9FB7D04A989C9E82A9E5436E01BC2AD4@MREXVS01.bc.broward.cty">26B357EF9FB7D04A989C9E82A9E5436E01BC2AD4@MREXVS01.bc.broward.cty</a>>
<br>
Content-Type: text/plain; charset="us-ascii"<br>
<br>
Can someone post a known working config for MGCP Fallback to H.323 SRST<br>
using analog FXO ports and/or PRI. I am having a little trouble getting<br>
the outbound inbound calls working once the phones failover. In<br>
particular I need to see specific commands on Pots dial peers and what<br>
actually needs to be there.<br>
<br>
<br>
<br>
Not sure if I need incoming called number under each dial peer or a<br>
separate dial peer to catch the incoming call leg, etc. Any help would<br>
be appreciated.<br>
<br>
<br>
<br>
Thanks,<br>
<br>
<br>
<br>
Carlos<br>
<br>