[f-nsp] DSCP Marking on BigIrons

Sam Stickland sam_ml at spacething.org
Thu Feb 17 07:13:13 EST 2005


Hi,

I'm having some real trouble working out how to dscp mark packets on an 
incoming interface (either a vlan or a ve).

Looking at the qos functions there's only:

qos-tos mark dscp

The documentation has this to say on the subject:

 	qos mark cos

 	Syntax: [no] qos mark cos | dscp

 	The cos | dscp parameter specifies the type of marking.

 	    * cos - The device changes the outbound packet's 802.1Q
 	priority value to match the results of the device's QoS mapping
 	from the ToS value (IP precedence or DSCP) into the 802.1Q value.

 	    * dscp - The device changes the outbound packet's ToS value to
 	match the results of the device's QoS mapping from IP precedence
 	to	DSCP.

Which seems to imply that the device will map the outbound packets based on the 
IP precendence value. This isn't what I want to do here - I wish to mark 
packets as they arrive on an interface to a specific DCSP value.

We don't actually wish to do any QoS based on the DSCP value. We want to mark 
traffic from directly connected peers with a nominal DSCP value, which we use 
in policy routing in some places in our network.

For example, for billing purposes, we would rewrite the next-hop for destined 
for some customers and from a directly connected peer:

 	route-map  POLICY_PARTIAL permit  10
 	  match ip address  ACL_S_DIRECT_PEER
 	  match ip address prefix-list PFX_CUST_1
 	  set ip next-hop x.y.z.w

 	ip access-list extended ACL_S_DIRECT_PEER
 	  permit ip any any dscp-mapping 14
 	  deny ip any any

On our cisco's we mark the traffic thus:

 	class-map match-any CM_ANY
 	  match access-group name ACL_ANY
 	!
 	!
 	policy-map PM_MARK_DIRECT_PEER
 	  class CM_ANY
 	    set ip dscp 14

 	ip access-list extended ACL_ANY
 	  permit ip any any

 	int vlan xxx
 	  service-policy input PM_MARK_DIRECT_PEER

The Foundry's in our network are able to utilise this marking for policy 
routing as shown above, but I'm unable to figure out how to do the marking.

Is this possible on the BigIrons? If not would the NetIrons be capable?

Sam



More information about the foundry-nsp mailing list