[j-nsp] OSPF from secondary IP addresses

Raymond Cheh rcheh at juniper.net
Tue Oct 21 17:32:23 EDT 2003


One thing you can do is to specify the ip address as the interface in
ospf:

user at router# show interfaces
at-0/0/1 {
     atm-options {
         vpi 1 {
             maximum-vcs 1200;
         }
     }
     unit 0 {
         vci 1.100;
         family inet {
             address 192.168.201.42/30;
         }
     }
}
fe-0/1/0 {
     unit 0 {
         family inet {
             address 10.0.0.1/30;
             address 192.168.202.41/30;
         }
     }
}


user at router# show protocols
ospf {
     area 0.0.0.0 {
         interface lo0.0;
         interface at-0/0/1.0;
     }
     area 0.0.0.2 {
         interface 192.168.202.41;
     }
}

In this case, if you have multiple addresses, you can specify the one
you'd want ospf to be enabled.

Hope this helps.

Raymond

Chris Hellberg wrote:
> Have you tried putting a preferred keyword under the address config stanza in the interface?
> 
> http://www.juniper.net/techpubs/software/junos/junos56/swconfig56-interfaces/html/interfaces-family-config12.html
> 
> 
> 
>>-----Original Message-----
>>From: Vlad [mailto:vlad at doom.net]
>>Sent: Wednesday, 22 October 2003 10:14
>>To: juniper-nsp at puck.nether.net
>>Subject: [j-nsp] OSPF from secondary IP addresses
>>
>>
>>Hello,
>>
>>I have a Juniper m20 with a GigE interface and multiple IP addresses
>>configured on that interface (secondary IP addresses in cisco speak).
>>I can form OSPF adjacency with other equipment on my network 
>>just fine.
>>However it appears my Juniper is also trying to form 
>>adjacency from the other
>>IP addresses configured on the GigE.   My other network 
>>equipment doesn't have
>>those networks configured on any interface, so a tcpdump on a 
>>workstation or
>>'debug ip ospf adj' on cisco  will show:
>>
>>*Oct 15 12:57:12: OSPF: Rcv pkt from 2.5.240.6, 
>>GigabitEthernet0/0/0, area 0.0.0.0 : src not on the same network
>>*Oct 15 12:57:13: OSPF: Rcv pkt from 2.2.13.1, 
>>GigabitEthernet0/0/0, area 0.0.0.0 : src not on the same network
>>*Oct 15 12:57:13: OSPF: Rcv pkt from 2.2.37.1, 
>>GigabitEthernet0/0/0, area 0.0.0.0 : src not on the same network
>>*Oct 15 12:57:13: OSPF: Rcv pkt from 2.2.41.1, 
>>GigabitEthernet0/0/0, area 0.0.0.0 : src not on the same network
>>*Oct 15 12:57:13: OSPF: Rcv pkt from 2.5.251.1, 
>>GigabitEthernet0/0/0, area 0.0.0.0 : src not on the same network
>>
>>It appears the Juniper is trying to form adjacency and sourcing OSPF
>>packets from every single IP addresses configured on my Junipers' GigE
>>interface.  I only want OSPF packets to be sourced from one particular
>>network.
>>
>>I believe I'm looking for juniper  equivalent to ciscos 
>>'network 2.5.224.0 0.0.0.255' configuration directive under 
>>'router ospf'
>>
>>Does such a thing exist, or do I have to craft something with a policy
>>or filter?  Or is something else going on?
>>
>>Thanks
>>-v
>>
>>
>>My Juniper config:
>>
>>foo> show configuration protocols ospf   
>>export ospf-out;
>>area 0.0.0.0 {
>>    interface ge-0/0/0.0;
>>}
>>
>>foo> show configuration policy-options policy-statement ospf-out 
>>term 5 {
>>    from protocol [ static direct ];
>>    then accept;
>>}
>>then reject;
>>
>>
>>My cisco config:
>>
>>foo#sh run | begin ospf
>>router ospf 100
>> router-id 2.5.224.3
>> log-adjacency-changes
>> redistribute connected subnets
>> redistribute static subnets
>> passive-interface default
>> no passive-interface GigabitEthernet0/0/0
>> network 2.5.224.0 0.0.0.255 area 0.0.0.0
>>!
>>
>>-v
>>_______________________________________________
>>juniper-nsp mailing list juniper-nsp at puck.nether.net
>>http://puck.nether.net/mailman/listinfo/juniper-nsp
>>
>>
> 
> 
> ------------------------------------------------------------------------------
> "This communication, including any attachments, is confidential. 
> If you are not the intended recipient, you should not read
> it - please contact me immediately, destroy it, and do not
> copy or use any part of this communication or disclose
> anything about it. Thank you."
> ------------------------------------------------------------------------------
> 
> 
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> http://puck.nether.net/mailman/listinfo/juniper-nsp
> 
> 




More information about the juniper-nsp mailing list