[j-nsp] Juniper - Redback Martini interop testing

Umar Ahmed Umar.Ahmed at vanco.co.uk
Thu Feb 17 01:31:55 EST 2005


Hi Stefan, as requested :

Redback config :


Current configuration:
!
context local
!
!
 interface 4/10
!
 interface 4/12
  ip address 10.10.10.1/30
!
 interface L2VPN
!
!
 interface loopback loopback
  ip address 2.2.2.2/32
!
 interface xcrp
  ip address 10.69.10.20/16
   ip source-address snmp
 no logging console
 ip soft-gre source 192.168.201.230
!
 router isis isis
  net 49.0001.1234.5678.2222.00
  is type level-2-only
  traffic-engineering level-2
  address-family ipv4 unicast
   redistribute static route-map export-stat
 !
  interface loopback
   passive-interface
   address-family ipv4 unicast
 !
  interface 4/12
   ! bind to ethernet 4/12
   address-family ipv4 unicast
!
!
 ip prefix-list statics
  seq 10 permit 32.10.4.2/32 eq 32
!
 route-map export-stat permit 10
  match ip address prefix-list statics
 route-map export-stat deny 20
!
 router mpls
  interface loopback
  interface 4/12
!
 router rsvp
  explicit-null
  interface loopback
  interface 4/12
  lsp rb-m5
   ingress 2.2.2.2
   egress 1.1.1.1
!
 router ldp
  router-id 2.2.2.2
  neighbor 1.1.1.1 targeted
  interface loopback
  interface 4/12
  interface 4/10
!
 router bgp <AS number>
  address-family ipv4 unicast
   redistribute connected
   network 192.168.201.230/32
!
  neighbor 1.1.1.1 internal
   update-source loopback
   address-family ipv4 unicast
   address-family ipv4 vpn
!
!
 ip route 32.10.4.2/32 null0
 service ssh
 service telnet
!
 l2vpn
  l2vpn-cct-bindings ldp
   xc 4/10 vlan-id 512 vc-id 1 peer 1.1.1.1
!
end




Current configuration:
!
context L2VPN
!
!
 interface ce
  ip address 5.5.5.2/24
 no logging console
!
end

Thanks,

Umar.

-----Original Message-----
From: Stefan Fouant [mailto:sfouant at gmail.com] 
Sent: 16 February 2005 22:08
To: Umar Ahmed
Cc: juniper-nsp at puck.nether.net
Subject: Re: [j-nsp] Juniper - Redback Martini interop testing

Can you post the Redback config as well?  Cheers,

Stefan

Umar Ahmed wrote:
> Hi all,
>  
> I am banging my head against a brick wall trying to get some simple 
> Martini working between an M5 and Redback SE400 back to back. The goal 
> is for the CE on the M5 (5.5.5.1/24) to talk to the same VLAN on the 
> other end of the Redback CE (5.5.5.2/24)!!!
>  
> The config is :  Redback----FE----M5
>  
> Detailed diagram, pardon the ascii art:)  : Redback(l/b 
> 2.2.2.2)------FE------M5(l/b 1.1.1.1)
>  
>  
> <outbind://10-00000000620D89607FAA314D9364E95DBED426AB07008783ED227BD5
> A94CB6 
> 11462050ABE53C000003CE56F400008783ED227BD5A94CB611462050ABE53C00000A9D
> B31400 00/cid:image001.jpg at 01C5144B.77E7F480>
>  
> For those of you who dont know, the Redback is a VR, so I've split it 
> in two
> - one half is the core PE device talking to the M5 and the other half 
> is its own CE with a Vlan configured simulating the customer equipment 
> - this is the same for the M5.
>  
> I am seeing the following on the juniper which is showing the 
> l2circuit as down :
>  
> M5> show l2circuit connections down extensive neighbor 2.2.2.2
> Layer-2 Circuit Connections:
>  
> Legend for connection status (St)
> EI -- encapsulation invalid      NP -- interface h/w not present
> MM -- mtu mismatch               Dn -- down
> EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down
> CM -- control-word mismatch      Up -- operational
> VM -- vlan id mismatch           CF -- Call admission control failure
> OL -- no outgoing label          XX -- unknown
> NC -- intf encaps not CCC/TCC
> CB -- rcvd cell-bundle size bad
>  
> Legend for interface status
> Up -- operational
> Dn -- down
>  
> Neighbor: 2.2.2.2
>     Interface                 Type  St     Time last up          # Up
trans
>     fe-0/0/2.512(vc 1)        rmt   OL
> 
> LDP is up :
>  
> M5> show ldp neighbor
> Address            Interface          Label space ID         Hold time
> 10.10.10.1         fe-0/0/0.0         2.2.2.2:0                12
> 2.2.2.2            lo0.0              2.2.2.2:0                13
> 
> also route is in the RT:
>  
> l2circuit.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
> + = Active Route, - = Last Active, * = Both
>  
> 2.2.2.2:CtrlWord:4:1:Local/96
>                    *[L2CKT/7] 05:50:26
>                     > to 10.10.10.1 via fe-0/0/0.0
> 
> What am I missing .. many thanks for your help guys !!
>  
>  
> The juniper config is :
>  
> logical-routers {
>     CE1 {
>         interfaces {
>             fe-0/0/3 {
>                 unit 0 {
>                     vlan-id 512;
>                     family inet {
>                         address 5.5.5.1/24;
>                     }
>          .....
> interfaces {
>     fe-0/0/0 {
>         unit 0 {
>             family inet {
>                 address 10.10.10.2/30;
>             }
>             family iso;
>             family mpls;
>         }
>     }
>     fe-0/0/2 {
>         vlan-tagging;
>         speed 100m;
>         mtu 1500;
>         link-mode full-duplex;
>         encapsulation vlan-ccc;
>         unit 512 {
>             encapsulation vlan-ccc;
>             vlan-id 512;
>         }
>     }
>     fe-0/0/3 {
>         vlan-tagging;
>     }
> lo0 {
>         unit 0 {
>             family inet {
>                 address 1.1.1.1/32;
>             }
>             family iso {
>                 address 49.0001.1234.5678.1111.00;
>             }
>         }
>     }
> }
> mpls {
>         traceoptions {
>             file mplslog;
>             flag error;
>         }
>         no-cspf;
>         label-switched-path m5-rb {
>             from 1.1.1.1;
>             to 2.2.2.2;
>         }
>         interface all;
>         interface fxp0.0 {
>             disable;
> isis {
>         level 1 disable;
>         interface all;
>         interface fxp0.0 {
>             disable;
>         }
>     }
>     ldp {
>         interface all;
>         interface fxp0.0 {
>             disable;
>         }
>     }
>     l2circuit {
>         neighbor 2.2.2.2 {
>             interface fe-0/0/2.512 {
>                 virtual-circuit-id 1;
>             }
>  
>  
>  
> 
> Regards,
> 
> Umar Ahmed


**********************************************************************
Any opinions expressed in the email are those of the individual and not necessarily the company. This email and any files transmitted with it are confidential and solely for the use of the intended recipient.  If you are not the intended recipient or the person responsible for delivering it to the intended recipient, be advised that you have received this email in error and that any dissemination, distribution, copying or use is strictly prohibited.

If you have received this email in error, or if you are concerned with the content of this email please e-mail to: e-security.support at vanco.info

The contents of an attachment to this e-mail may contain software viruses which could damage your own computer system. While the sender has taken every reasonable precaution to minimise this risk, we cannot accept liability for any damage which you sustain as a result of software viruses. You should carry out your own virus checks before opening any attachments to this e-mail. 
**********************************************************************



More information about the juniper-nsp mailing list