[j-nsp] Re: VLAN tagging

Nuno Vieira nuno.vieira at nfsi.pt
Mon Jan 17 23:24:12 EST 2005


You should fix that with:

set int fe-0/0/1 unit 0 vlan-id 0
set int fe-0/0/1 unit 100 vlan-id 100
set int fe-0/0/1 unit 200 vlan-id 200

Regards,
-- 
Nuno Vieira
NFSi - Soluções Internet, Lda.
Chief Technical Officer

Office Phone  : +351 244 145615
Mobile Phone  : +351 91 6184656
General Phone : +351 244 145600 (ext. 15)
Fax           : +351 244 145601


Craig Pierantozzi wrote:
> VLAN tagging is set on the physical and then 
> you break it into logical units on the M series. 
> You shouldn't be able to do this without a commit
> error:
> 
> ---snip---
> router# show interfaces fe-0/0/1 
> vlan-tagging;
> unit 0 {
>     family inet {
>         address 192.168.1.1/30;
>     }
> }
> unit 100 {
>     vlan-id 100;
>     family inet {
>         address 10.100.100.1/30;
>     }
> }
> unit 200 {
>     vlan-id 200;
>     family inet {
>         address 10.200.200.1/30;
>     }
> }
> 
> [edit]
> router# commit check 
> [edit interfaces fe-0/0/1]
>   'unit 0'
>      VLAN-ID must be specified on tagged ethernet interfaces
> error: configuration check-out failed
> 
> ---snip---
> 
> regards
> -Craig
> 
> * Thus spake Thomas Salmen (tsalmen at orcon.net.nz):
> 
> 
>>Hello,
>>
>>On a Cisco router, it is possible to do this:
>>
>>interface FastEthernet4/0
>> ip address 192.168.1.1 255.255.255.252
>>!
>>interface FastEthernet4/0.100
>>encapsulation dot1Q 100
>> ip address 10.100.100.1 255.255.255.252
>>!
>>interface FastEthernet4/0.200
>>encapsulation dot1Q 200
>>ip address 10.200.200.1 255.255.255.252
>>
>>That is, add VLAN-tagged logical subinterfaces to a non-tagged physical
>>interface.
>>
>>Does anyone know if this can be duplicated on an M-series?
>>
>>Cheers,
>>Thomas 
>>
>>
>>_______________________________________________
>>juniper-nsp mailing list juniper-nsp at puck.nether.net
>>http://puck.nether.net/mailman/listinfo/juniper-nsp
> 
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> http://puck.nether.net/mailman/listinfo/juniper-nsp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nuno.vieira.vcf
Type: text/x-vcard
Size: 356 bytes
Desc: not available
Url : https://puck.nether.net/pipermail/juniper-nsp/attachments/20050117/0feafc68/nuno.vieira.vcf


More information about the juniper-nsp mailing list