[j-nsp] multiple bgp routing-instances on one router

Jake Bourgeois jbourg at jtac.juniper.net
Fri Nov 11 13:00:06 EST 2005


If I understand your ultimate goal here you'll want something like this


show routing-options

rib-groups {
    common {
        import-rib [ partial.inet.0 integral.inet.0 ];
    }
}




routing-instances {
    Integral {
        description Integral-VRF-Table;
        instance-type vrf;
        interface ge-1/3/0.200;
        route-distinguisher 9991:0;
        vrf-target import target:9991:0;
        vrf-target export target:9991:1111;
        protocols {
            bgp {
                group Local {
                      family inet {
                          unicast {
                             rib-group common; <<------
                    type internal;
                    neighbor 9.9.9.2;
                } 
            }
        }
    }
    Partial {
        description Partial-VRF-Table;
        instance-type vrf;
        interface ge-1/3/0.100;
        route-distinguisher 9991:1111;
        vrf-target import target:9991:1111;
        vrf-target export target:9991:0;
        protocols {
            bgp {
                group External {
                    type external;
                         family inet {
                             unicast {
                                rib-group common; <<----
                    }
                    neighbor 1.1.1.2 {
                        peer-as 1111;
                    }
                }
            }
        }
    }
}

For more info check
https://www.juniper.net/techpubs/software/junos/junos70/swconfig70-routi
ng/html/routing-generic-config6.html

hths



> -----Original Message-----
> From: juniper-nsp-bounces at puck.nether.net
> [mailto:juniper-nsp-bounces at puck.nether.net] On Behalf Of
> Dmitry Cherkasov
> Sent: Friday, November 11, 2005 10:21 AM
> To: juniper-nsp at puck.nether.net
> Subject: [j-nsp] multiple bgp routing-instances on one router
>
> Hello everybody,
>
> What I try to do is the following:
>
> 1) separate routing instances for BGP tables from 3 eBGP neighbors
> 2) integral BGP-table for iBGP neighbors
>
> Routes are exported from eBGP tables to iBGP table and from iBGP table
> to eBGP tables.
>
> JunOS 7.3, router M7i
>
> Here is the configuration:
>
> interfaces {
>       unit 100 {
>               description eBGP-neighbor-1
>               vlan-id 100;
>               family inet {
>                       address 1.1.1.1/30;
>               }
>       }
>
> ... similar for other eBGP-neighbors ...
>
>         unit 200 {
>                 description iBGP-neighbor
>                 vlan-id 200;
>                 family inet {
>                         address 9.9.9.1/30;
>                 }
>         }
> }
> routing-options {
>       router-id 9.9.9.1;
>       autonomous-system 9991;
> }
> routing-instances {
>     Integral {
>         description Integral-VRF-Table;
>         instance-type vrf;
>         interface ge-1/3/0.200;
>         route-distinguisher 9991:0;
>         vrf-target import target:9991:0;
>         vrf-target export target:9991:1111;
>         protocols {
>             bgp {
>                 group Local {
>                     type internal;
>                     neighbor 9.9.9.2;
>                 } 
>             }
>         }
>     }
>     Partial {
>         description Partial-VRF-Table;
>         instance-type vrf;
>         interface ge-1/3/0.100;
>         route-distinguisher 9991:1111;
>         vrf-target import target:9991:1111;
>         vrf-target export target:9991:0;
>         protocols {
>             bgp {
>                 group External {
>                     type external;
>                     neighbor 1.1.1.2 {
>                         peer-as 1111;
>                     }
>                 }
>             }
>         }
>     }
> }
>
> Yet it does not work: the routes visible by 'show route table
> Partial.inet.0' does not appear in 'show route table Integral.inet.0'
>
> Please advice, what I'm doing wrong?
>
>
> --
> -------------------------------------------------------
>  Dmitry Cherkasov   ISP "Intercom"   (380)44 251-12-88
>    http://www.intercom.net.ua    DC1-UANIC CHD1-RIPE
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> http://puck.nether.net/mailman/listinfo/juniper-nsp
>





More information about the juniper-nsp mailing list