[j-nsp] Trunking routed vlan interfaces on a Juniper mx960

Nilesh Khambal nkhambal at juniper.net
Fri Aug 21 13:38:24 EDT 2009


FYI

Thanks,
Nilesh

On 8/21/09 10:34 AM, "陈江" <ilovebgp4 at gmail.com> wrote:

interfaces {
ge-0/0/0 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 10;
}
}
}
ge-0/0/1 {
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list 1-4000;
}
}
}
irb {
unit 10 {
family inet {
address 10.0.0.3/29 <http://10.0.0.3/29>
}
}
}
}
}
}
}
bridge-domains {
vlan10 {
vlan-id 10;
routing-interface irb.10;
}
}


On Sat, Aug 22, 2009 at 12:48 AM, Nilesh Khambal <nkhambal at juniper.net> wrote:
Check the MX solution guide in documentation for latest JUNOS release.
You need to look for "interface-mode trunk", "bridge-domain
configuration" and "IRB interface configuration"

Thanks,
Nilesh


--------------------------------------------------
Sent from my mobile handheld device

On Aug 21, 2009, at 9:27 AM, "Michael Phung" <cytogen at gmail.com> wrote:

> Hello everyone,
>
> I just got my hands on a Juniper mx router and I'm starting the
> initial config in preparation to convert from Cisco. As I configure
> the interfaces, I can't seem to figure our how to create a routed vlan
> interface and have the ability to trunk it down multiple physical
> interfaces. I've looked up on the the web but was unable to find
> anything that direct describes what I'm trying to achieve.
>
> Below is a sample config from a Cisco;
>
> !
> spanning-tree mode pvst
> spanning-tree vlan 200 priority 8192
> !
> interface GigabitEthernet2/1
> switchport
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 200
> switchport mode trunk
> switchport nonegotiate
> !
> interface GigabitEthernet2/10
> switchport
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 200
> switchport mode trunk
> switchport nonegotiate
> !
> interface Vlan200
> ip address 10.10.10.2 255.255.255.192
> no ip redirects
> no ip unreachables
> no ip proxy-arp
> standby ip 10.10.10.1
> !
>
> Can this be done on a MX router? if so, can a sample config be
> provided?
>
> Any help would be much appreciated.
>
> Michael
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
_______________________________________________
juniper-nsp mailing list juniper-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp




More information about the juniper-nsp mailing list