[j-nsp] Trunking routed vlan interfaces on a Juniper mx960

Nilesh Khambal nkhambal at juniper.net
Fri Aug 21 15:00:53 EDT 2009


Dan,

This EX switch configuration. Original post requested configuration for MX Switches.

Thanks,
Nilesh.


On 8/21/09 11:45 AM, "Dan Farrell" <danno at appliedi.net> wrote:

This is how I do it... if this is not a recommended method, please let me know (PLEASE!) I currently configure around 90 L3 interfaces in this manner right now.

interfaces {
        ge-0/0/20 {
        description "physical port";
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                native-vlan-id 3007;
            }
        }
        }

        vlan {
         unit 98 {
                    description "prov - vlan 98 - 8.0.0.0/30 - pri-switch - fa0/3";
                    family inet {
                 address 8.0.0.1/30;
             }
                }

                 unit 4070 {
                    description "psc - vlan 4070 - 10.254.0.128/26";
                 family inet {
                          address 10.254.0.129/26;
                    }
                }
                  }

vlans {
        prov {
        description "prov - vlan 98 - 8.0.0.0/30 - pri-switch - fa0/3";
        vlan-id 98;
        interface {
            ge-0/0/20.0;
            ge-0/0/1.0;
        }
        l3-interface vlan.98;
    }

        psc {
        description "psc - vlan 4070 - 10.254.0.128/26";
        vlan-id 4070;
        interface {
            ge-0/0/20.0;
        }
        l3-interface vlan.4070;
    }


Thanks,


Dan

-----Original Message-----
From: juniper-nsp-bounces at puck.nether.net [mailto:juniper-nsp-bounces at puck.nether.net] On Behalf Of ??
Sent: Friday, August 21, 2009 1:34 PM
To: Michael Phung
Cc: juniper-nsp at puck.nether.net
Subject: Re: [j-nsp] Trunking routed vlan interfaces on a Juniper mx960

interfaces {
    ge-0/0/0 {
        unit 0 {
            family bridge {
                interface-mode access;
                vlan-id 10;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 1-4000;
            }
        }
    }
    irb {
        unit 10 {
            family inet {
                address 10.0.0.3/29
                        }
                    }
                }
            }
        }
    }
}
bridge-domains {
    vlan10 {

        vlan-id 10;
        routing-interface irb.10;
    }
}

On Sat, Aug 22, 2009 at 12:23 AM, Michael Phung <cytogen at gmail.com> wrote:

> Hello everyone,
>
> I just got my hands on a Juniper mx router and I'm starting the
> initial config in preparation to convert from Cisco. As I configure
> the interfaces, I can't seem to figure our how to create a routed vlan
> interface and have the ability to trunk it down multiple physical
> interfaces. I've looked up on the the web but was unable to find
> anything that direct describes what I'm trying to achieve.
>
> Below is a sample config from a Cisco;
>
> !
> spanning-tree mode pvst
> spanning-tree vlan 200 priority 8192
> !
> interface GigabitEthernet2/1
>  switchport
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 200
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface GigabitEthernet2/10
>  switchport
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 200
>  switchport mode trunk
>  switchport nonegotiate
> !
> interface Vlan200
>  ip address 10.10.10.2 255.255.255.192
>  no ip redirects
>  no ip unreachables
>  no ip proxy-arp
>  standby ip 10.10.10.1
> !
>
> Can this be done on a MX router? if so, can a sample config be provided?
>
> Any help would be much appreciated.
>
> Michael
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>



--
BR!



          James Chen
_______________________________________________
juniper-nsp mailing list juniper-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
_______________________________________________
juniper-nsp mailing list juniper-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp



More information about the juniper-nsp mailing list