[j-nsp] M7i and equal cost static routes

Chris Grundemann cgrundemann at gmail.com
Mon Jan 26 11:21:45 EST 2009


On Mon, Jan 26, 2009 at 04:25, Samit <janasamit at wlink.com.np> wrote:
> Hi,
>
> My upstream has Cisco router  and I have 2xSTM-1 connected with my Cisco
> router. We have 2 equal cost static routes in loopback address in order
> to load balance the traffic, I believe it is "per-destination" both
> side. I want to replace my end Cisco router with M7i and below is my
> interface and static routes config. Unfortunately I don't have any Cisco
> router with STM interfaces to test.  As I don't want my upstream to make
> any changes are there any thing I need to look at?

I don't want to speak to the interface configs specifically but I
think I can shed some light on your BGP and routing questions:

> I can only see "per-packet" load balancing option in policy?

The default load balancing will be equal cost (per prefix), if you
enable 'per-packet' the load balancing will actually be per flow (the
syntax is left over from earlier JUNOS versions which attempted actual
per packet load balancing).

> Do I need "multipath" in bgp as well?

You will need to enable 'multihop' (not multipath) for this BGP
session and configure a 'local-address' (most likely your loopback
address - whatever address the upstream is peering with today).

Something like this:

group test {
    multihop;
    local-address 172.16.1.1;
    peer-as 65111;
    neighbor 192.168.1.1;
}

>
> Current Cisco config:
>
> interface POS1/0
>  description 1st Link
>  ip address 172.16.0.1 255.255.255.252
>
> interface POS2/0
>  description 2nd Link
>  ip address 172.16.1.1 255.255.255.252
>
> ip route 192.168.1.1 255.255.255.255 POS1/0
> ip route 192.168.1.1 255.255.255.255 POS2/0
>
> 192.168.1.1 is my remote peer's loopback doing eBgp
>
>
> My juniper config:
>
> so-0/1/0 {
>        description "1st Link ";
>        encapsulation cisco-hdlc;
>        sonet-options {
>            no-payload-scrambler;
>        }
>        unit 0 {
>            family inet {
>                address 172.16.0.1/30;
>            }
>        }
> so-0/1/1 {
>        description "2nd Link ";
>        encapsulation cisco-hdlc;
>        sonet-options {
>            no-payload-scrambler;
>        }
>        unit 0 {
>            family inet {
>                address 172.16.1.1/30;
>            }
>        }

Your interface config looks ok to me but I am no expert on Cisco
interfaces - I will let someone else speak to that more specifically.

>
> routing-options {
>    static {
>        route 192.168.1.1/32 next-hop [ so-0/1/0.0 so-0/1/1.0 ];

This static route config looks good.


Good luck,
~Chris

>
>
> Regards,
> Samit
>
>
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>



-- 
Chris Grundemann
www.chrisgrundemann.com


More information about the juniper-nsp mailing list