[j-nsp] MPLS Layer 2 backaul on EX/MX

Jay Hanke jhanke at myclearwave.net
Thu Oct 8 21:07:03 EDT 2009


## Here is a sample MX config:

 

chassis {

    fpc 0 {

        pic 0 {

            tunnel-services {

                bandwidth 1g;

            }

        }

    }

}

interfaces {

    ge-0/0/0 {

        encapsulation ethernet-ccc;

        unit 0 {

            family ccc;

        }

    }

    ge-0/0/1 {

        unit 0 {

            family inet {

                address 1.1.1.2/30;

            }

            family mpls;

        }

    }

    lt-0/0/10 {

        unit 0 {

            encapsulation ethernet-ccc;

            peer-unit 1;

            family ccc;

        }

        unit 1 {

            encapsulation ethernet;

            peer-unit 0;

            family inet {

                address 3.3.3.2/30;

            }

        }

    }

    lo0 {

        unit 0 {

            family inet {

                address 11.11.11.2/32;

            }

        }

    }

}

protocols {

    rsvp {

        interface ge-0/0/1.0;

    }

    mpls {

        label-switched-path to_snow {

            to 11.11.11.1;

        }

        label-switched-path to_snow2 {

            to 11.11.11.1;

        }

        interface ge-0/0/1.0;

    }

    ospf {

        traffic-engineering;

        area 0.0.0.0 {

            interface ge-0/0/1.0;

            interface lo0.0;

        }

    }

    connections {

        remote-interface-switch to_snow {

            interface ge-0/0/0.0;

            transmit-lsp to_snow;

            receive-lsp to_hunk;

        }

        remote-interface-switch to_snow2 {

            interface lt-0/0/10.0;

            transmit-lsp to_snow2;

            receive-lsp to_hunk2;

        }

    }

}

 

 

## and on the EX

 

 

interfaces {

    ge-0/0/1 {

        unit 0 {

            family ccc;

        }

    }

    ge-0/0/2 {

        unit 0 {

            family inet {

                address 1.1.1.1/30;

            }

            family mpls;

        }

    }

    ge-0/0/3 {

        unit 0 {

            family ccc;

        }

    }

    lo0 {

        unit 0 {

            family inet {

                address 11.11.11.1/32;

            }

        }

    }               

}

protocols {

    rsvp {

        interface ge-0/0/2.0;

    }

    ##

    ## Warning: requires 'mpls' license

    ##

    mpls {

        label-switched-path to_hunk {

            to 11.11.11.2;

        }

        label-switched-path to_hunk2 {

            to 11.11.11.2;

        }

        interface ge-0/0/2.0;

    }

    ospf {

        traffic-engineering;

        area 0.0.0.0 {

            interface ge-0/0/2.0;

            interface lo0.0;

        }           

    }

    connections {

        remote-interface-switch to_hunk {

            interface ge-0/0/1.0;

            transmit-lsp to_hunk;

            receive-lsp to_snow;

        }

        remote-interface-switch to_hunk2 {

            interface ge-0/0/3.0;

            transmit-lsp to_hunk2;

            receive-lsp to_snow2;

        }

    }

    igmp-snooping {

        vlan all;

    }

    lldp {

        interface all;

    }

    lldp-med {

        interface all;

    }

}                   

ethernet-switching-options {

    voip;

}

 

 

From: dotwaffle at gmail.com [mailto:dotwaffle at gmail.com] On Behalf Of Matthew Walster
Sent: Thursday, October 08, 2009 7:37 PM
To: Jay Hanke
Cc: juniper-nsp at puck.nether.net
Subject: Re: [j-nsp] MPLS Layer 2 backaul on EX/MX

 

2009/10/9 Jay Hanke <jhanke at myclearwave.net>

The logical tunnel trick on the MX works great (THANKS ALL!) but only for Ethernet-ccc (not vlan-ccc) from an EX series switch. JTAC is looking at vlan-ccc issue. The vlan-ccc works if you come in from a M series router, but not EX.


As I was only theorising at the time, I'd be interested to see the relevant configuration parts - would you mind posting them here for record? Obviously, obfuscate anything sensitive ;)
 
Thanks for the update!

Matthew Walster



More information about the juniper-nsp mailing list