[j-nsp] VRF load balancing between pair of j-MX480 PEs and pair of c-7609 PEs

Sorilla, Edmar (NSN - AE/Dubai) edmar.sorilla at nsn.com
Mon Feb 15 15:01:08 EST 2010


Dear Experts,

We are integrating a pair of MX480 (PE) to a Cisco based IP network and
we are  having problem with VRF load balancing.We cannot ping all
connected interfaces (only some of them can be pinged) of the Cisco
routers from Juniper routers. Below are the configuration excerpts of
the routers. If we try to remove the "maximum-paths eibgp 2 " command
from cisco address family ipv4, everything works fine (all routed
interfaces of cisco are reachable from Juniper). But this command is
required by the network to load balance the VRF traffics on the two PEs
of every site. This configuration is loaded to all cisco PE routers of
the network and we cannot easily remove it from all cisco PE routers.

If you had experienced this kind of setup please share with us the
working configuration. Or if you have any suggestion to share I will be
very grateful. The routers are: MX480-1 and MX480-2 in one site and
OSR-1 and OSR-2 on another site.

Thank you in advance.

Br,
Edmar

 
------------------------------------------------------------------------
----------------------------------------------------------------------
MX-480-1
 bgp {
        traceoptions {
            file bgp.log size 5m files 10;
            flag general;
            flag open;
            flag state;
        }
        hold-time 20;
        log-updown;
        group mpbgp-peer {
            type internal;
            local-address 10.44.105.3;
            family inet {
                unicast;
            }
            family inet-vpn {
                unicast;
            }
            authentication-key "$9$5z6AleWxNbIEclKvLXUji.Tz"; ##
SECRET-DATA
            peer-as 15802;
            multipath multiple-as;
            neighbor 10.19.56.141 {
                description "**** MPIBGP with dxbor01 ****";
                peer-as 15802;
            }
            neighbor 10.19.56.143 {
                description "**** MPIBGP with auhor01 ****";
                peer-as 15802;
            }
        }
    }

}

routing-instances {
}
    Huawei_Iu-U {
        instance-type vrf;
        interface irb.201;
        route-distinguisher 15802:3201;
        vrf-import Huawei_Iu_U_import;
        vrf-export Huawei_Iu_U_export;
        vrf-table-label;
        routing-options {
            static {
                route 94.201.225.3/32 next-hop 10.164.128.36;
                route 94.201.225.4/32 next-hop 10.164.128.37;
                route 94.201.225.5/32 next-hop 10.164.128.38;
                route 94.201.225.6/32 next-hop 10.164.128.39;
                route 94.201.225.7/32 next-hop 10.164.128.40;
                route 94.201.225.8/32 next-hop 10.164.128.41;
                route 94.201.225.9/32 next-hop 10.164.128.42;
            }
            multipath;
        }
    }
 
------------------------------------------------------------------------
----------------------------------------------------------------------
MX-480-2
bgp {
        traceoptions {
            file bgp.log size 5m files 10;
            flag general;
            flag open;
            flag state;
        }
        hold-time 20;
        log-updown;
        group mpbgp-peer {
            type internal;
            local-address 10.44.105.4;
            family inet {
                unicast;
            }
            family inet-vpn {
                unicast;
            }
            authentication-key "$9$Uqi.5OBEylM/CtO1IcSwY2aDi"; ##
SECRET-DATA
            peer-as 15802;
            multipath multiple-as;
            neighbor 10.19.56.141 {
                description "**** MPIBGP with dxbor01 ****";
                peer-as 15802;
            }
            neighbor 10.19.56.143 {
                description "**** MPIBGP with auhor01 ****";
                peer-as 15802;
            }


routing-instances {
}
    Huawei_Iu-U {
        instance-type vrf;
        interface irb.201;
        route-distinguisher 15802:13201;
        vrf-import Huawei_Iu_U_import;
        vrf-export Huawei_Iu_U_export;
        vrf-table-label;
        routing-options {
            static {
                route 94.201.225.3/32 next-hop 10.164.128.36;
                route 94.201.225.4/32 next-hop 10.164.128.37;
                route 94.201.225.5/32 next-hop 10.164.128.38;
                route 94.201.225.6/32 next-hop 10.164.128.39;
                route 94.201.225.7/32 next-hop 10.164.128.40;
                route 94.201.225.8/32 next-hop 10.164.128.41;
                route 94.201.225.9/32 next-hop 10.164.128.42;
            }
            multipath;
        }
    }
 
------------------------------------------------------------------------
----------------------------------------------------------------------
OSR-1
!
ip vrf Huawei_Iu-U
 description Huawei RNC User Plane
 rd 15802:3210
 route-target export 15802:3210
 route-target export 15802:3201
 route-target import 15802:3220
 route-target import 15802:3210
 route-target import 15802:3201
!
!
router bgp 15802
 bgp router-id 10.44.105.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp graceful-restart restart-time 120
 bgp graceful-restart stalepath-time 360
 bgp graceful-restart
 bgp bestpath med missing-as-worst
 timers bgp 5 20
 neighbor mpbgp-peer peer-group
 neighbor mpbgp-peer remote-as 15802
 neighbor mpbgp-peer password 7 02080B5002075E731F
 neighbor mpbgp-peer update-source Loopback0
 neighbor 10.19.56.141 peer-group mpbgp-peer
 neighbor 10.19.56.141 description **** MPIBGP with dxbor01 ****
 neighbor 10.19.56.143 peer-group mpbgp-peer
 neighbor 10.19.56.143 description **** MPIBGP with auhor01 ****
 !
 !
 address-family ipv4 vrf Huawei_Iu-U
  no synchronization
  redistribute connected
  redistribute static
  maximum-paths eibgp 2
  exit-address-family
 !
 
------------------------------------------------------------------------
----------------------------------------------------------------------
OSR-2

!
ip vrf Huawei_Iu-U
 description Huawei RNC User Plane
 rd 15802:13210
 route-target export 15802:3210
 route-target export 15802:3201
 route-target import 15802:3220
 route-target import 15802:3210
 route-target import 15802:3201
!
!
router bgp 15802
 bgp router-id 10.44.105.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp graceful-restart restart-time 120
 bgp graceful-restart stalepath-time 360
 bgp graceful-restart
 bgp bestpath med missing-as-worst
 timers bgp 5 20
 neighbor mpbgp-peer peer-group
 neighbor mpbgp-peer remote-as 15802
 neighbor mpbgp-peer password 7 02080B5002075E731F
 neighbor mpbgp-peer update-source Loopback0
 neighbor 10.19.56.141 peer-group mpbgp-peer
 neighbor 10.19.56.141 description **** MPIBGP with dxbor01 ****
 neighbor 10.19.56.143 peer-group mpbgp-peer
 neighbor 10.19.56.143 description **** MPIBGP with auhor01 ****
 !
 !
 address-family ipv4 vrf Huawei_Iu-U
  no synchronization
  redistribute connected
  redistribute static
  maximum-paths eibgp 2
  exit-address-family
 !
 
------------------------------------------------------------------------
----------------------------------------------------------------------







More information about the juniper-nsp mailing list