[j-nsp] Understanding DPC Cards

Nilesh Khambal nkhambal at juniper.net
Tue May 4 20:28:23 EDT 2010


On MX, you can create access-ports connected to the hosts using
"interface-mode access" with a unique vlan id assigned to the port. This is
conceptually similar to "switchport mode access" on Cisco.

With either "interface-mode access" you do not need to explicitly assign the
logical unit to the bridge-domain. It automatically gets assigned to the
bridge-domain configured with same vlan-id. For.e.g.

[edit]
lab at re0-MX960# show interfaces ge-1/1/1
unit 0 {
    family bridge {
        interface-mode access;
        vlan-id 61;
    }
}

[edit]
lab at re0-MX960# show bridge-domains vlan-61
domain-type bridge;
vlan-id 61;  <<<< 
 
[edit]
lab at re0-MX960#


With this configuration, ge-1/1/1.0 is automatically part of bridge domain
"vlan-61". Now if you want to enable routing on this bridge (RVI in Cisco),
you can configure IRB interface and assign this irb logical unit to this
bridge-domain.

[edit]
lab at re0-MX960# show interfaces irb unit 61
family inet {
    address 1.2.3.4/24;
}
 
[edit]
lab at re0-MX960#

[edit]
lab at re0-MX960# show bridge-domains vlan-61
domain-type bridge;
vlan-id 61;
routing-interface irb.61;
 
[edit]
lab at re0-MX960#

[edit]
lab at re0-MX960# run show bridge domain bridge-domain vlan-61
 
Routing instance        Bridge domain            VLAN ID     Interfaces
default-switch          vlan-61                  61
                                                             ge-1/1/1.0
 
[edit]
lab at re0-MX960#

If you add more interfaces to vlan 61 as access ports, they will get
assigned to the same bridge-domain. It will do a switching between the ports
in the same bridge-domain and will do routing to destinations outside
bridge-domain via irb interface.

When you create a trunk carrying the same vlan id 61, it will also become
part of the same bridge domain.

[edit]
lab at re0-MX960# show interfaces ge-1/1/2
unit 0 {
    family bridge {
        interface-mode trunk;
        vlan-id-list [ 61 62 ];
    }
}
 
[edit]
lab at re0-MX960#

[edit]
lab at re0-MX960# run show bridge domain bridge-domain vlan-61
 
Routing instance        Bridge domain            VLAN ID     Interfaces
default-switch          vlan-61                  61
                                                             ge-1/1/1.0
                                                             ge-1/1/2.0
 
[edit]
lab at re0-MX960#

You will need a bridge-domain configuration for the vlan-ids configured on
the trunk port to instantiate the switching of that vlans in the forwarding
table. In the above configuration, vlan id 62 does not yet  have the
bridge-domain associated with it, so the trunk is not yet enabled to carry
its traffic. 


[edit]
lab at re0-MX960# run show bridge domain bridge-domain vlan-62
 
[edit]
lab at re0-MX960# set bridge-domains vlan-62 domain-type bridge
 
[edit]
lab at re0-MX960# set bridge-domains vlan-62 vlan-id 62
 
[edit]
lab at re0-MX960# commit
commit complete
 
[edit]
lab at re0-MX960# run show bridge domain bridge-domain vlan-62
 
Routing instance        Bridge domain            VLAN ID     Interfaces
default-switch          vlan-62                  62
                                                             ge-1/1/2.0
 
[edit]
lab at re0-MX960#


An access port can technically receive both tagged and untagged packets from
the host but it will only send untagged packets to the host connected to
port. A tagged port can send and receive only tagged packets. You can
configure a tagged port with a "native-vlan-id" for it enable receiving
untagged packets. It is somewhat similar to Cisco, where all untagged
traffic is assigned to vlan 1 by default and can be configured to  a
different vlan if needed. When you configure native-vlan-id, all the
untagged traffic is treated as being received over the vlan configured as
native vlan.

[edit]
lab at re0-MX960# show interfaces ge-1/1/2
native-vlan-id 62;
unit 0 {
    family bridge {
        interface-mode trunk;
        vlan-id-list [ 61 62 ];
    }
}
 
[edit]
lab at re0-MX960#


Hope this helps. I have seen other replies providing the information about
XDPC and RDPCs as well as flexible-ethernet-services so do not want to
repeat it here.

Thanks,
Nilesh.



On 5/4/10 4:01 PM, "Martin Levin" <martin.levin at molndal.se> wrote:

> I'll try to help... We also run MX and EX.
> 
> So, first off. MX and EX are not even remotely related in respect to
> what they can and can not do. The MX is a L3 box with L2 capabilities,
> the EX is a L2 box with L3 capabilities.
> 
> So, vlans in an MX are not global (at least not necessarily). This means
> you can have the same vlan id on different ports without them being the
> same service (this may be a bit unclear, I apologize if that is the case)
> 
> Encapsulation flexible-ethernet-services gives you the opportunity to
> use different encapsulation on different units (i.e vlan, mpls, vpls and
> so forth).
> 
> vlan-tagging enables support for reception of singel tagged ethernet
> frames. If you want double-tagged it's stacked-vlan-tagging or if you
> want the option of doing both on the same physical port it's
> flexible-vlan-tagging.
> 
> If you intend solely to terminate a vlan in a L3 interface you would
> simply state it like this.
> 
> ge-0/0/0 {
>    encapsulation flexible-ethernet-services;
>    vlan-tagging;
>    unit 0 {
>      vlan-id z;
>      family inet {
>        address xx.xx.xx.xx/yy;
>      }
> }
> 
> If you want the option of bridging several interfaces together and
> simultaneously have a routable interface enabled it get's a bit more
> complicated. Basicly you have to set up a bridge-domain and then an
> routing-interface (interface irb) on it.
> 
> //Martin
> 
> On 2010-05-04 23:05, Paul Stewart wrote:
>> Hi there..
>> 
>> 
>> 
>> I'm not sure if I'm asking this right . again, as I mentioned earlier - I'm
>> a Cisco guy jumping into the JunOS world so pardon me if I've missed this
>> somewhere in the docs. my translation between the two worlds is "slow but
>> steady"..
>> 
>> 
>> 
>> Working on an MX480 that has a pair of DPC cards (DPCE 20x 1GE + 2x 10GE R).
>> 
>> 
>> 
>> Some questions ;)
>> 
>> 
>> 
>> Can someone give me in "simple terms" what the differences are between
>> "chassis network-services Ethernet" and "chassis network-services IP"?
>> 
>> 
>> 
>> Secondly, on EX switches (which I'm just getting used too) we can do:
>> 
>> 
>> 
>>      ge-0/0/12 {
>> 
>>          description xxxxxxxxxxxxxxx;
>> 
>>          unit 0 {
>> 
>>              family ethernet-switching {
>> 
>>                  port-mode trunk;
>> 
>>                  vlan {
>> 
>>                      members [ xxxxxxxx yyyyyyyy ]
>> 
>> 
>> 
>> On the MX it seems this is quite different?  I have the following:
>> 
>> 
>> 
>>      ge-5/0/2 {
>> 
>>          description xxxxxxxxxxxxxxxxxxxx;
>> 
>>          vlan-tagging;
>> 
>>          encapsulation flexible-ethernet-services;
>> 
>>          unit 0 {
>> 
>>              family bridge {
>> 
>>                  interface-mode trunk;
>> 
>>                  vlan-id-list 61;
>> 
>>              }
>> 
>>          }
>> 
>> 
>> 
>> 
>> 
>> I'm sure this isn't correct J  This is what I created after reading some of
>> the Juniper docs with a lack of understanding what
>> "flexible-ethernet-services" actually refers too..
>> 
>> 
>> 
>> My goal is to have a dot1q trunk come in with a dozen or so VLAN's on it and
>> then create layer3 RVI's for them.  The RVI configuration I have is this
>> (which again I know is wrong):
>> 
>> 
>> 
>>      vlan {
>> 
>>          unit 61 {
>> 
>>              family inet {
>> 
>>                  address xxx.xx.235.34/24;
>> 
>>              }
>> 
>>              family inet6 {
>> 
>>                  address xxx:xxx:235::34/64;
>> 
>>              }
>> 
>>          }
>> 
>> 
>> 
>> 
>> 
>> Any assistance is much appreciated - thanks again to those folks who helped
>> earlier with my BGP questions.
>> 
>> 
>> 
>> Paul
>> 
>> 
>> 
>> _______________________________________________
>> juniper-nsp mailing list juniper-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/juniper-nsp
>>    
> 
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp




More information about the juniper-nsp mailing list