[j-nsp] VLAN and RVI on MX Series
Chuck Anderson
cra at WPI.EDU
Tue Jan 18 17:11:18 EST 2011
On Tue, Jan 18, 2011 at 07:54:26PM +0000, Bill Blackford wrote:
> I'm looking to duplicate or closely proximate the VLAN RVI
> functionality currently used on a LAN switch over to a MX80. Is
> there a best accepted practices or any examples available for doing
> this? There seem to be a lot of knobs and so far my experimentation
> has yielded little results.
> An understanding of some of these knobs would be advantageous as
> well if there are any references.
You can take a look at the Layer 2 Configuration Guide:
http://www.juniper.net/techpubs/en_US/junos10.4/information-products/topic-collections/config-guide-layer-2/config-guide-layer-2.pdf
but beware that "trunk-style" configurations don't work on MX80 or
MX-MPC/Trio hardware yet. You have to rewind back to 9.1
documentation to learn how to configure MX80 and MX-MPC/Trio cards
until the new hardware catches up with the 9.2+ Layer 2 features:
https://www.juniper.net/techpubs/software/junos/junos91/mx-solutions-guide/mx-solutions-guide.pdf
Here is an example of something that should work on an MX80 with 10.4
or older (untested configuration):
bridge-domains {
FOO {
vlan-id 10;
interface xe-0/0/0.10;
interface xe-1/0/0.0;
routing-interface irb.10;
}
BAR {
vlan-id 20;
interface xe-0/0/0.20;
routing-interface irb.20;
}
BAZ {
vlan-id 30;
interface xe-0/0/0.30;
routing-interface irb.30;
}
}
interfaces {
xe-0/0/0 {
description "tagged interface on vlans 10, 20, 30";
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 10 {
encapsulation vlan-bridge;
vlan-id 10;
}
unit 20 {
encapsulation vlan-bridge;
vlan-id 20;
}
unit 30 {
encapsulation vlan-bridge;
vlan-id 30;
}
}
xe-1/0/0 {
description "untagged interface on vlan 10";
encapsulation ethernet-bridge;
unit 0;
}
irb {
unit 10 {
family inet {
address 10.10.10.1/24;
}
}
unit 20 {
family inet {
address 10.10.20.1/24;
}
}
unit 30 {
family inet {
address 10.10.30.1/24;
}
}
}
}
Here is the above example converted to "trunk-style" which should work
on DPC-only today (again, untested configuration). MPC/Trio and MX80
support for this will come "soon":
bridge-domains {
FOO {
vlan-id 10;
routing-interface irb.10;
}
BAR {
vlan-id 20;
routing-interface irb.20;
}
BAZ {
vlan-id 30;
routing-interface irb.30;
}
}
interfaces {
xe-0/0/0 {
description "tagged interface on vlans 10, 20, 30";
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list [ 10 20 30 ];
}
}
}
xe-1/0/0 {
description "untagged interface on vlan 10";
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 0 {
family bridge {
interface-mode access;
vlan-id 10;
}
}
}
irb {
unit 10 {
family inet {
address 10.10.10.1/24;
}
}
unit 20 {
family inet {
address 10.10.20.1/24;
}
}
unit 30 {
family inet {
address 10.10.30.1/24;
}
}
}
}
More information about the juniper-nsp
mailing list