[j-nsp] ISIS between ERX 1440 and MX960

sthaug at nethelp.no sthaug at nethelp.no
Thu May 19 15:34:53 EDT 2011


> 2. I tried but without success. I believe that the ISO MTU is less than the padded hello of the MX. I will try to set mtu of the gi 12/0 of the ERX to 1518 : I will update you if it works

We have IS-IS running between MX and ERX with no problem. Use 4 byte 
more for the ERX MTU than the MX MTU on the physical interfaces, and
you should be all set.

Example of working config below, lightly anonymized.

Steinar Haug, Nethelp consulting, sthaug at nethelp.no
----------------------------------------------------------------------

interface gigabitEthernet 2/0
 mtu 4488
 ip address a.b.2.202 255.255.255.252
 ip router isis
 isis network point-to-point
 isis circuit-type level-2-only

interface loopback 0
 ip address a.b.0.75 255.255.255.255
 ip router isis
 isis circuit-type level-2-only

router isis
 is-type level-2-only
 net 47.0001.0000.0000.0075.00
 metric-style wide level-2

interfaces {
    ge-0/0/3 {
        mtu 4484;
        unit 0 {
            family inet {
                address a.b.2.201/30;
            }
            family iso;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address a.b.0.78/32;
            }
            family iso {
                address 47.0001.0000.0000.0078.00;
            }
        }
    }
}

protocols {
    isis {
        level 2 wide-metrics-only;
        level 1 disable;
        interface ge-0/0/3.0 {
            point-to-point;
        }
        interface lo0.0 {
            level 2 passive;
        }
    }
}



More information about the juniper-nsp mailing list