[j-nsp] Junos-RSVP-TE_nested_paths_RFC4206

Victor Lyapunov victor.lyapunov at gmail.com
Tue Feb 7 17:05:36 EST 2012


Hello

Forgot to post the config (was using a very simple setup).

The setup CORE1,2,3 are juniper routers while PE1 & PE2 are cisco.

Topology:  (PE1) <=10.0.14.0/24=> (CORE1)
<=10.0.12.0/24=>(CORE2)<=10.0.23.0/24=>(CORE3)<=10.0.35.0/24=>(PE2)

Two MPLS-TE paths are established: Between (CORE1,CORE3) & (PE1, PE2).
I am trying to make (PE1, PE2) "nested" inside (CORE1, CORE3)
so that traffic flowing though nore CORE2 will have 2 MPLS label layers.

==========CORE1===========

interfaces {
    em0 {
        vlan-tagging;
        unit 14 {
            vlan-id 14;
            family inet {
                address 10.0.14.1/24;
            }
            family iso;
            family mpls;
        }
        unit 12 {
            vlan-id 12;
            family inet {
                address 10.0.12.1/24;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 163.0.0.1/32;
            }
            family iso {
                address 49.0123.1111.1111.1111.00;
            }
        }
    }
}
routing-options {
    router-id 163.0.0.1;
}
protocols {
    rsvp {
        interface em0.12;
        interface em0.14;
    }
    mpls {
        traffic-engineering bgp-igp;
        label-switched-path 123 {
            to 163.0.0.3;
            record;
        }
        interface em0.12;
        interface em0.14;
    }
    isis {
        interface em0.14 {
            point-to-point;
        }
        interface em0.12 {
            point-to-point;
        }
        interface lo0.0 {
            passive;
        }
    }

=====================================

CORE3

interfaces {
    em0 {
        vlan-tagging;
        unit 35 {
            vlan-id 35;
            family inet {
                address 10.0.35.3/24;
            }
            family iso;
            family mpls;
        }
        unit 23 {
            vlan-id 23;
            family inet {
                address 10.0.23.3/24;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 163.0.0.3/32;
            }
            family iso {
                address 49.0123.3333.3333.3333.00;
            }
        }
    }
}
routing-options {
    router-id 163.0.0.3;
}
protocols {
    rsvp {
        interface em0.23;
        interface em0.35;
    }
    mpls {
        traffic-engineering bgp-igp;
        label-switched-path 123 {
            to 163.0.0.1;
            record;
        }
        interface em0.23;
        interface em0.35;
    }
    isis {
        interface em0.35 {
            point-to-point;
        }
        interface em0.23 {
            point-to-point;
        }
        interface lo0.0 {
            passive;
        }
    }
}

=====================================

plain cisco setup for MPLS-TE

PE1:

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 no ip directed-broadcast
!
interface Tunnel45
 ip unnumbered Loopback0
 no ip directed-broadcast
 tunnel destination 5.5.5.5
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 100 dynamic
!
interface FastEthernet0/0.14
 encapsulation dot1Q 14
 ip address 10.0.14.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 mpls traffic-eng tunnels
 isis network point-to-point
 isis csnp-interval 10 level-1
 isis csnp-interval 10 level-2
!
router isis
 net 49.0123.0004.0004.0004.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 passive-interface Loopback0

PE2:

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 no ip directed-broadcast
!
interface Tunnel45
 ip unnumbered Loopback0
 no ip directed-broadcast
 tunnel destination 4.4.4.4
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 100 dynamic
!
interface FastEthernet0/0.35
 encapsulation dot1Q 35
 ip address 10.0.35.5 255.255.255.0
 no ip directed-broadcast
 ip router isis
 mpls traffic-eng tunnels
 isis network point-to-point
 isis csnp-interval 10 level-1
 isis csnp-interval 10 level-2
!
router isis
 net 49.0123.0005.0005.0005.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 passive-interface Loopback0



======================================================================





So far traffic flowing between PE1 & PE2 goes through the tunnel14,
but only a single MPLS label is used when packets
are flowing through CORE2. (The MPLS-TE lsp established between CORE1
& CORE3 is not used)

I was wondering the proper configuration in CORE1, CORE3 that will
make the tunnel (PE1,PE2) "nested" inside MPLS-TE
path (CORE1, CORE3)



On Tue, Feb 7, 2012 at 5:18 AM, saurabh sood <saurabh24u at gmail.com> wrote:
> Hi,
>
> Please share the configuration...
>
> BR//
>
> On Tue, Feb 7, 2012 at 3:32 AM, Victor Lyapunov <victor.lyapunov at gmail.com>
> wrote:
>>
>> Hello All
>>
>> I have been trying to perform a simple to test for RSVP-TE testing
>> according to RFC4206. Specifically my test topology is the following
>>
>> PE1<=>CORE1<=>CORE2<=>CORE3<=>PE2
>>
>> All routers belong to the same ISIS area
>>
>> - I install an MPLS-TE path spanning between CORE1, CORE2.
>> - I have not found the necessary commands to make end-to-end MPLS-TE
>> paths, spanning across the core, (e.g between PE1 and PE2) to be
>> nested inside the core MPLS-TE path CORE1,2
>>
>> Does anyone knows how to achieve MPLS-TE nesting according to RFC4206 in
>> JunOS?
>>
>> Thnx for your help
>> _______________________________________________
>> juniper-nsp mailing list juniper-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/juniper-nsp
>
>


More information about the juniper-nsp mailing list