[j-nsp] ISIS over GRE (1500 MTU)

Doug Hanks dhanks at juniper.net
Mon Mar 12 22:01:18 EDT 2012


Hello,

What you're looking for is "allow-fragmentation"

http://www.juniper.net/techpubs/en_US/junos11.1/topics/usage-guidelines/ser
vices-configuring-unicast-tunnels.html#configure-packet-reassembly

(although this refers to ms-dpc, the mpc/trio behaves the same)

I labbed this up to confirm:

{master}
jnpr at R1-RE0> show interfaces ae0.1 | match mtu
    Protocol inet, MTU: 1500
    Protocol iso, MTU: 1497
    Protocol multiservice, MTU: Unlimited

{master}
jnpr at R1-RE0> show interfaces gr-2/0/0 | match mtu
  Type: GRE, Link-level type: GRE, MTU: Unlimited, Speed: 10000mbps
    Protocol inet, MTU: 1476
    Protocol iso, MTU: 1516
      Flags: User-MTU

{master}
jnpr at R1-RE0> show configuration interfaces gr-2/0/0
unit 0 {
    tunnel {
        source 10.8.0.0;
        destination 10.8.0.1;
        allow-fragmentation;
    }
    family inet {
        address 1.1.1.1/30;
    }
    family iso {
        mtu 1516;
    }
}

{master}
jnpr at R1-RE0> show isis adjacency
Interface             System         L State        Hold (secs) SNPA
ae0.1                 R2-RE0         2  Up                   23
gr-2/0/0.0            R2-RE0         2  Up                   21


Thank you,

-- 
Doug Hanks - JNCIE-ENT #213,  JNCIE-SP #875
Sr. Systems Engineer
Juniper Networks

On 3/12/12 4:49 PM, "EXT - lists at beatmixed.com" <lists at beatmixed.com>
wrote:

>Wanted to throw this out there to see if anyone else has solved this
>problem before me.
>
>I'd like to set up an IS-IS adjacency over an Internet based GRE
>tunnel. The tunnel comes up fine in my tests but the IS-IS adjacency
>never forms. One can probably safely presume this is due to an MTU
>issue -- the 1492 PDU size for IS-IS + 24 for GRE doesn't fit in the
>1500 MTU this is all riding over.
>
>Juniper has a technical note which touches upon the issue:
>
>http://kb.juniper.net/InfoCenter/index?page=content&id=KB7848
>
>... so I have some hope the problem is solvable...
>
>I'm using Trio linecards on MX platform. Technically speaking, I don't
>want to enable fragmentation of my IP traffic. I'd like for path MTU
>discovery to do its thing with that. Not quite sure I actually
>understand (from the tech note) what I am supposed to do
>configuration-wise to solve this...
>
>Here's a rough outline of my basic config (real simple):
>
>== R1 ==
>
>set chassis fpc 2 pic 3 tunnel-services bandwidth 10g
>
>set interfaces gr-2/3/0 unit 0 tunnel destination x.x.x.3
>set interfaces gr-2/3/0 unit 0 tunnel source x.x.y.3
>set interfaces gr-2/3/0 unit 0 family inet
>set interfaces gr-2/3/0 unit 0 family iso
>
>set protocols isis interface gr-2/3/0.0 point-to-point
>set protocols isis interface gr-2/3/0.0 level 1 disable
>set protocols isis interface gr-2/3/0.0 level 2 metric 1000
>
>== R2 ==
>
>set chassis fpc 2 pic 3 tunnel-services bandwidth 10g
>
>set interfaces gr-2/3/0 unit 0 tunnel source x.x.y.3
>set interfaces gr-2/3/0 unit 0 tunnel destination x.x.x.3
>set interfaces gr-2/3/0 unit 0 family inet
>set interfaces gr-2/3/0 unit 0 family iso
>
>set protocols isis interface gr-2/3/0.0 point-to-point
>set protocols isis interface gr-2/3/0.0 level 1 disable
>set protocols isis interface gr-2/3/0.0 level 2 metric 1000
>
>
>--
>
>Thanks for any thoughts or ideas.
>
>-M
>_______________________________________________
>juniper-nsp mailing list juniper-nsp at puck.nether.net
>https://puck.nether.net/mailman/listinfo/juniper-nsp




More information about the juniper-nsp mailing list