[j-nsp] ng-mvpn problem

Mihai mihaigabriel at gmail.com
Tue Oct 22 16:44:31 EDT 2013


You understand correctly. The source,PE's and the receiver  are on the 
same MX running Junos 12.3R3.4.
Removing PIM from lt-1/1/10.770 is not a solution because the PE will 
not learn about the source and the multicast group.Changing the 
multicast group didn't change anything.

mx# run ping logical-system a 225.10.10.10 ttl 100 bypass-routing 
interface lt-1/1/10.771 size 1500 rapid count 10000000 interval 0.1
PING 225.10.10.10 (225.10.10.10): 1500 data bytes
............................................................................................................^C
--- 225.10.10.10 ping statistics ---
109 packets transmitted, 0 packets received, 100% packet loss

mx# run show pim join extensive logical-system x instance mvpn
Instance: PIM.mvpn Family: INET
R = Rendezvous Point Tree, S = Sparse, W = Wildcard

Group: 225.10.10.10
     Source: 10.100.1.2
     Flags: sparse,spt
     Upstream interface: lt-1/1/10.770
     Upstream neighbor: Direct
     Upstream state: Local Source, Local RP
     Keepalive timeout: 329
     Uptime: 00:01:31
     Number of downstream interfaces: 0

mx# run show multicast route extensive logical-system x instance mvpn
Instance: mvpn Family: INET

Group: 225.10.10.10
     Source: 10.100.1.2/32
     Upstream interface: lt-1/1/10.770
     Session description: Unknown
     Statistics: 16 kBps, 20 pps, 329 packets
     Next-hop ID: 0
     Upstream protocol: PIM
     Route state: Active
     Forwarding state: Pruned
     Cache lifetime/timeout: 360 seconds
     Wrong incoming interface notifications: 0
     Uptime: 00:01:00



The full configuration is below:

mx#top show logical-systems x
interfaces {
     lt-1/1/10 {
         unit 770 {
             description x-a;
             encapsulation ethernet;
             peer-unit 771;
             family inet {
                 address 10.100.1.1/24;
             }
         }
         unit 776 {
             description x-z;
             encapsulation ethernet;
             peer-unit 777;
             family inet {
                 address 10.100.3.1/24;
             }
             family iso;
             family mpls;
         }
  lo0 {
         unit 770 {
             family inet {
                 address 20.20.20.1/32;
             }
             family iso {
                 address 49.1111.0020.0020.0201.00;
             }
         }
         unit 777 {
             family inet {
                 address 20.20.20.111/32;
             }
         }
     }
}
protocols {
     rsvp {
         interface all;
     }
     mpls {
         interface lt-1/1/10.776;
     }
     bgp {
         group ibgp {
             type internal;
             local-address 20.20.20.1;
             family inet-vpn {
                 any;
             }
             family inet-mvpn {
                 signaling;
             }
             neighbor 20.20.20.2;
         }
     }
isis {
         level 2 disable;
         level 1 wide-metrics-only;
         interface lt-1/1/10.776;
         interface lo0.770;
     }
ldp {
         interface lt-1/1/10.776;
     }
}
routing-instances {
     mvpn {
         instance-type vrf;
         interface lt-1/1/10.770;
         interface lo0.777;
         route-distinguisher 1:1;
         provider-tunnel {
             rsvp-te {
                 label-switched-path-template {
                     default-template;
                 }
             }
         }
         vrf-target target:1:1;
         vrf-table-label;
         protocols {
             pim {
                 rp {
                     local {
                         address 20.20.20.111;
                     }
                 }
                 interface all;
             }
             mvpn;
         }
     }
}
routing-options {
     autonomous-system 65550;
}

-----------

mx# top show logical-systems z
interfaces {
     lt-1/1/10 {
         unit 772 {
             description z-b;
             encapsulation ethernet;
             peer-unit 773;
             family inet {
                 address 10.100.2.1/24;
             }
         }
         unit 777 {
             description z-x;
             encapsulation ethernet;
             peer-unit 776;
             family inet {
                 address 10.100.3.2/24;
             }
             family iso;
             family mpls;
         }
protocols {
     rsvp {
         interface all;
     }
     mpls {
         interface lt-1/1/10.777;
     }
     bgp {
         group ibgp {
             type internal;
             local-address 20.20.20.2;
             family inet-vpn {
                 any;
             }
             family inet-mvpn {
                 signaling;
             }
             neighbor 20.20.20.1;
         }
     }
     isis {
         level 2 disable;
         level 1 wide-metrics-only;
         interface lt-1/1/10.777;
         interface lo0.780;
     }
ldp {
         interface lt-1/1/10.777;
     }
}
routing-instances {
     mvpn {
         instance-type vrf;
         interface lt-1/1/10.772;
         route-distinguisher 1:2;
         provider-tunnel {
             rsvp-te {
                 label-switched-path-template {
                     default-template;
                 }
             }
         }
         vrf-target target:1:1;
         vrf-table-label;
  protocols {
     pim {
         rp {
             static {
                 address 20.20.20.111;
             }
         }
         interface all;
     }
     mvpn;
}
routing-options {
     autonomous-system 65550;
}

----

mx# top show logical-systems a
interfaces {
     lt-1/1/10 {
         unit 771 {
             description a-x;
             encapsulation ethernet;
             peer-unit 770;
             family inet {
                 address 10.100.1.2/24;
             }
         }
protocols {
pim {
         rp {
             static {
                 address 20.20.20.111;
             }
         }
         interface all;
     }
}
routing-options {
     static {
         route 0.0.0.0/0 next-hop 10.100.1.1;
     }
}

--------------------

# top show logical-systems b
interfaces {
     lt-1/1/10 {
         unit 773 {
             description b-z;
             encapsulation ethernet;
             peer-unit 772;
             family inet {
                 address 10.100.2.2/24;
             }
         }
protocols {
     sap {
         listen 225.10.10.10 port 7777;
     }
pim {
         rp {
             static {
                 address 20.20.20.111;
             }
         }
         interface all;
     }
}
routing-options {
     static {
         route 0.0.0.0/0 next-hop 10.100.2.1;
     }
}





On 10/22/2013 10:54 PM, Stacy W. Smith wrote:
> Do understand correctly that the source of the traffic is a logical-system on the same router? How are you generating the multicast traffic?
>
> I believe the issue is running PIM on the first-hop interface facing the source. The router is expecting either PIM-register encapsulated traffic from upstream, or expecting to already have PIM join state.
>
> Can you try removing PIM from lt-1/1/10.770 in routing-instance x and configuring lt-1/1/10.770 to forward multicast traffic without running PIM (set routing-instance x routing-options multicast interface lt-1/1/10.770)?
>
> If that doesn't help, please provide config of the logical-system containing the source, and the outputs of "show pim rps extensive [instance instance-name]", "show pim join extensive [instance instance-name]", and "show multicast route extensive [instance instance-name]".
>
> If you're still having issue, you may also want to try a different group address to avoid any peculiarities with adminstratively-scoped addresses.
>
> --Stacy
>
> On Oct 22, 2013, at 12:20 PM, Mihai <mihaigabriel at gmail.com> wrote:
>> Hello,
>>
>> lo0.777 has the rp address, and the lt-1/1/10.770 is the link between PE and multicast source (it's a single MX with logical-systems and I already tried the same setup with physical interfaces between PE and CE with the same result):
>>
>>
>> x> show configuration interfaces lo0 unit 777
>> family inet {
>>     address 20.20.20.111/32;
>> }
>>
>> x> show configuration interfaces lt-1/1/10.770
>> description x-a;
>> encapsulation ethernet;
>> peer-unit 771;
>> family inet {
>>     address 10.100.1.1/24;
>> }
>>
>>
>> On 10/22/2013 08:07 PM, Antonio Sanchez-Monge wrote:
>>> Hi Mihai,
>>>
>>> Doesn't ring a bell at first sight. What's the configuration of interfaces
>>> lo0.777 and lt-1/1/10.770 ?
>>>
>>> Thanks,
>>>
>>> Ato
>>>
>>>
>>>
>>>
>>> On 10/22/13 6:56 PM, "Mihai Gabriel" <mihaigabriel at gmail.com> wrote:
>>>
>>>> Hello,
>>>>
>>>> I have a basic setup with 2 PE's (X and Z) , one multicast source
>>>> attached
>>>> to X and one receiver attached to Z.
>>>> I configured a NG-MVPN with rsvp-te between  PE's but X doesn't send SA
>>>> autodiscovery to Z so the traffic is dropped.
>>>>
>>>> x> show configuration routing-instances
>>>> mvpn {
>>>>     instance-type vrf;
>>>>     interface lt-1/1/10.770;
>>>>     interface lo0.777;
>>>>     route-distinguisher 1:1;
>>>>     provider-tunnel {
>>>>         rsvp-te {
>>>>             label-switched-path-template {
>>>>                 default-template;
>>>>             }
>>>>         }
>>>>     }
>>>>     vrf-target target:1:1;
>>>>     vrf-table-label;
>>>>     protocols {
>>>>         pim {
>>>>             rp {
>>>>                 local {
>>>>                     address 20.20.20.111;
>>>>                 }
>>>>             }
>>>>             interface all;
>>>>         }
>>>>         mvpn;
>>>>     }
>>>> }
>>>>
>>>>
>>>> z> show configuration routing-instances
>>>> mvpn {
>>>>     instance-type vrf;
>>>>     interface lt-1/1/10.772;
>>>>     route-distinguisher 1:2;
>>>>     provider-tunnel {
>>>>         rsvp-te {
>>>>             label-switched-path-template {
>>>>                 default-template;
>>>>             }
>>>>         }
>>>>     }
>>>>     vrf-target target:1:1;
>>>>     vrf-table-label;
>>>>     protocols {
>>>>         pim {
>>>>             interface all;
>>>>         }
>>>>         mvpn;
>>>>     }
>>>> }
>>>>
>>>>
>>>> x> show multicast route instance mvpn extensive
>>>> Instance: mvpn Family: INET
>>>>
>>>> Group: 239.1.1.1
>>>>     Source: 10.100.1.2/32
>>>>     Upstream interface: lt-1/1/10.770
>>>>     Session description: Organisational Local Scope
>>>>     Statistics: 10 kBps, 10 pps, 1291 packets
>>>>     Next-hop ID: 0
>>>>     Upstream protocol: PIM
>>>>     Route state: Active
>>>>     Forwarding state: Pruned
>>>>     Cache lifetime/timeout: 360 seconds
>>>>     Wrong incoming interface notifications: 0
>>>>     Uptime: 00:10:37
>>>>
>>>> Instance: mvpn Family: INET6
>>>>
>>>> x> show route receive-protocol bgp 20.20.20.2 table mvpn.mvpn.0
>>>>
>>>> mvpn.mvpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
>>>>   Prefix  Nexthop       MED     Lclpref    AS path
>>>>   1:1:2:20.20.20.2/240
>>>> *                         20.20.20.2                   100        I
>>>>
>>>> z> show route receive-protocol bgp 20.20.20.1 table mvpn.mvpn.0
>>>>
>>>> mvpn.mvpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
>>>>   Prefix  Nexthop       MED     Lclpref    AS path
>>>>   1:1:1:20.20.20.1/240
>>>> *                         20.20.20.1                   100        I
>>>>
>>>> x> show mpls lsp p2mp
>>>> Ingress LSP: 1 sessions
>>>> P2MP name: 1:1:mvpn:mvpn, P2MP branch count: 1
>>>> To              From            State Rt P     ActivePath       LSPname
>>>> 20.20.20.2      20.20.20.1      Up     0 *
>>>> 20.20.20.2:1
>>>> :1:mvpn:mvpn
>>>> Total 1 displayed, Up 1, Down 0
>>>>
>>>> Egress LSP: 1 sessions
>>>> P2MP name: 1:2:mvpn:mvpn, P2MP branch count: 1
>>>> To              From            State   Rt Style Labelin Labelout LSPname
>>>> 20.20.20.1      20.20.20.2      Up       0  1 SE      16        -
>>>> 20.20.20.1:1:2:mvpn:mvpn
>>>> Total 1 displayed, Up 1, Down 0
>>>>
>>>> Transit LSP: 0 sessions
>>>> Total 0 displayed, Up 0, Down 0
>>>>
>>>> Am i doing something wrong?
>>>>
>>>> Thanks
>>>> _______________________________________________
>>>> juniper-nsp mailing list juniper-nsp at puck.nether.net
>>>> https://puck.nether.net/mailman/listinfo/juniper-nsp
>>>>
>>>>
>>>
>>>
>> _______________________________________________
>> juniper-nsp mailing list juniper-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/juniper-nsp
>


More information about the juniper-nsp mailing list