[j-nsp] H-QoS support

Eric Van Tol eric at atlantech.net
Fri Feb 7 14:50:00 EST 2014


> -----Original Message-----
> From: sthaug at nethelp.no [mailto:sthaug at nethelp.no]
>
> You should be just fine with 12.3. Can you share some of your config
> related to the H-QoS?

I'm barely at the testing phase right now.  The config I was using is below, but using this config, I was unable to ping across my S-VLAN 107 C-VLAN 100 until I removed the entire config and added it back in again without the 'hierarchical-scheduler' command.  Then I saw the errors and went to investigate further, as opposed to spending all day trying to get it working.  (Instead, I spent all day trying to see if it was even supported).

Config follows.  Trying to do a simple 'strict-high' priority on SV107-CV100 (unit 107) while sharing 100m with units 1777 (45m cir) and 1778 (45m cir).

~~~~~~~~~~~~~~~~~~~
interfaces {
    interface-set cid-1111 {
        interface ge-1/0/5 {
            vlan-tags-outer 107;
        }
    }
    ge-1/0/5 {
        enable;
        hierarchical-scheduler;
        flexible-vlan-tagging;
        mtu 9192;
        encapsulation flexible-ethernet-services;
        gigether-options {
            no-auto-negotiation;
        }
        unit 102 {
            vlan-tags outer 102 inner 102;
            family inet {
                address 172.20.1.21/30;
            }
            family mpls;
        }
        unit 103 {
            vlan-tags outer 103 inner 103;
            family inet {
                address 172.20.1.9/30;
            }
            family mpls;
        }
        unit 104 {
            vlan-id 104;
            family inet {
                address 172.20.1.5/30;
            }
            family mpls;
        }
        unit 105 {
            vlan-id 105;
            family inet {
                address 172.20.1.25/30;
            }
            family mpls;
        }
        unit 106 {
            vlan-tags outer 106 inner 106;
            family inet {
                address 172.20.1.13/30;
            }
            family mpls;
        }
        unit 107 {
            vlan-tags outer 107 inner 100;
            family inet {
                address 172.20.1.245/30;
            }                           
        }
        unit 1777 {
            encapsulation vlan-ccc;
            vlan-tags outer 107 inner 300;
            input-vlan-map pop-pop;
            output-vlan-map push-push;
            family ccc;
        }
        unit 1778 {
            vlan-tags outer 107 inner 101;
            family inet {
                address 172.20.1.97/30;
            }
        }
        unit 2694 {
            vlan-id 2694;
            family inet {
                address 172.20.1.17/30;
            }
            family mpls;
        }
    }
}
class-of-service {
    classifiers {
        dscp ds-voip {
            forwarding-class ef-class {
                loss-priority low code-points ds-ef;
            }
            forwarding-class af-class {
                loss-priority low code-points ds-af;
            }
        }
    }
    code-point-aliases {
        dscp {
            ds-be 000000;
            ds-af 100010;
            ds-ef 101110;
            ds-nc 110000;
        }
    }
    forwarding-classes {
        queue 0 be-class;
        queue 1 ef-class;
        queue 2 af-class;
        queue 3 nc-class;               
    }
    traffic-control-profiles {
        LEVEL_1-phy_int_shaper {
            shaping-rate 1g;
        }
        LEVEL_2-svlan_100m {
            shaping-rate 100m;
            guaranteed-rate 100m;
        }
        LEVEL_3-cvlan_100 {
            scheduler-map cvlan-voice;
            shaping-rate 10m;
            guaranteed-rate 10m;
        }
        LEVEL_3-cvlan_101 {
            scheduler-map cvlan-data;
            shaping-rate 100m;
            guaranteed-rate 45m;
        }
        LEVEL_3-cvlan_300 {
            scheduler-map cvlan-data;
            shaping-rate 100m;
            guaranteed-rate 45m;
        }
        LEVEL_2-svlan_10m {
            shaping-rate 10m;
            guaranteed-rate 10m;
        }
    }
    interfaces {
        interface-set cid-1111 {
            output-traffic-control-profile LEVEL_2-svlan_100m;
        }
        ge-1/0/5 {
            output-traffic-control-profile LEVEL_1-phy_int_shaper;
            unit 102 {
                output-traffic-control-profile LEVEL_2-svlan_10m;
                classifiers {
                    dscp ds-voip;
                }
            }
            unit 103 {
                output-traffic-control-profile LEVEL_2-svlan_10m;
                classifiers {
                    dscp ds-voip;
                }
            }
            unit 104 {
                output-traffic-control-profile LEVEL_2-svlan_10m;
                classifiers {
                    dscp ds-voip;
                }
            }
            unit 105 {                  
                output-traffic-control-profile LEVEL_2-svlan_100m;
                classifiers {
                    dscp ds-voip;
                }
            }
            unit 106 {
                output-traffic-control-profile LEVEL_2-svlan_10m;
                classifiers {
                    dscp ds-voip;
                }
            }
            unit 107 {
                output-traffic-control-profile LEVEL_3-cvlan_100;
                classifiers {
                    dscp ds-voip;
                }
            }
            unit 1777 {
                output-traffic-control-profile LEVEL_3-cvlan_300;
            }
            unit 1778 {
                output-traffic-control-profile LEVEL_3-cvlan_101;
                classifiers {
                    dscp ds-voip;
                }
                rewrite-rules {
                    dscp ds-voip;
                }
            }
            unit 2694 {
                output-traffic-control-profile LEVEL_2-svlan_10m;
                classifiers {
                    dscp ds-voip;
                }
            }
        }
    }
    rewrite-rules {
        dscp ds-voip {
            forwarding-class ef-class {
                loss-priority low code-point ds-ef;
                loss-priority high code-point ds-ef;
            }
            forwarding-class af-class {
                loss-priority low code-point ds-af;
                loss-priority high code-point ds-af;
            }
        }
    }
    scheduler-maps {
        cvlan-voice {
            forwarding-class ef-class scheduler ef-sched;
            forwarding-class af-class scheduler af-sched;
            forwarding-class nc-class scheduler nc-sched;
        }
        cvlan-data {
            forwarding-class be-class scheduler be-sched;
        }
    }
    schedulers {
        be-sched {
            transmit-rate percent 50;
            buffer-size percent 50;
            priority low;
        }
        ef-sched {
            transmit-rate percent 35;
            buffer-size percent 5;
            priority strict-high;
        }
        af-sched {
            transmit-rate percent 10;
            buffer-size percent 5;
            priority high;
        }
        nc-sched {
            transmit-rate percent 5;
            buffer-size percent 5;
            priority medium-high;
        }
    }
}



More information about the juniper-nsp mailing list