[j-nsp] Experience with QFX5100 13.2 & 14.1

Chuck Anderson cra at WPI.EDU
Thu Jan 15 09:55:48 EST 2015

On Thu, Jan 15, 2015 at 10:30:54AM +0100, Richard Hartmann wrote:
> I was wondering what experience, if any, you have had with QFX5100.
> Of special interest would be what JunOS version you are running, what
> features you have enabled, and if you consider them production-ready.

We are using 48S in production with 13.2X51-D20 & D26, standalone and
VC (not VCF), L2 features only (MSTP, RSTP).  TISSU worked great up to
D20 (completely hitless), but I was told I couldn't use it for getting
to D26 (it would fail or cause issues), so I didn't try.

The only issue we had was due to PR860226 with xSTP between two


We had the MSTP protocol enabled but specifically excluded the MSTP
interface configuration for the link to the other QFX5100 (there is no
"protocols mstp interface X disable" command), and RSTP enabled on all
interfaces on the other QFX5100 including the uplink to the first
QFX5100.  In this case, the first QFX5100 interface didn't forward
traffic or learn MAC address (except LLDP worked fine).  This is what
they told me:

"This behavior is experienced when we have enabled xstp on the QFX and
do not specify a physical interface, what happens when the interface
is not included is that the switch does not learn any MAC address
therefore it does not send any traffic to its neighbors, as of now the
workaround is to include the physical interface, the fix is going to
be coming on the 15.X version."

Basically, if you enable xSTP but don't include an interface (which
should mean that interface should not participate in xSTP--it
certainly didn't appear in "show spanning-tree interface" output),
that interface won't forward traffic, and it doesn't show as
"blocking" anywhere either, even though that is effectively what it is
doing--blocking all traffic.

BTW, this might also answer your question from October 20 "Spanning
tree RJ45 SFP on QFX5100".

More information about the juniper-nsp mailing list