[j-nsp] Setting CoS bits on ingress frames

Alexander Arseniev arseniev at btinternet.com
Wed Jun 17 02:12:53 EDT 2015


Hello,
You can do it only on MX with JUNOS 14.2R3 and newer using new JUNOS 
feature "policy-map", example config below:
chassis {
     network-services enhanced-ip;
}
class-of-service {
     policy-map pm1 {
         dscp proto-ip code-point 110001;
     }
     forwarding-classes {
         queue 0 be;
         queue 1 ef;
         queue 2 af;
         queue 3 nc;
         queue 4 be1;
         queue 5 ef1;
         queue 6 af1;
         queue 7 nc1;
     }
}
firewall {
     family inet {
         filter cmap1 {
             term t1 {
                 from {
                     protocol icmp;
                 }
                 then {
                     policy-map pm1;
                     count c1;
                     accept;
                 }
             }
             term t2 {
                 then {
                     count c2;
                     accept;
                 }}}}}

interfaces {
     ge-0/0/0 {
         unit 0 {
             family inet {
                 filter {
                     input cmap1;
                 }
                 address 172.16.10.246/30;
             }}}}
This is not supported on any other Juniper product, to my knowledge.
Thanks
Alex

On 17/06/2015 06:58, Victor Sudakov wrote:
> Colleagues,
>
> I hope I am not asking something unusual? I just want to classify
> frames based solely on the ingress port and pass these frames out the
> trunk ports keeping the CoS value.
>
> I have read about rewriting rules and classifiers, but would be really
> grateful for a simple example.
>
> Victor Sudakov wrote:
>> Colleagues,
>>
>> I have the following configuration on some Cisco switches, e.g.
>>
>> interface GigabitEthernet0/10
>>   switchport access vlan XXX
>>   switchport mode access
>>   mls qos cos 6
>>   mls qos cos override
>> !
>>
>> How do I do the same on a Juniper EX4200 switch, namely force a 802.1p
>> CoS value on all ingress frames incoming via a certain access port
>> and keep this value when these frames leave the EX4200 switch via a
>> trunk port?
>>
>> I don't need to modify Juniper queues or anything sophisticated. I
>> just need to classify frames and pass the classified frames to the
>> communications equipment which understands CoS bits.
>>
>> Thank you in advance for any input.
>>
>> -- 
>> Victor Sudakov,  VAS4-RIPE, VAS47-RIPN
>> sip:sudakov at sibptus.tomsk.ru
>> _______________________________________________
>> juniper-nsp mailing list juniper-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/juniper-nsp



More information about the juniper-nsp mailing list