[j-nsp] IPv6 traceroute over 6PE

kworm83 at gmail.com kworm83 at gmail.com
Wed Aug 31 16:50:26 EDT 2016


I have a simple lab setup using logical systems on an MX80 and I’m trying to get trace route to work from CE1 <-> PE1 <-> P1 <-> PE2 <-> CE2 using ipv6 and I always get loss on the 2nd hop although it completes after the timeouts.  Any clues would be appreciated.

Traceroute output:

kevin at lab> traceroute 2222::2 logical-system CE1
traceroute6 to 2222::2 (2222::2) from 1111::2, 64 hops max, 12 byte packets
 1  1111::1 (1111::1)  0.886 ms  0.831 ms  0.506 ms
 2  * * *
 3  2222::1 (2222::1)  0.804 ms  0.579 ms  0.599 ms
 4  2222::2 (2222::2)  0.702 ms  0.608 ms  0.722 ms

kevin at lab> traceroute 1111::2 logical-system CE2
traceroute6 to 1111::2 (1111::2) from 2222::2, 64 hops max, 12 byte packets
 1  2222::1 (2222::1)  0.679 ms  0.544 ms  2.186 ms
 2  * * *
 3  1111::1 (1111::1)  0.771 ms  0.619 ms  0.594 ms
 4  1111::2 (1111::2)  0.724 ms  0.605 ms  0.622 ms

The config of the logical systems is simple:

CE1 {
    interfaces {
        lt-0/0/10 {
            unit 8 {
                description "Link to PE1";
                encapsulation ethernet;
                peer-unit 7;
                family inet {
                    address 10.0.0.2/24;
                }
                family inet6 {
                    address 1111::2/64;
                }
            }
        }
    }
    routing-options {
        rib inet6.0 {
            static {
                route 0::/0 next-hop 1111::1;
            }
        }
    }
}
CE2 {
    interfaces {
        lt-0/0/10 {
            unit 10 {
                description "Link to PE2";
                encapsulation ethernet;
                peer-unit 9;
                family inet {
                    address 10.1.1.2/24;
                }
                family inet6 {
                    address 2222::2/64;
                }
            }
        }
    }
    routing-options {
        rib inet6.0 {
            static {
                route 0::/0 next-hop 2222::1;
            }
        }
    }
}
P1 {
    interfaces {
        lt-0/0/10 {
            unit 4 {
                description "Link to PE2";
                encapsulation ethernet;
                peer-unit 3;
                family inet {
                    address 10.4.4.1/24;
                }
                family iso;
                family inet6;
                family mpls;
            }
            unit 6 {
                description "Link to PE1";
                encapsulation ethernet;
                peer-unit 5;
                family inet {
                    address 10.5.5.1/24;
                }
                family iso;
                family inet6;
                family mpls;
            }
        }
        lo0 {
            unit 6 {
                family inet {
                    address 75.75.75.1/32;
                }
                family iso {
                    address 49.0001.0750.7507.5001.00;
                }
                family mpls;
            }
        }
    }
    protocols {
        rsvp {
            interface lt-0/0/10.6;
            interface lt-0/0/10.4;
            interface lo0.6;
        }
        mpls {
            interface lt-0/0/10.6;
            interface lt-0/0/10.4;
            interface lo0.6;
        }
        isis {
            level 1 disable;
            interface lt-0/0/10.4;
            interface lt-0/0/10.6;
            interface lo0.6 {
                passive;
            }
        }
    }
}
PE1 {
    interfaces {
        lt-0/0/10 {
            unit 5 {
                description "Link to P1";
                encapsulation ethernet;
                peer-unit 6;
                family inet {
                    address 10.5.5.2/24;
                }
                family iso;
                family inet6;
                family mpls;
            }
            unit 7 {
                description "Link to CE1";
                encapsulation ethernet;
                peer-unit 8;
                family inet {
                    address 10.0.0.1/24;
                }
                family inet6 {
                    address 1111::1/64;
                }
            }
        }
        lo0 {
            unit 5 {
                family inet {
                    address 75.75.75.2/32;
                }
                family iso {
                    address 49.0001.0750.7507.5002.00;
                }
                family mpls;
            }
        }
    }
    protocols {
        rsvp {
            interface lt-0/0/10.5;
            interface lo0.5;
        }
        mpls {
            ipv6-tunneling;
            label-switched-path PE1-to-PE2 {
                from 75.75.75.2;
                to 75.75.75.3;
            }
            interface lt-0/0/10.5;
            interface lo0.5;
        }
        isis {
            level 1 disable;
            interface lt-0/0/10.5;
            interface lo0.5 {
                passive;
            }
        }
    }
    routing-options {
        rib inet6.0 {
            static {
                route 2222::/64 {
                    lsp-next-hop PE1-to-PE2;
                }
            }
        }
    }
}
PE2 {
    interfaces {
        lt-0/0/10 {
            unit 3 {
                description "Link to P1";
                encapsulation ethernet;
                peer-unit 4;
                family inet {
                    address 10.4.4.2/24;
                }
                family iso;
                family inet6;
                family mpls;
            }
            unit 9 {
                description "Link to CE2";
                encapsulation ethernet;
                peer-unit 10;
                family inet {
                    address 10.1.1.1/24;
                }
                family inet6 {
                    address 2222::1/64;
                }
            }
        }
        lo0 {
            unit 3 {
                family inet {
                    address 75.75.75.3/32;
                }
                family iso {
                    address 49.0001.0750.7507.5003.00;
                }
                family mpls;
            }
        }
    }
    protocols {
        rsvp {
            interface lo0.3;
            interface lt-0/0/10.3;
        }
        mpls {
            ipv6-tunneling;
            label-switched-path PE2-to-PE1 {
                from 75.75.75.3;
                to 75.75.75.2;
            }
            interface lo0.3;
            interface lt-0/0/10.3;
        }
        isis {
            level 1 disable;
            interface lt-0/0/10.3;
            interface lo0.3 {
                passive;
            }
        }
    }
    routing-options {
        rib inet6.0 {
            static {
                route 1111::/64 {
                    lsp-next-hop PE2-to-PE1;
                }
            }
        }
    }
}


More information about the juniper-nsp mailing list