[j-nsp] BGP add-path on QFX

Alexandre Snarskii snar at snar.spb.ru
Fri Jan 27 12:08:04 EST 2017

On Fri, Jan 27, 2017 at 05:00:59PM +0100, Vincent Bernat wrote:
> >> I have upgraded some QFX to 16.1R3 but there is no difference with
> >> 14.1X53-D40: add-path is an hidden command and only "receive" is
> >> available ("send" is not accepted):
> >> 
> >>   set protocols bgp group batman family inet unicast add-path send ...
> >> 
> >> I have also tried on MX104 running 14.1R8. Feature explorer says this
> >> should be supported since 13.2R2. But I am in the exact same situation:
> >> add-path is a hidden command and only "receive" is available.
> >> 
> >> I wonder if I am not missing something obvious. Any tip would be
> >> appreciated!
> >
> > No ideas on what can be wrong with your configuration :(
> > We run add-path on most MXes without any problems. Just tried with QFX 
> > (not running bgp actually), add-path command is not hidden for me and commit 
> > check succeeds: 
> Thanks for checking, that's helpful!
> In fact, I am using routing instances. Like you, I can get add-path
> send/receive outside a routing instance, but inside, add-path is
> hidden. I assumed this was independent of the routing instance
> (configured type virtual-router), so I didn't bother to check that.
> Does "set routing-instances rr1 protocols bgp group apath family inet
> unicast add-path ..." complete for you?

Looks like routing-instances is the difference. Within routing-instance
add-path does not complete for me too, neither on QFX nor on MX.

> -- 
> ROMEO:		Courage, man; the hurt cannot be much.
> MERCUTIO:	No, 'tis not so deep as a well, nor so wide
> 			as a church-door; but 'tis enough, 'twill serve.

More information about the juniper-nsp mailing list