<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.5.7652.24">
<TITLE>RE: [rbak-nsp] SE-400 IP Pool Help</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/plain format -->
<P><FONT SIZE=2>Yes, I've had stupid amounts of problems with the "summary-only" keyword in the past,<BR>
it is most certainly broken in my release (6.1.3.1)<BR>
<BR>
Since you are doing this in a VPN content (and hence can't filter iBGP),<BR>
Remove the "redistribute subscriber" and all the aggregate addresses<BR>
and only have "redistribute static" then maintain static supernets<BR>
routed to null0 (ip route x.x.x.x/y null0)<BR>
<BR>
like:<BR>
<BR>
router bgp vpn<BR>
redistribute static<BR>
no redistribute subscriber address<BR>
no aggregate-address 200.96.96.0/19 summary-only<BR>
no aggregate-address 200.96.204.0/22 summary-only<BR>
no aggregate-address 200.96.252.0/22 summary-only<BR>
ip route 200.96.96.0/19 null0<BR>
ip route 200.96.204.0/22 null0<BR>
ip route 200.96.252.0/22 null0<BR>
<BR>
Dave.<BR>
<BR>
------------------------------------------------<BR>
David Freedman<BR>
Group Network Engineering<BR>
Claranet Limited<BR>
<A HREF="http://www.clara.net">http://www.clara.net</A><BR>
<BR>
<BR>
<BR>
-----Original Message-----<BR>
From: redback-nsp-bounces@puck.nether.net on behalf of Sherwin Ang<BR>
Sent: Sun 12/7/2008 11:46<BR>
To: redback-nsp@puck.nether.net<BR>
Subject: [rbak-nsp] SE-400 IP Pool Help<BR>
<BR>
Hello Redback List,<BR>
<BR>
i've added a new IP Pool to our SE-400 using this configuration:<BR>
<BR>
interface IPPOOL<BR>
ip address 200.96.0.1/30<BR>
!<BR>
interface POOL multibind lastresort<BR>
ip unnumbered IPPOOL<BR>
ip pool 200.96.96.0/19<BR>
ip pool 200.96.204.0/22<BR>
ip pool 200.96.252.0/22<BR>
<BR>
subscriber default<BR>
ip address pool name POOL<BR>
timeout idle 10<BR>
ppp mtu 1492<BR>
<BR>
Everything works great with regards to the Pool on our PPPoE but the<BR>
problem now is how the routes are redistributed and aggregated on our<BR>
BGP.<BR>
<BR>
I have this configuration to aggregate and redistribute the routes.<BR>
<BR>
router bgp vpn<BR>
address-family ipv4 unicast<BR>
export route-target 999:4<BR>
import route-target 999:4<BR>
redistribute connected<BR>
redistribute subscriber address<BR>
redistribute static<BR>
aggregate-address 200.96.96.0/19 summary-only<BR>
aggregate-address 200.96.204.0/22 summary-only<BR>
aggregate-address 200.96.252.0/22 summary-only<BR>
<BR>
it looks correct but when i take a look at the BGP peer's routing<BR>
table, it's getting a lot of /32's from the subscriber pool. i now<BR>
have like 8,000+ of them and growing. The routes are not advertised<BR>
without redistribute subscriber. I tried putting a route-map and a<BR>
prefix-filter to match only the supernets (/19's,/22's) but since it's<BR>
still sending /32's, it won't match.<BR>
<BR>
I hope someone can point me to the right direction.<BR>
<BR>
Thank you.<BR>
<BR>
-Sherwin<BR>
_______________________________________________<BR>
redback-nsp mailing list<BR>
redback-nsp@puck.nether.net<BR>
<A HREF="https://puck.nether.net/mailman/listinfo/redback-nsp">https://puck.nether.net/mailman/listinfo/redback-nsp</A><BR>
<BR>
</FONT>
</P>
</BODY>
</HTML>