[c-nsp] Issue with advertising host addresses in BGP

Alex Foster afoster at gammatelecom.com
Wed Mar 22 11:26:08 EST 2006


Hi All,

Trying to advertise some host addresses to an upstream provider using a
specific metric.  The addresses are hosts on a directly connected
network (VLAN411).  I don't see the addresses in the advertised-routes
to the peer - is there something I have missed.  

interface Vlan411
 ip vrf forwarding test
 ip address 88.x.y.252 255.255.255.248
!
!
router bgp 2222
 no synchronization
 bgp router-id w.x.y.z
 bgp log-neighbor-changes
 bgp dampening
 no auto-summary
 !
 address-family ipv4 vrf test
 network 88.x.y.249 mask 255.255.255.255
 network 88.x.y.250 mask 255.255.255.255
 neighbor radius-session peer-group
 neighbor radius-session remote-as 1111
 neighbor radius-session description xxxx
 neighbor radius-session password xxxx
 neighbor radius-session version 4
 neighbor radius-session activate
 neighbor radius-session remove-private-as
 neighbor radius-session soft-reconfiguration inbound
 neighbor radius-session route-map radius-out out
 neighbor 88.x.y.234 peer-group radius-session
 !!!additional config omitted!!!
!
ip route vrf test 83.245.6.248 255.255.255.248 Null0
!
ip prefix-list radius-out seq 10 permit 88.x.y.249/32
ip prefix-list radius-out seq 15 permit 88.x.y.250/32
ip prefix-list radius-out seq 20 deny 0.0.0.0/0 le 32
!
route-map radius-out permit 10
 match ip address prefix-list radius-out
 set metric 100
!

Regards

Alex



The information in this e-mail and any attachments is confidential and may be subject to legal professional privilege. It is intended solely for the attention and use of the named addressee(s). If you are not the intended recipient, or person responsible for delivering this information to the intended recipient, please notify the sender immediately. Unless you are the intended recipient or his/her representative you are prohibited from, and therefore must not, read, copy, distribute, use or retain this message or any part of it. The views expressed in this e-mail may not represent those of Gamma Telecom.

This message has been scanned for viruses by MailController



More information about the cisco-nsp mailing list