RE: [nsp] 2924/linux vlan

From: Andy Harding (aharding@verio.net)
Date: Mon Apr 08 2002 - 17:35:55 EDT


Kathleen Ronay wrote on 08 April 2002:
>
> Having trouble configuring a vlan that will enable a Linux server and
> our 7200 router to communicate through a cisco 2924.
>
> Linux ---- Cisco2924 ---- Cisco7200
>
> I am hoping it is simply a configuration error. Any ideas woud be very
> helpful.
>
> Cisco2924# sh run
> interface FastEthernet0/15
> switchport access vlan 127
> !
> interface FastEthernet0/19
> switchport multi vlan 1,127-129
> switchport mode multi

try:

interface FastEthernet0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk

using "switchport multi" just overlaps vlans - & hence broadcast domains -
on regular ethernet encapsulation - this is at best ugly

if you need to limit the vlans permitted on a trunk then try:

switch(config-if)#switchport trunk allowed vlan ?
  WORD VLAN IDs of the allowed VLANs when this port is in trunking mode
  add add VLANs to the current list
  all all VLANs
  except all VLANs except the following
  remove remove VLANs from the current list

> I can see both MAC addresses:
> Cisco2924#sh mac-address-table | i 127
> 0004.6df0.a000 Dynamic 127 FastEthernet0/19
> 0030.4811.3236 Dynamic 127 FastEthernet0/15
>
> The 7200 router:
> interface FastEthernet0/0.1
> encapsulation dot1Q 127
> ip address 192.168.20.1 255.255.255.0
> !

router config looks good

> The redhat server has the correct ip and subnet mask, but reports
> the 7200
> router ip (192.168.20.1) as unreachable.
>
> Any ideas?
>
> Thanks,
>
> -Kat
>
>



This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:13:40 EDT