I do just that with a private LAN type product.
Create your sub-interfaces.
Create a VRF ad assign RD and RT (Route distinguished and target - I used
the same number as the 802.1q VLAN)
And hook the Interfaces to the VRF, re-enter the IP addressing (VRF's always
take the IP's out)
Add some routing to the VRF and wayhey... it works great. Just not on a
2600/3600 for some reason.
Each VRF is isolated from the root device and each other VRF.
Here's a sample-config.
ip vrf Customer1
rd 100:100
route-target export 100:100
route-target import 100:100
!
ip vrf Customer2
rd 101:101
route-target export 101:101
route-target import 101:101
!
interface Serial1/0/1:0
ip vrf forwarding Customer1
ip address 10.44.100.1 255.255.255.252
no ip redirects
no ip proxy-arp
encapsulation ppp
!
interface Serial1/0/2:0
ip vrf forwarding Customer2
ip address 172.168.31.1 255.255.255.252
no ip redirects
no ip proxy-arp
!
interface FastEthernet2/0.100
encapsulation isl 100
ip vrf forwarding Customer1
ip address 10.44.50.1 255.255.255.0
no ip redirects
no ip proxy-arp
!
interface FastEthernet2/0.101
encapsulation isl 101
ip vrf forwarding Customer2
ip address 172.168.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
!
router ospf 1 vrf Customer1
log-adjacency-changes
redisribute connected subnets
network 10.44.50.0 0.0.0.255 area 0.0.0.0
network 10.44.100.0 0.0.0.3 area 0.0.0.0
!
ip classless
ip route vrf Customer2 172.16.0.0 255.255.0.0 172.168.31.2
Hope this helps.
Cheers
Jonathan
-----Original Message-----
From: Mark McSweeny [mailto:MarkM@interconnect.co.nz]
Sent: 20 April 2001 08:20
To: cisco-nsp@puck.nether.net
Subject: [nsp] Mapping MPLS VPN to a 802.1q VLAN
Hi folks,
Was wondering if anyone had a sample config to get traffic to come
into the router on MPLS VPN on ATM and out onto a 802.1q VLAN on the
fastethernet.
Don't really want to use route maps.
Best Regards
Mark McSweeny
######################################################################
Attention:
This e-mail message is privileged and confidential. If you are not the
intended recipient please delete the message and notify the sender.
Any views or opinions presented are solely those of the author.
######################################################################
**********************************************************************
COLT Telecommunications
Registered in England No. 2452736
Registered Office: Bishopsgate Court, 4 Norton Folgate, London E1 6DQ
Tel. 020 7390 3900
This message is subject to and does not create or vary any contractual
relationship between COLT Telecommunications, its subsidiaries or
affiliates ("COLT") and you. Internet communications are not secure
and therefore COLT does not accept legal responsibility for the
contents of this message. Any view or opinions expressed are those of
the author. The message is intended for the addressee only and its
contents and any attached files are strictly confidential. If you have
received it in error, please telephone the number above. Thank you.
**********************************************************************
This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:12:35 EDT